Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

device returns server error when schema omitted #17

Closed
entrez opened this issue Oct 10, 2019 · 0 comments · Fixed by #20

Comments

@entrez
Copy link
Owner

commented Oct 10, 2019

when I have used curl to contact my roku boxes prior to today, the results have been the same no matter whether the address was written as ${ROKU_IP}/plugin_package or http://${ROKU_IP}/plugin_package. starting today, however, (or potentially even earlier, since I haven't sideloaded a new app in the ~two days before this) curl fails to successfully contact the device unless the schema is included in the address or the port is explicitly specified. this means that the installation and packaging commands in this plugin are not working at all for me.

I don't know if this is due to an update to the roku OS or something else (could even be related to macos 10.15 I guess??), but the fix is pretty easy—just prepend http:// before the device IP when installing or packaging a channel.

@entrez entrez self-assigned this Oct 10, 2019
@entrez entrez added the bug label Oct 10, 2019
@entrez entrez closed this in #20 Oct 10, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.