New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix the CI Build #58

Merged
merged 4 commits into from Jan 4, 2019

Conversation

Projects
None yet
2 participants
@orien
Copy link
Member

orien commented Jan 4, 2019

Since Bundler 2.0 was released, our build has failed:

image

In our CI we install the latest version of Bundler (2.0.1), but our gemspec specifies we must use ~> 1.10 which excludes version 2.

To fix this:

  • remove the constraint on the Bundler version from the gemspec
  • ensure the latest version of Rubygems is installed, and
  • remove Ruby 2.2 from the build matrix (Bundler 2.0 is not available on this version of Ruby)

image

@orien orien force-pushed the orien/bundler-2.0 branch from ab1c89a to 9703ee3 Jan 4, 2019

@orien orien merged commit 2babb5c into master Jan 4, 2019

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details

@orien orien deleted the orien/bundler-2.0 branch Jan 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment