New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Test on latest version of Rubygems and Bundler #271

Merged
merged 2 commits into from Jan 4, 2019

Conversation

Projects
None yet
2 participants
@orien
Copy link
Member

orien commented Jan 3, 2019

And loosen constraints to allow Stack Master developers to use the newly released Bundler 2.0! https://bundler.io/blog/2019/01/03/announcing-bundler-2.html#

@@ -30,7 +30,7 @@ Gem::Specification.new do |spec|
spec.required_ruby_version = ">= 2.1.0"
spec.platform = gem_platform

spec.add_development_dependency "bundler", "~> 1.5"
spec.add_development_dependency "bundler"

This comment has been minimized.

@patrobinson

patrobinson Jan 3, 2019

Contributor

Should we just change this to > 1.5 to avoid having to support earlier versions?

This comment has been minimized.

@orien

orien Jan 3, 2019

Member

It's just a development dependency: this change won't influence the released gem.

I think there's only a minuscule chance that there's a Stack Master developer with such a old version of Bundler installed.

@orien orien changed the title Remove version constraint on Bundler Test on latest version of Rubygems and Bundler Jan 3, 2019

@patrobinson
Copy link
Contributor

patrobinson left a comment

Thanks!

@orien orien merged commit eb9874a into master Jan 4, 2019

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details

@orien orien deleted the orien/bundler branch Jan 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment