New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Test against Ruby 2.6 and RubyGems 3.0 #60

Closed
wants to merge 2 commits into
base: master
from

Conversation

Projects
None yet
2 participants
@johnsyweb
Copy link
Member

johnsyweb commented Jan 3, 2019

Context

https://www.ruby-lang.org/en/news/2018/12/25/ruby-2-6-0-released/

I had to change the rubygems specification to get Bundler to install the dependencies.

Change

  • Add 2.6.0 to the list of Rubies to build against.

johnsyweb added some commits Jan 3, 2019

@johnsyweb

This comment has been minimized.

Copy link
Member

johnsyweb commented Jan 3, 2019

@@ -4,6 +4,7 @@ rvm:
- 2.3.8
- 2.4.5
- 2.5.3
- 2.6.0
before_install:
- gem update --system
- gem install bundler

This comment has been minimized.

@orien

orien Jan 4, 2019

Member

We could temporarily change this to install Bundler version 1, until the next bundler-audit version is released. rubysec/bundler-audit#203

- gem install bundler --version 1.17.3

This comment has been minimized.

@orien

orien Jan 10, 2019

Member

Actually, given the new Rubygems includes Bundler, we don't need this line.

@johnsyweb

This comment has been minimized.

Copy link
Member

johnsyweb commented Jan 10, 2019

Will redo.

@johnsyweb johnsyweb closed this Jan 10, 2019

@johnsyweb johnsyweb deleted the paj/ruby-2.6 branch Jan 10, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment