Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cant run Jekyll 4.0 return error =>`find_directory_manifest': wrong number of arguments (given 2, expected 1) #622

Open
reatlat opened this issue Oct 13, 2019 · 3 comments

Comments

@reatlat
Copy link

@reatlat reatlat commented Oct 13, 2019

  • I tried updating to the latest version
    • I can't, there is an issue
    • This is about an < latest
      • I understand older versions may be unsupported
  • I Am on Windows
    • Ubuntu Bash on Windows
    • Fedora Bash on Windows
    • Other Bash on Windows
  • I Am on Linux
    • Ubuntu
    • Fedora
    • CentOS
    • Redhat
    • Debian
  • I am on macOS 10.13
  • I am on macOS 10.14
  • I am on macOS 10.15
  • I'm on Docker
    • I understand Docker may be unsupported

Description

I run clean Jekyll 4.0 with assets and can't do it for reason in this file
/usr/local/bundle/gems/jekyll-assets-3.0.12/lib/jekyll/assets/manifest.rb:58:in `find_directory_manifest': wrong number of arguments (given 2, expected 1) (ArgumentError)

Is it my local issue, or new Jekyl not supported?

@rgant

This comment has been minimized.

Copy link

@rgant rgant commented Oct 15, 2019

I believe this is actually an issue with a change in sprockets 4.0.0:

ArgumentError: wrong number of arguments (given 2, expected 1)
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-assets-3.0.12/lib/jekyll/assets/manifest.rb:58:in `find_directory_manifest'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/sprockets-4.0.0/lib/sprockets/manifest.rb:56:in `initialize'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-assets-3.0.12/lib/jekyll/assets/manifest.rb:29:in `initialize'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-assets-3.0.12/lib/jekyll/assets/env.rb:48:in `new'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-assets-3.0.12/lib/jekyll/assets/env.rb:48:in `initialize'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-assets-3.0.12/lib/jekyll/assets.rb:24:in `new'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-assets-3.0.12/lib/jekyll/assets.rb:24:in `block in <top (required)>'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-3.8.6/lib/jekyll/hooks.rb:103:in `block in trigger'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-3.8.6/lib/jekyll/hooks.rb:102:in `each'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-3.8.6/lib/jekyll/hooks.rb:102:in `trigger'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-3.8.6/lib/jekyll/site.rb:166:in `read'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-3.8.6/lib/jekyll/commands/doctor.rb:25:in `process'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-3.8.6/lib/jekyll/commands/doctor.rb:17:in `block (2 levels) in init_with_program'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `block in execute'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `each'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `execute'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/mercenary-0.3.6/lib/mercenary/program.rb:42:in `go'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/mercenary-0.3.6/lib/mercenary.rb:19:in `program'
  /Users/rgant/.rbenv/versions/2.6.5/lib/ruby/gems/2.6.0/gems/jekyll-3.8.6/exe/jekyll:15:in `<top (required)>'
  /Users/rgant/.rbenv/versions/2.6.5/bin/jekyll:23:in `load'
  /Users/rgant/.rbenv/versions/2.6.5/bin/jekyll:23:in `<top (required)>'
@rgant

This comment has been minimized.

Copy link

@rgant rgant commented Oct 15, 2019

Probably a duplicate of #589

@rgant

This comment has been minimized.

Copy link

@rgant rgant commented Oct 15, 2019

Fixed this by forcing the earlier version:

gem "sprockets", "~> 3.7"
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.