Permalink
Browse files

Fixed a compatibility issue with libnotify 0.7 (attach-widget warnings)

This fixes warnings like these: GLib-GObject-WARNING **:
g_object_set_valist: object class `MNPopup' has no property named
`attach-widget'

Patch by Erik van Pienbroek
http://pkgs.fedoraproject.org/cgit/mail-notification.git/commit/?id=bf59f4eab091c71c4ee82ef881a0ba5d8e505262
  • Loading branch information...
1 parent 33ea094 commit 0815ae4970d9f5b96c1ee94c57332635cefbc262 @epienbroek committed Aug 21, 2012
Showing with 2 additions and 0 deletions.
  1. +2 −0 src/mn-popup.gob
View
2 src/mn-popup.gob
@@ -51,10 +51,12 @@ class MN:Popup from Notify:Notification
"icon-name", "stock_mail",
NULL);
+#if !NOTIFY_CHECK_VERSION(0,7,0)
if (mn_conf_get_enum_value(MN_TYPE_POPUP_POSITION, MN_CONF_POPUPS_POSITION) == MN_POPUP_POSITION_ATTACHED) {
self_wait_for_icon_to_become_ready(self);
g_object_set(self, "attach-widget", mn_shell->icon, NULL);
}
+#endif
g_string_free(body, TRUE);

0 comments on commit 0815ae4

Please sign in to comment.