Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Evidently forgot to run automated testing after last update

  • Loading branch information...
commit 3c3c9679e87c53a513c1aff2522c425f90a44f59 1 parent 2acb5d1
@eric1234 authored
Showing with 39 additions and 41 deletions.
  1. +37 −39 Gemfile.lock
  2. +1 −1  lib/test_engine.rb
  3. +1 −1  test_engine.gemspec
View
76 Gemfile.lock
@@ -1,74 +1,72 @@
PATH
remote: .
specs:
- test_engine (0.0.1)
+ test_engine (0.0.3)
bundler
rails (> 3)
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.1.3)
- actionpack (= 3.1.3)
- mail (~> 2.3.0)
- actionpack (3.1.3)
- activemodel (= 3.1.3)
- activesupport (= 3.1.3)
+ actionmailer (3.2.0)
+ actionpack (= 3.2.0)
+ mail (~> 2.4.0)
+ actionpack (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- i18n (~> 0.6)
- rack (~> 1.3.5)
+ journey (~> 1.0.0)
+ rack (~> 1.4.0)
rack-cache (~> 1.1)
- rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.0.3)
- activemodel (3.1.3)
- activesupport (= 3.1.3)
+ sprockets (~> 2.1.2)
+ activemodel (3.2.0)
+ activesupport (= 3.2.0)
builder (~> 3.0.0)
- i18n (~> 0.6)
- activerecord (3.1.3)
- activemodel (= 3.1.3)
- activesupport (= 3.1.3)
- arel (~> 2.2.1)
+ activerecord (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
+ arel (~> 3.0.0)
tzinfo (~> 0.3.29)
- activeresource (3.1.3)
- activemodel (= 3.1.3)
- activesupport (= 3.1.3)
- activesupport (3.1.3)
+ activeresource (3.2.0)
+ activemodel (= 3.2.0)
+ activesupport (= 3.2.0)
+ activesupport (3.2.0)
+ i18n (~> 0.6)
multi_json (~> 1.0)
- arel (2.2.1)
+ arel (3.0.0)
builder (3.0.0)
erubis (2.7.0)
hike (1.2.1)
i18n (0.6.0)
- json (1.6.4)
- mail (2.3.0)
+ journey (1.0.0)
+ json (1.6.5)
+ mail (2.4.1)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.17.2)
multi_json (1.0.4)
polyglot (0.3.3)
- rack (1.3.6)
+ rack (1.4.1)
rack-cache (1.1)
rack (>= 0.4)
- rack-mount (0.8.3)
- rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.3)
- actionmailer (= 3.1.3)
- actionpack (= 3.1.3)
- activerecord (= 3.1.3)
- activeresource (= 3.1.3)
- activesupport (= 3.1.3)
+ rails (3.2.0)
+ actionmailer (= 3.2.0)
+ actionpack (= 3.2.0)
+ activerecord (= 3.2.0)
+ activeresource (= 3.2.0)
+ activesupport (= 3.2.0)
bundler (~> 1.0)
- railties (= 3.1.3)
- railties (3.1.3)
- actionpack (= 3.1.3)
- activesupport (= 3.1.3)
+ railties (= 3.2.0)
+ railties (3.2.0)
+ actionpack (= 3.2.0)
+ activesupport (= 3.2.0)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
@@ -76,7 +74,7 @@ GEM
rake (0.9.2.2)
rdoc (3.12)
json (~> 1.4)
- sprockets (2.0.3)
+ sprockets (2.1.2)
hike (~> 1.2)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
View
2  lib/test_engine.rb
@@ -41,7 +41,7 @@ def install_generate
# Define the "setup" task that will load any engine migrations and seed data
def install_setup
task 'test:engine:setup' => 'test:engine:generate' do
- unless app_path.exist?
+ unless app_path.join('db/schema.rb').exist?
clean_sh 'bundle install --quiet', {'BUNDLE_GEMFILE' => gemfile_path}, true
rake "railties:install:migrations"
rake "db:migrate", 'RAILS_ENV' => 'test'
View
2  test_engine.gemspec
@@ -1,6 +1,6 @@
Gem::Specification.new do |s|
s.name = 'test_engine'
- s.version = '0.0.3'
+ s.version = '0.0.4'
s.author = 'Eric Anderson'
s.email = 'eric@pixelwareinc.com'
s.add_dependency 'rails', '> 3'
Please sign in to comment.
Something went wrong with that request. Please try again.