Skip to content
This repository
Browse code

change gem name, release v1.0.alpha.0

  • Loading branch information...
commit 0a05a7eb9e9a651c46b02fb810802cd578c04bf2 1 parent 010b42f
Eric M. Suzanne authored May 06, 2012
3  .gitignore
... ...
@@ -1,2 +1,3 @@
1  
-compass-susy-plugin-*.gem
  1
+susy-*.gem
  2
+*.DS_Store
2 3
 *~
10  Manifest
@@ -2,13 +2,19 @@ CHANGELOG.mkdn
2 2
 LICENSE.txt
3 3
 Manifest
4 4
 README.mkdn
  5
+REFERENCE.mkdn
5 6
 Rakefile
6 7
 VERSION
7  
-compass-susy-plugin.gemspec
8 8
 lib/susy.rb
9 9
 sass/_susy.scss
  10
+sass/susy/_background.scss
  11
+sass/susy/_functions.scss
10 12
 sass/susy/_grid.scss
11  
-sass/susy/_susy.scss
  13
+sass/susy/_margin.scss
  14
+sass/susy/_media.scss
  15
+sass/susy/_padding.scss
  16
+sass/susy/_settings.scss
  17
+susy.gemspec
12 18
 templates/project/_base.scss
13 19
 templates/project/manifest.rb
14 20
 templates/project/screen.scss
2  README.mkdn
Source Rendered
@@ -24,7 +24,7 @@ system I know of that could never exist as a library apart from Sass.
24 24
 Installation
25 25
 ------------
26 26
 
27  
-    sudo gem install compass-susy-plugin
  27
+    sudo gem install susy
28 28
     compass create <project name> -r susy -u susy
29 29
 
30 30
 Grid Basics
5  Rakefile
@@ -4,14 +4,13 @@ require 'sass'
4 4
 begin
5 5
   require 'echoe'
6 6
 
7  
-  Echoe.new('compass-susy-plugin', open('VERSION').read) do |p|
  7
+  Echoe.new('susy', open('VERSION').read) do |p|
8 8
     p.summary = "A responsive grid system plugin for Compass."
9 9
     p.description = "Responsive web design with grids the quick and reliable way."
10 10
     p.url = "http://susy.oddbird.net/"
11 11
     p.author = "Eric Meyer"
12 12
     p.email = "eric@oddbird.net"
13  
-    p.dependencies = ["compass >=0.11.1"]
14  
-    p.has_rdoc = false
  13
+    p.dependencies = ["compass >=0.13.alpha.0"]
15 14
   end
16 15
 
17 16
 rescue LoadError => boom
2  VERSION
... ...
@@ -1 +1 @@
1  
-0.9
  1
+1.0.alpha.0
32  susy.gemspec
... ...
@@ -0,0 +1,32 @@
  1
+# -*- encoding: utf-8 -*-
  2
+
  3
+Gem::Specification.new do |s|
  4
+  s.name = "susy"
  5
+  s.version = "1.0.alpha.0"
  6
+
  7
+  s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
  8
+  s.authors = ["Eric Meyer"]
  9
+  s.date = "2012-05-06"
  10
+  s.description = "Responsive web design with grids the quick and reliable way."
  11
+  s.email = "eric@oddbird.net"
  12
+  s.extra_rdoc_files = ["CHANGELOG.mkdn", "LICENSE.txt", "README.mkdn", "lib/susy.rb"]
  13
+  s.files = ["CHANGELOG.mkdn", "LICENSE.txt", "Manifest", "README.mkdn", "REFERENCE.mkdn", "Rakefile", "VERSION", "lib/susy.rb", "sass/_susy.scss", "sass/susy/_background.scss", "sass/susy/_functions.scss", "sass/susy/_grid.scss", "sass/susy/_margin.scss", "sass/susy/_media.scss", "sass/susy/_padding.scss", "sass/susy/_settings.scss", "susy.gemspec", "templates/project/_base.scss", "templates/project/manifest.rb", "templates/project/screen.scss"]
  14
+  s.homepage = "http://susy.oddbird.net/"
  15
+  s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "Susy", "--main", "README.mkdn"]
  16
+  s.require_paths = ["lib"]
  17
+  s.rubyforge_project = "susy"
  18
+  s.rubygems_version = "1.8.15"
  19
+  s.summary = "A responsive grid system plugin for Compass."
  20
+
  21
+  if s.respond_to? :specification_version then
  22
+    s.specification_version = 3
  23
+
  24
+    if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
  25
+      s.add_runtime_dependency(%q<compass>, [">= 0.13.alpha.0"])
  26
+    else
  27
+      s.add_dependency(%q<compass>, [">= 0.13.alpha.0"])
  28
+    end
  29
+  else
  30
+    s.add_dependency(%q<compass>, [">= 0.13.alpha.0"])
  31
+  end
  32
+end

0 notes on commit 0a05a7e

Please sign in to comment.
Something went wrong with that request. Please try again.