Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Forgot to commit package.json + builder adjustment

  • Loading branch information...
commit f0ce6e81205a8f1cfa3bf5fcee61e5270b2185c4 1 parent 3afe889
@3rd-Eden 3rd-Eden authored
Showing with 9 additions and 7 deletions.
  1. +5 −6 bin/builder.js
  2. +4 −1 package.json
View
11 bin/builder.js
@@ -10,8 +10,7 @@
var fs = require('fs')
, socket = require('../lib/io')
- , uglyfyParser = require('../lib/vendor/uglifyjs/lib/parse-js')
- , uglyfyAst = require('../lib/vendor/uglifyjs/lib/process');
+ , uglify = require('uglify-js');
/**
* License headers.
@@ -187,11 +186,11 @@ var builder = module.exports = function(){
// check if we need to process it any further
if (settings.minify){
- var ast = uglyfyParser.parse(code);
- ast = uglyfyAst.ast_mangle(ast);
- ast = uglyfyAst.ast_squeeze(ast);
+ var ast = uglify.parser.parse(code);
+ ast = uglify.uglify.ast_mangle(ast);
+ ast = uglify.uglify.ast_squeeze(ast);
- code = production + uglyfyAst.gen_code(ast);
+ code = production + uglify.uglify.gen_code(ast);
}
callback(error, code);
View
5 package.json
@@ -17,12 +17,15 @@
"type": "git"
, "url": "https://github.com/LearnBoost/Socket.IO.git"
}
+ , "dependencies": {
+ "uglify-js": "1.0.3"
+ }
, "devDependencies": {
"expresso": "0.7.7"
, "express": "2.3.11"
, "jade": "0.12.1"
, "stylus": "0.13.3"
- , "socket.io": "0.7.3"
+ , "socket.io": "0.7.6"
, "socket.io-client": "0.7.1"
}
, "engines": { "node": ">= 0.4.0" }
Please sign in to comment.
Something went wrong with that request. Please try again.