Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

alex == 3.0.1 constraint causes problems #19

Closed
luite opened this Issue Oct 15, 2012 · 2 comments

Comments

Projects
None yet
2 participants

luite commented Oct 15, 2012

if someone does cabal install alex he'll get version 3.0.2 from hackage. Language-javascript will fail to install with this. Is this intentional?

Collaborator

alanz commented Oct 15, 2012

Well, I was updating it and the compilation breaks with 3.0.2

Strictly speaking Alex is only required for development, if the lexer changes, since the output of Alex is included in the distributed source.

Perhaps I should remove the constraint and note it for development?

Alan

luite commented Oct 15, 2012

Ah that sounds annoying. I think 3.0.1 doesn't build with GHC 7.6, so that would require users with only that version to install another GHC. Removing it from the requirements would certainly make it easier for those people.

@alanz alanz closed this in 0b04a58 Oct 15, 2012

alanz added a commit that referenced this issue Jul 29, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment