Skip to content
Browse files

Fetch firebird from the correct repository

The firebird that is in the regular apt repository contains a bug,
therefore fetch firebird 2.5.1 from the ppa:mapopa repository.
https://help.ubuntu.com/community/Firebird2.5

relates to #43
  • Loading branch information...
1 parent 31ff938 commit eef3a249b620c21aa2e59e5384b16fb6fff3bed2 @erikfrerejean committed Apr 17, 2012
Showing with 14 additions and 1 deletion.
  1. +14 −1 ci_environment/firebird/recipes/default.rb
View
15 ci_environment/firebird/recipes/default.rb
@@ -17,8 +17,21 @@
# limitations under the License.
#
+# Due to a bug in firebird 2.5, it is needed to fetch 2.5.1 from the ppa repository
+# https://help.ubuntu.com/community/Firebird2.5
+apt_repository "mapopa" do
+ uri "http://ppa.launchpad.net/mapopa/ppa/ubuntu/"
+ distribution node['lsb']['codename']
+ components ["main"]
+
+ key "EF648708"
+ keyserver "keyserver.ubuntu.com"
+
+ action :add
+end
+
package "firebird2.5-super" do
- action :upgrade
+ action :install
end
template "/etc/firebird/2.5/SYSDBA.password" do

0 comments on commit eef3a24

Please sign in to comment.
Something went wrong with that request. Please try again.