Browse files

The problem all along is that thor runner was not loading thor and th…

…or/group. This was fixed. Neither Thor or Thor::Group are autoloaded, you need to require them by hand. The good news is, if you just require 'thor', you will get only Thor, if you require only 'thor/group', you will get only Thor::Group.
  • Loading branch information...
josevalim committed Feb 11, 2010
1 parent c7bfbdd commit 5e713a0c1d3c84738643ddc7e1b8e7fe863127d1
Showing with 4 additions and 3 deletions.
  1. +0 −2 bin/thor
  2. +4 −1 lib/thor/runner.rb
@@ -1,8 +1,6 @@
#!/usr/bin/env ruby
# -*- mode: ruby -*-
-require 'thor'
require 'thor/runner'
$thor_runner = true
@@ -1,5 +1,8 @@
-require 'fileutils'
+require 'thor'
+require 'thor/group'
require 'thor/core_ext/file_binary_read'
+require 'fileutils'
require 'open-uri'
require 'yaml'
require 'digest/md5'

0 comments on commit 5e713a0

Please sign in to comment.