Permalink
Browse files

update ref to lsp4j 0.1.0 and xtend 2.11

  • Loading branch information...
1 parent 8b0abc5 commit 0e4f8f25c24835691ac0d8507e0ce47b96df1ebd @vladdu vladdu committed Feb 2, 2017
@@ -30,9 +30,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.erlide.libs.annotations;bundle-version="1.0.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Eclipse-ExtensibleAPI: true
@@ -11,9 +11,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.erlide.core,
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Export-Package: org.erlide.branding
Bundle-Vendor: %vendor
Bundle-ClassPath: .
@@ -31,9 +31,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.erlide.libs.annotations;bundle-version="1.0.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ClassPath: .
@@ -10,8 +10,8 @@ Require-Bundle: org.eclipse.core.runtime,
org.erlide.libs;bundle-version="1.17.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.erlide.cover.api
@@ -18,9 +18,9 @@ Require-Bundle: org.eclipse.core.runtime,
org.erlide.libs2;bundle-version="[1.16.1,2.0.0)",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.erlide.cover.constants,
@@ -22,9 +22,9 @@ Require-Bundle: org.eclipse.ui,
org.erlide.ui,
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.erlide.cover.ui;x-internal:=true,
@@ -9,7 +9,7 @@ Export-Package: org.eclipse.jdt.annotation,
Require-Bundle: org.erlide.libs;bundle-version="1.16.2",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
@@ -17,6 +17,6 @@ Export-Package: org.fishwife.jrugged,
org.incava.util.diff
Require-Bundle: com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
@@ -11,7 +11,7 @@ Export-Package: com.ericsson.otp.erlang,
Require-Bundle: org.erlide.libs;bundle-version="1.16.1",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
@@ -31,10 +31,10 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.erlide.libs.annotations;bundle-version="1.0.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0",
- org.eclipse.lsp4j;bundle-version="0.1.0",
- org.eclipse.lsp4j.jsonrpc;bundle-version="0.1.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
+ org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
+ org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.erlide.engine.ModelApiActivator
@@ -16,11 +16,11 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
org.erlide.backend,
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0",
- org.eclipse.lsp4j;bundle-version="0.1.0",
- org.eclipse.lsp4j.jsonrpc;bundle-version="0.1.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
+ org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
+ org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.erlide.engine.internal;x-internal:=true,
@@ -39,12 +39,12 @@
<repository>
<id>xtend</id>
<layout>p2</layout>
- <url>http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.10.0</url>
+ <url>http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.11.0</url>
</repository>
<repository>
<id>lsp4j</id>
<layout>p2</layout>
- <url>http://services.typefox.io/open-source/jenkins/job/lsp4j/job/master/lastSuccessfulBuild/artifact/build/p2-repository/</url>
+ <url>http://download.eclipse.org/lsp4j/updates/releases/0.1.0/</url>
</repository>
<repository>
<id>handly</id>
@@ -291,7 +291,7 @@
<plugin>
<groupId>org.eclipse.xtend</groupId>
<artifactId>xtend-maven-plugin</artifactId>
- <version>2.9.0</version>
+ <version>2.11.0</version>
<executions>
<execution>
<goals>
@@ -10,9 +10,9 @@ Require-Bundle: org.erlide.libs;bundle-version="1.16.2",
org.erlide.libs2;bundle-version="[1.16.1,2.0.0)",
org.erlide.libs.annotations;bundle-version="1.0.0";resolution:=optional,
com.google.guava;bundle-version="15.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0",
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
javax.inject;bundle-version="1.0.0"
Export-Package: org.erlide.runtime,
org.erlide.runtime.api,
@@ -15,11 +15,11 @@ Require-Bundle: org.eclipse.jface.text,
org.erlide.libs2;bundle-version="1.17.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0",
- org.eclipse.lsp4j;bundle-version="0.1.0",
- org.eclipse.lsp4j.jsonrpc;bundle-version="0.1.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
+ org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
+ org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)"
Export-Package: org.eclipse.languageserver,
org.erlide.server
Import-Package: org.eclipse.osgi.util
@@ -12,10 +12,13 @@
<bundle id="com.google.guava" version="15.0.0.v201403281430">
<category name="3pp_deps"/>
</bundle>
- <bundle id="org.eclipse.xtend.lib.macro" version="2.10.0.v201605250459">
+ <bundle id="com.google.gson" version="2.7.0.v20161205-1708">
+ <category name="3pp_deps"/>
+ </bundle>
+ <bundle id="org.eclipse.xtend.lib.macro" version="2.11.0.v20170124-1424">
<category name="3pp_deps"/>
</bundle>
- <bundle id="org.eclipse.xtext.xbase.lib" version="2.10.0.v201605250459">
+ <bundle id="org.eclipse.xtext.xbase.lib" version="2.11.0.v20170124-1424">
<category name="3pp_deps"/>
</bundle>
<bundle id="javax.inject" version="1.0.0.v20091030">
@@ -24,17 +27,17 @@
<bundle id="com.google.gson" version="2.7.0.v20161205-1708">
<category name="3pp_deps"/>
</bundle>
- <bundle id="org.eclipse.xtend.lib" version="2.10.0.v201605250459">
+ <bundle id="org.eclipse.xtend.lib" version="2.11.0.v20170124-1424">
<category name="3pp_deps"/>
</bundle>
- <bundle id="org.eclipse.lsp4j" version="0.0.0">
+ <bundle id="org.eclipse.lsp4j" version="0.1.0">
<category name="3pp_deps"/>
</bundle>
- <bundle id="org.eclipse.lsp4j.jsonrpc" version="0.0.0">
+ <bundle id="org.eclipse.lsp4j.jsonrpc" version="0.1.0">
<category name="3pp_deps"/>
</bundle>
<category-def name="erlide" label="erlide - Erlang development tools"/>
<category-def name="extras" label="erlide - optional plugins"/>
<category-def name="3pp_deps" label="Dependencies"/>
- <repository-reference location="http://download.eclipse.org/tools/orbit/downloads/drops/R20150124073747/repository" enabled="true" />
+ <repository-reference location="http://download.eclipse.org/tools/orbit/downloads/drops/R20160221192158/repository/" enabled="true" />
</site>
@@ -15,9 +15,9 @@
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="com.google.gson" version="2.7.0.v20161205-1708"/>
-<unit id="org.eclipse.lsp4j" version="0.0.0"/>
-<unit id="org.eclipse.lsp4j.jsonrpc" version="0.0.0"/>
-<repository location="http://services.typefox.io/open-source/jenkins/job/lsp4j/job/master/lastSuccessfulBuild/artifact/build/p2-repository/"/>
+<unit id="org.eclipse.lsp4j" version="0.1.0.v20170106-1037"/>
+<unit id="org.eclipse.lsp4j.jsonrpc" version="0.1.0.v20170106-1037"/>
+<repository location="http://download.eclipse.org/lsp4j/updates/releases/0.1.0/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.handly.feature.group" version="0.6.0.v20161109-0701"/>
@@ -27,7 +27,7 @@
<unit id="org.eclipse.xtend.lib" version="0.0.0"/>
<unit id="org.eclipse.xtend.lib.macro" version="0.0.0"/>
<unit id="org.eclipse.xtext.xbase.lib" version="0.0.0"/>
-<repository location="http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.10.0/"/>
+<repository location="http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.11.0/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="com.google.guava" version="15.0.0.v201403281430"/>
@@ -28,9 +28,9 @@ Require-Bundle: org.eclipse.ui,
org.erlide.libs2;bundle-version="[1.16.1,2.0.0)",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.erlide.test_support,
@@ -13,8 +13,8 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
org.junit;bundle-version="4.11.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-ClassPath: truth-0.28.jar
Export-Package: com.google.common.truth
@@ -22,9 +22,9 @@ Require-Bundle: org.eclipse.core.runtime,
org.erlide.libs.annotations;bundle-version="1.0.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-Localization: plugin
@@ -100,11 +100,11 @@ Require-Bundle: org.eclipse.compare;bundle-version="3.5.202",
org.erlide.server,
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0",
- org.eclipse.lsp4j;bundle-version="0.1.0",
- org.eclipse.lsp4j.jsonrpc;bundle-version="0.1.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
+ org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
+ org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Eclipse-ExtensibleAPI: true
@@ -11,9 +11,9 @@ Require-Bundle: org.eclipse.core.runtime,
org.erlide.libs.annotations;bundle-version="1.0.0",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.erlide.util,
@@ -9,9 +9,9 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.ui,
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Import-Package: com.abstratt.graphviz;resolution:=optional
Export-Package: org.erlide.wrangler.refactoring.codeinspection;x-internal:=true,
org.erlide.wrangler.refactoring.codeinspection.ui;x-internal:=true,
@@ -19,7 +19,7 @@ Require-Bundle: org.eclipse.ui,
org.eclipse.core.resources,
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
@@ -25,9 +25,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.9.100,4.0.0)",
org.erlide.libs2;bundle-version="[1.16.1,2.0.0)",
com.google.guava;bundle-version="15.0.0",
javax.inject;bundle-version="1.0.0",
- org.eclipse.xtend.lib;bundle-version="2.10.0",
- org.eclipse.xtend.lib.macro;bundle-version="2.10.0",
- org.eclipse.xtext.xbase.lib;bundle-version="2.10.0"
+ org.eclipse.xtend.lib;bundle-version="2.11.0",
+ org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
+ org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
Bundle-ActivationPolicy: lazy
Export-Package:
org.erlide.wrangler.refactoring;x-internal:=true,

0 comments on commit 0e4f8f2

Please sign in to comment.