Permalink
Browse files

update lsp4j and xtend dependencies

  • Loading branch information...
vladdu committed Dec 21, 2017
1 parent 33243a7 commit 47cb82b9c972227481bfa849797b850a657454dc
Showing with 146 additions and 114 deletions.
  1. +1 −0 extras/org.erlide.jvmcheck/META-INF/MANIFEST.MF
  2. +2 −1 extras/wrangler/plugins/org.erlide.wrangler.core/META-INF/MANIFEST.MF
  3. +1 −0 extras/wrangler/plugins/org.erlide.wrangler.help/META-INF/MANIFEST.MF
  4. +5 −4 extras/wrangler/plugins/org.erlide.wrangler.refactoring.codeinspection/META-INF/MANIFEST.MF
  5. +5 −4 extras/wrangler/plugins/org.erlide.wrangler.refactoring.duplicatedcode/META-INF/MANIFEST.MF
  6. +5 −4 extras/wrangler/plugins/org.erlide.wrangler.refactoring/META-INF/MANIFEST.MF
  7. +1 −0 libs/com.ericsson.otp.jinterface/META-INF/MANIFEST.MF
  8. +1 −0 libs/com.google.truth/META-INF/MANIFEST.MF
  9. +4 −3 libs/nl.kii.util/META-INF/MANIFEST.MF
  10. +4 −3 libs/org.erlide.annotations/META-INF/MANIFEST.MF
  11. +1 −0 libs/org.fishwife.jrugged/META-INF/MANIFEST.MF
  12. +1 −0 libs/org.incava.util.diff/META-INF/MANIFEST.MF
  13. +5 −4 plugins/org.erlide.backend/META-INF/MANIFEST.MF
  14. +5 −4 plugins/org.erlide.branding/META-INF/MANIFEST.MF
  15. +5 −4 plugins/org.erlide.core/META-INF/MANIFEST.MF
  16. +5 −4 plugins/org.erlide.cover.api/META-INF/MANIFEST.MF
  17. +5 −4 plugins/org.erlide.cover.core/META-INF/MANIFEST.MF
  18. +5 −4 plugins/org.erlide.cover.ui/META-INF/MANIFEST.MF
  19. +7 −6 plugins/org.erlide.model.api/META-INF/MANIFEST.MF
  20. +1 −2 plugins/org.erlide.model.api/src/org/erlide/engine/ModelApiActivator.xtend
  21. +7 −6 plugins/org.erlide.model/META-INF/MANIFEST.MF
  22. +6 −5 plugins/org.erlide.runtime/META-INF/MANIFEST.MF
  23. +7 −6 plugins/org.erlide.server/META-INF/MANIFEST.MF
  24. +5 −4 plugins/org.erlide.test_support/META-INF/MANIFEST.MF
  25. +5 −4 plugins/org.erlide.tracing.core/META-INF/MANIFEST.MF
  26. +7 −6 plugins/org.erlide.ui/META-INF/MANIFEST.MF
  27. +5 −4 plugins/org.erlide.util/META-INF/MANIFEST.MF
  28. +2 −2 pom.xml
  29. +5 −7 releng/org.erlide.site/category.xml
  30. +10 −9 releng/org.erlide.target/org.erlide.target.target
  31. +1 −0 tests/org.erlide.backend.tests/META-INF/MANIFEST.MF
  32. +2 −1 tests/org.erlide.core.tests/META-INF/MANIFEST.MF
  33. +2 −1 tests/org.erlide.model.tests/META-INF/MANIFEST.MF
  34. +2 −1 tests/org.erlide.runtime.tests/META-INF/MANIFEST.MF
  35. +2 −1 tests/org.erlide.test_support.tests/META-INF/MANIFEST.MF
  36. +5 −4 tests/org.erlide.testing.libs/META-INF/MANIFEST.MF
  37. +2 −1 tests/org.erlide.ui.tests/META-INF/MANIFEST.MF
  38. +2 −1 tests/org.erlide.util.tests/META-INF/MANIFEST.MF
@@ -8,3 +8,4 @@ Require-Bundle: org.eclipse.ui,
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-Vendor: erlide.org Team
Export-Package: org.erlide.jvmcheck
Automatic-Module-Name: org.erlide.jvmcheck
@@ -6,4 +6,5 @@ Bundle-Version: 0.11.0.qualifier
Bundle-Vendor: UKC
Require-Bundle: org.erlide.core;bundle-version="0.32.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.wrangler.core
@@ -6,3 +6,4 @@ Bundle-Version: 0.11.0.qualifier
Bundle-Vendor: UKC
Require-Bundle: org.eclipse.help;bundle-version="[3.6.0,4.0.0)"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Automatic-Module-Name: org.erlide.wrangler.help
@@ -9,12 +9,13 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.eclipse.ui,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.abstratt.graphviz;bundle-version="[2.2.201606,3.0.0)",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Export-Package: org.erlide.wrangler.refactoring.codeinspection;x-internal:=true,
org.erlide.wrangler.refactoring.codeinspection.ui;x-internal:=true,
org.erlide.wrangler.refactoring.codeinspection.view;x-internal:=true
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.wrangler.refactoring.codeinspection
@@ -15,12 +15,13 @@ Export-Package: org.erlide.wrangler.refactoring.core.exception,
org.erlide.wrangler.refactoring.util
Import-Package: org.erlide.wrangler.refactoring.exception,
org.erlide.wrangler.refactoring.util,
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
org.eclipse.jdt.annotation;resolution:=optional
Require-Bundle: org.eclipse.ui,
org.eclipse.core.resources,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Automatic-Module-Name: org.erlide.wrangler.refactoring.duplicatedcode
@@ -24,9 +24,9 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="[3.9.100,4.0.0)",
org.erlide.runtime;bundle-version="0.32.0",
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Export-Package: org.erlide.wrangler.refactoring;x-internal:=true,
@@ -48,4 +48,5 @@ Export-Package: org.erlide.wrangler.refactoring;x-internal:=true,
Bundle-Localization: plugin
Bundle-Vendor: UKC
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.wrangler.refactoring
@@ -7,3 +7,4 @@ Bundle-Version: 1.8.0
Bundle-Vendor: Erlide project
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: com.ericsson.otp.erlang
Automatic-Module-Name: com.ericsson.otp.jinterface
@@ -8,3 +8,4 @@ Bundle-ClassPath: truth-0.28.jar
Export-Package: com.google.common.truth
Require-Bundle: com.google.guava;bundle-version="15.0.0",
org.junit;bundle-version="4.12.0"
Automatic-Module-Name: com.google.truth
@@ -9,7 +9,8 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: nl.kii.util
Require-Bundle: com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0"
Automatic-Module-Name: nl.kii.util
@@ -7,7 +7,8 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.erlide.annotations
Require-Bundle: com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0"
Automatic-Module-Name: org.erlide.annotations
@@ -15,3 +15,4 @@ Export-Package: org.fishwife.jrugged,
org.fishwife.jrugged.interval
Require-Bundle: com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0"
Automatic-Module-Name: org.fishwife.jrugged
@@ -8,3 +8,4 @@ Bundle-Vendor: Erlide project
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ClassPath: java-diff-1.1.jar
Export-Package: org.incava.util.diff
Automatic-Module-Name: org.incava.util.diff
@@ -30,12 +30,13 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.erlide.kernel.ide;bundle-version="0.113.0",
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Eclipse-ExtensibleAPI: true
Bundle-Activator: org.erlide.backend.internal.BackendActivator
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.backend
@@ -11,12 +11,13 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.erlide.core,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0"
Export-Package: org.erlide.branding
Bundle-Vendor: %vendor
Bundle-ClassPath: .
Bundle-Localization: plugin
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.branding
@@ -29,13 +29,14 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.12.0",
org.erlide.util,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ClassPath: .
Eclipse-ExtensibleAPI: true
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.core
@@ -10,9 +10,10 @@ Require-Bundle: org.eclipse.core.runtime,
org.fishwife.jrugged,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Export-Package: org.erlide.cover.api
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.cover.api
@@ -17,9 +17,9 @@ Require-Bundle: org.eclipse.core.runtime,
org.erlide.util,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
@@ -28,4 +28,5 @@ Export-Package: org.erlide.cover.constants,
org.erlide.cover.runtime.launch,
org.erlide.cover.views.model
Bundle-ClassPath: .
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.cover.core
@@ -21,9 +21,9 @@ Require-Bundle: org.eclipse.ui,
org.erlide.ui,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0"
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
Export-Package: org.erlide.cover.ui;x-internal:=true,
@@ -35,4 +35,5 @@ Export-Package: org.erlide.cover.ui;x-internal:=true,
org.erlide.cover.ui.views.helpers;x-internal:=true,
org.erlide.cover.ui.views.util;x-internal:=true
Bundle-ClassPath: .
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.cover.ui
@@ -29,12 +29,13 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.fishwife.jrugged,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
org.eclipse.lsp4j;bundle-version="0.3.0",
org.eclipse.lsp4j.jsonrpc;bundle-version="0.3.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.erlide.engine.ModelApiActivator
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.model.api
@@ -32,8 +32,7 @@ class ModelApiActivator implements BundleActivator {
val params = new ErlangInitializeParamsImpl => [
stateDir = Platform.getStateLocation(modelPlugin).toPortableString()
processId = getProcessId(0)
rootPath = ResourcesPlugin.workspace.root.location.toPortableString
clientName = "erlide-eclipse"
rootUri = '''file://«ResourcesPlugin.workspace.root.location.toPortableString»'''
capabilities = new ClientCapabilities
]
engine.initialize(params);
@@ -14,11 +14,11 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
org.erlide.backend,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
org.eclipse.lsp4j;bundle-version="0.3.0",
org.eclipse.lsp4j.jsonrpc;bundle-version="0.3.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
@@ -35,4 +35,5 @@ Export-Package: org.erlide.engine.internal;x-internal:=true,
org.erlide.engine.internal.services.search;x-internal:=true,
org.erlide.engine.internal.services.text;x-internal:=true,
org.erlide.engine.internal.util;x-internal:=true
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.model
@@ -8,12 +8,12 @@ Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Require-Bundle: org.fishwife.jrugged,
org.erlide.util,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
javax.inject;bundle-version="1.0.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0",
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)"
org.eclipse.jdt.annotation
Export-Package: org.erlide.runtime,
org.erlide.runtime.api,
org.erlide.runtime.epmd,
@@ -25,4 +25,5 @@ Export-Package: org.erlide.runtime,
org.erlide.runtime.service,
org.erlide.runtime.shell
Bundle-ActivationPolicy: lazy
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.runtime
@@ -13,12 +13,13 @@ Require-Bundle: org.eclipse.jface.text,
org.fishwife.jrugged,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)"
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
org.eclipse.lsp4j;bundle-version="0.3.0",
org.eclipse.lsp4j.jsonrpc;bundle-version="0.3.0"
Export-Package: org.eclipse.languageserver,
org.erlide.server
Import-Package: org.eclipse.osgi.util,
org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.server
@@ -29,9 +29,9 @@ Require-Bundle: org.eclipse.ui,
org.erlide.model.api,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
@@ -42,4 +42,5 @@ Export-Package: org.erlide.test_support,
org.erlide.test_support.ui.suites,
org.erlide.test_support.ui.trace
Bundle-ClassPath: .
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.test_support
@@ -21,9 +21,9 @@ Require-Bundle: org.eclipse.core.runtime,
org.erlide.kernel.debugger;bundle-version="0.113.0",
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
@@ -40,4 +40,5 @@ Export-Package: org.erlide.tracing.core;x-internal:=true,
org.erlide.tracing.core.ui.menu;x-internal:=true,
org.erlide.tracing.core.utils;x-internal:=true,
org.erlide.tracing.core.views;x-internal:=true
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.tracing.core
@@ -101,14 +101,15 @@ Require-Bundle: org.eclipse.compare;bundle-version="3.5.202",
org.erlide.server,
com.google.guava;bundle-version="[15.0.0,16.0.0)",
javax.inject;bundle-version="1.0.0",
org.eclipse.xtend.lib;bundle-version="2.11.0",
org.eclipse.xtend.lib.macro;bundle-version="2.11.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.11.0",
org.eclipse.lsp4j;bundle-version="[0.1.0,0.2.0)",
org.eclipse.lsp4j.jsonrpc;bundle-version="[0.1.0,0.2.0)",
org.eclipse.xtend.lib;bundle-version="2.12.0",
org.eclipse.xtend.lib.macro;bundle-version="2.12.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.12.0",
org.eclipse.lsp4j;bundle-version="0.3.0",
org.eclipse.lsp4j.jsonrpc;bundle-version="0.3.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Eclipse-ExtensibleAPI: true
Import-Package: org.eclipse.jdt.annotation;bundle-version="[2.0.0,3.0.0)";resolution:=optional
Import-Package: org.eclipse.jdt.annotation;resolution:=optional
Automatic-Module-Name: org.erlide.ui
Oops, something went wrong.

0 comments on commit 47cb82b

Please sign in to comment.