Skip to content
Permalink
Browse files

Remove lsp4j references

We will add them when needed, keep it clean for now
  • Loading branch information...
vladdu committed Jun 21, 2019
1 parent 6022500 commit 47cc38fa13abddbbd8930fb628f89842c96bb842
@@ -5,6 +5,11 @@
<projects>
</projects>
<buildSpec>
<buildCommand>
<name>org.eclipse.xtext.ui.shared.xtextBuilder</name>
<arguments>
</arguments>
</buildCommand>
<buildCommand>
<name>org.eclipse.m2e.core.maven2Builder</name>
<arguments>
@@ -13,5 +18,6 @@
</buildSpec>
<natures>
<nature>org.eclipse.m2e.core.maven2Nature</nature>
<nature>org.eclipse.xtext.ui.shared.xtextNature</nature>
</natures>
</projectDescription>
@@ -31,8 +31,6 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.eclipse.xtend.lib;bundle-version="2.14.0",
org.eclipse.xtend.lib.macro;bundle-version="2.14.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.14.0",
org.eclipse.lsp4j;bundle-version="0.3.0",
org.eclipse.lsp4j.jsonrpc;bundle-version="0.3.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Bundle-Activator: org.erlide.engine.ModelApiActivator
@@ -1,8 +1,6 @@
package org.erlide.engine;

import org.eclipse.lsp4j.InitializeParams;

public abstract class ErlangInitializeParams extends InitializeParams {
public abstract class ErlangInitializeParams {

public abstract String getStateDir();

@@ -2,12 +2,10 @@ package org.erlide.engine

import java.io.File
import java.lang.management.ManagementFactory
import org.eclipse.core.resources.ResourcesPlugin
import org.eclipse.core.runtime.CoreException
import org.eclipse.core.runtime.IStatus
import org.eclipse.core.runtime.Platform
import org.eclipse.core.runtime.Status
import org.eclipse.lsp4j.ClientCapabilities
import org.erlide.util.ErlLogger
import org.erlide.util.services.ExtensionUtils
import org.osgi.framework.BundleActivator
@@ -31,9 +29,6 @@ class ModelApiActivator implements BundleActivator {
val modelPlugin = Platform.getBundle("org.erlide.model")
val params = new ErlangInitializeParamsImpl => [
stateDir = Platform.getStateLocation(modelPlugin).toPortableString()
processId = getProcessId(0)
rootUri = '''file://«ResourcesPlugin.workspace.root.location.toPortableString»'''
capabilities = new ClientCapabilities
]
engine.initialize(params);
ErlLogger.debug("Started model api")
@@ -16,8 +16,6 @@ Require-Bundle: org.eclipse.core.runtime;bundle-version="3.10.0",
org.eclipse.xtend.lib;bundle-version="2.14.0",
org.eclipse.xtend.lib.macro;bundle-version="2.14.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.14.0",
org.eclipse.lsp4j;bundle-version="0.3.0",
org.eclipse.lsp4j.jsonrpc;bundle-version="0.3.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-ActivationPolicy: lazy
@@ -102,8 +102,6 @@ Require-Bundle: org.eclipse.compare;bundle-version="3.5.202",
org.eclipse.xtend.lib;bundle-version="2.14.0",
org.eclipse.xtend.lib.macro;bundle-version="2.14.0",
org.eclipse.xtext.xbase.lib;bundle-version="2.14.0",
org.eclipse.lsp4j;bundle-version="0.3.0",
org.eclipse.lsp4j.jsonrpc;bundle-version="0.3.0",
com.ericsson.otp.jinterface;bundle-version="1.8.0"
Bundle-ActivationPolicy: lazy
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
12 pom.xml
@@ -42,16 +42,6 @@
<layout>p2</layout>
<url>http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.14.0</url>
</repository>
<repository>
<id>lsp4j</id>
<layout>p2</layout>
<url>http://download.eclipse.org/lsp4j/updates/releases/0.3.0/</url>
</repository>
<repository>
<id>handly</id>
<layout>p2</layout>
<url>http://download.eclipse.org/handly/releases/0.6/repository</url>
</repository>
<repository>
<id>kernel</id>
<layout>p2</layout>
@@ -74,7 +64,7 @@
<module>plugins/org.erlide.branding</module>
<module>plugins/org.erlide.core</module>
<module>plugins/org.erlide.help</module>

<module>plugins/org.erlide.model</module>
<module>plugins/org.erlide.model.api</module>
<module>plugins/org.erlide.runtime</module>
@@ -7,7 +7,6 @@
<category name="extras"/>
</feature>
<feature url="features/com.abstratt.eclipsegraphviz.feature_2.2.201606.201701211537.jar" id="com.abstratt.eclipsegraphviz.feature" version="2.2.201606.201701211537"/>
<feature url="features/org.eclipse.lsp4j.sdk_0.3.0.v20170913-0640.jar" id="org.eclipse.lsp4j.sdk" version="0.3.0.v20170913-0640"/>
<feature url="features/org.erlide.kernel.feature_0.115.3.201806041948.jar" id="org.erlide.kernel.feature" version="0.115.3.201806041948">
<category name="erlide"/>
</feature>
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde?>
<!-- generated with https://github.com/eclipse-cbi/targetplatform-dsl -->
<target name="erlide target" sequenceNumber="1560962107">
<target name="erlide target" sequenceNumber="1561147255">
<locations>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="true" type="InstallableUnit">
<unit id="org.eclipse.e4.rcp.feature.group" version="0.0.0"/>
@@ -22,10 +22,6 @@
<unit id="org.eclipse.xtext.xbase.lib" version="0.0.0"/>
<repository location="http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.16.0/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="true" type="InstallableUnit">
<unit id="org.eclipse.lsp4j.sdk.feature.group" version="0.0.0"/>
<repository location="http://download.eclipse.org/lsp4j/updates/releases/0.4.0/"/>
</location>
<location includeMode="planner" includeAllPlatforms="false" includeSource="true" includeConfigurePhase="true" type="InstallableUnit">
<unit id="org.erlide.kernel.feature.feature.group" version="0.0.0"/>
<repository location="http://download.erlide.org/update/kernel/0.115.3"/>
@@ -22,10 +22,6 @@ location "http://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.16.0
org.eclipse.xtext.xbase.lib lazy
}

location "http://download.eclipse.org/lsp4j/updates/releases/0.4.0/"{
org.eclipse.lsp4j.sdk.feature.group lazy
}

location "http://download.erlide.org/update/kernel/0.115.3" {
org.erlide.kernel.feature.feature.group lazy
}

0 comments on commit 47cc38f

Please sign in to comment.
You can’t perform that action at this time.