Permalink
Browse files

prepare v0.29.12

  • Loading branch information...
vladdu committed Jul 10, 2015
1 parent 2612193 commit e287c7fe14c287bcb12fc594ac6e91d1065a0e5a
Showing with 79 additions and 29 deletions.
  1. +1 −1 .ruby-version
  2. +34 −0 CHANGELOG.md
  3. +16 −0 CHANGES
  4. +1 −1 org.erlide.backend/META-INF/MANIFEST.MF
  5. +1 −1 org.erlide.branding/META-INF/MANIFEST.MF
  6. +1 −1 org.erlide.core.tests/META-INF/MANIFEST.MF
  7. +1 −1 org.erlide.core/META-INF/MANIFEST.MF
  8. +1 −1 org.erlide.cover.core/META-INF/MANIFEST.MF
  9. +1 −1 org.erlide.cover.ui/META-INF/MANIFEST.MF
  10. +1 −1 org.erlide.dialyzer.ui/META-INF/MANIFEST.MF
  11. +1 −1 org.erlide.headless/feature.xml
  12. +1 −1 org.erlide.kernel.common/META-INF/MANIFEST.MF
  13. +1 −1 org.erlide.kernel.debugger.otp.17/META-INF/MANIFEST.MF
  14. +1 −1 org.erlide.kernel.debugger.otp.r15/META-INF/MANIFEST.MF
  15. +1 −1 org.erlide.kernel.debugger.otp.r16/META-INF/MANIFEST.MF
  16. +1 −1 org.erlide.kernel.debugger/META-INF/MANIFEST.MF
  17. +1 −1 org.erlide.kernel.ide/META-INF/MANIFEST.MF
  18. +1 −1 org.erlide.model.api/META-INF/MANIFEST.MF
  19. +1 −1 org.erlide.model.tests/META-INF/MANIFEST.MF
  20. +1 −1 org.erlide.model/META-INF/MANIFEST.MF
  21. +1 −1 org.erlide.runtime/META-INF/MANIFEST.MF
  22. +1 −1 org.erlide.sdk/feature.xml
  23. +1 −1 org.erlide.test_support/META-INF/MANIFEST.MF
  24. +1 −1 org.erlide.testing.libs/META-INF/MANIFEST.MF
  25. +1 −1 org.erlide.tracing.core/META-INF/MANIFEST.MF
  26. +1 −1 org.erlide.tracing.erlang/META-INF/MANIFEST.MF
  27. +1 −1 org.erlide.tracing.ttbe/META-INF/MANIFEST.MF
  28. +1 −1 org.erlide.ui.tests/META-INF/MANIFEST.MF
  29. +1 −1 org.erlide.ui/META-INF/MANIFEST.MF
  30. +1 −1 org.erlide.util/META-INF/MANIFEST.MF
  31. +1 −1 org.erlide/feature.xml
View
@@ -1 +1 @@
1.9.3-p547
2.1.1-github
View
@@ -0,0 +1,34 @@
# Change Log
## [v0.29.12](https://github.com/erlide/erlide/tree/v0.29.12) (2015-07-10)
[Full Changelog](https://github.com/erlide/erlide/compare/v0.29.11...v0.29.12)
**Implemented enhancements:**
- simplify "new module" dialog [\#222](https://github.com/erlide/erlide/issues/222)
**Fixed bugs:**
- epp error, unable to build automatically [\#229](https://github.com/erlide/erlide/issues/229)
**Closed issues:**
- There is no way to securely download the plugin [\#228](https://github.com/erlide/erlide/issues/228)
- docs: remove outdated info about sourceforge [\#226](https://github.com/erlide/erlide/issues/226)
- unable to build erlide [\#225](https://github.com/erlide/erlide/issues/225)
- Couldn't able to run erlide in Eclipse, throws an error [\#217](https://github.com/erlide/erlide/issues/217)
- Cannot get Console working [\#212](https://github.com/erlide/erlide/issues/212)
- Can you support offline download method for erlide? [\#199](https://github.com/erlide/erlide/issues/199)
**Merged pull requests:**
- Have the source found where it is defined in the beam when default search fails. [\#220](https://github.com/erlide/erlide/pull/220) ([zsoci](https://github.com/zsoci))
\* *This Change Log was automatically generated by [github_changelog_generator](https://github.com/skywinder/Github-Changelog-Generator)*
View
16 CHANGES
@@ -1,3 +1,19 @@
List of user visible changes between 0.29.11 and 0.29.12 (20150710)
dca59f3 #229 - epp error, unable to build automatically
05289aa #228 - create github release and upload zip from cli
c731619 add debugger plugin för OTP 18
40b2878 #222: simplify "new module" dialog
17d5a63 treat "test" dir as source if in test mode
7e81dab Merge pull request #220 from zsoci/debug-int
983bdf8 Have the source found where it is defined in the beam when default search fails.
556c7a6 add navigator filter for beam files
fa93600 fix display of multiline compiler error messages
9144595 update default backend version to R17
a56a5c2 replace usages of erlang:now as per OTP 18 recommendations
a57c7cc move "erlang tools" menu to ui plugin
092a8d8 fix NPE when terminating backend
List of user visible changes between 0.29.10 and 0.29.11 (20150216)
6bfa566 fix stupid mistake
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.erlide.backend;singleton:=true
Bundle-Version: 0.24.16.qualifier
Bundle-Version: 0.24.17.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: erlide - Erlang language tools
Bundle-SymbolicName: org.erlide.branding;singleton:=true
Bundle-Version: 0.24.3.qualifier
Bundle-Version: 0.24.4.qualifier
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.eclipse.ui.intro.universal;bundle-version="3.2.500",
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: erlide core Tests Fragment
Bundle-SymbolicName: org.erlide.core.tests;singleton:=true
Bundle-Version: 0.24.6.qualifier
Bundle-Version: 0.24.7.qualifier
Bundle-Vendor: erlide.org
Fragment-Host: org.erlide.core;bundle-version="0.14.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.erlide.core; singleton:=true
Bundle-Version: 0.24.12.qualifier
Bundle-Version: 0.24.13.qualifier
Bundle-Activator: org.erlide.core.ErlangPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Cover suport for ErlIde (Core plugin)
Bundle-SymbolicName: org.erlide.cover.core;singleton:=true
Bundle-Version: 0.2.24.qualifier
Bundle-Version: 0.2.25.qualifier
Bundle-Activator: org.erlide.cover.core.Activator
Bundle-Vendor: Erlang Solutions
Require-Bundle: org.eclipse.core.runtime,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Cover plugin UI
Bundle-SymbolicName: org.erlide.cover.ui;singleton:=true
Bundle-Version: 0.2.24.qualifier
Bundle-Version: 0.2.25.qualifier
Bundle-Activator: org.erlide.cover.ui.Activator
Bundle-Vendor: Erlang Solutions
Require-Bundle: org.eclipse.ui,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Dialyzer Ui
Bundle-SymbolicName: org.erlide.dialyzer.ui;singleton:=true
Bundle-Version: 0.24.10.qualifier
Bundle-Version: 0.24.11.qualifier
Bundle-Activator: org.erlide.dialyzer.ui.Activator
Bundle-Vendor: erlide.org
Require-Bundle: org.eclipse.ui,
@@ -2,7 +2,7 @@
<feature
id="org.erlide.headless"
label="Erlang headless support"
version="0.29.11.qualifier"
version="0.29.12.qualifier"
provider-name="erlide.org"
license-feature="org.erlide.licenses"
license-feature-version="1.0.0.qualifier">
@@ -2,6 +2,6 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Kernel Erlang functionality
Bundle-SymbolicName: org.erlide.kernel.common;singleton:=true
Bundle-Version: 0.24.13.qualifier
Bundle-Version: 0.24.14.qualifier
Bundle-Vendor: Erlide project
Require-Bundle: org.erlide.core
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Kernel Erlang Debugger functionality
Bundle-SymbolicName: org.erlide.kernel.debugger.otp.17;singleton:=true
Bundle-Version: 0.24.5.qualifier
Bundle-Version: 0.24.6.qualifier
Bundle-Vendor: Erlide project
Require-Bundle: org.erlide.core,
org.erlide.kernel.common
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Kernel Erlang Debugger functionality
Bundle-SymbolicName: org.erlide.kernel.debugger.otp.r15;singleton:=true
Bundle-Version: 0.25.2.qualifier
Bundle-Version: 0.25.3.qualifier
Bundle-Vendor: Erlide project
Require-Bundle: org.erlide.core,
org.erlide.kernel.common
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Kernel Erlang Debugger functionality
Bundle-SymbolicName: org.erlide.kernel.debugger.otp.r16;singleton:=true
Bundle-Version: 0.25.2.qualifier
Bundle-Version: 0.25.3.qualifier
Bundle-Vendor: Erlide project
Require-Bundle: org.erlide.core,
org.erlide.kernel.common
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Kernel Erlang Debugger functionality
Bundle-SymbolicName: org.erlide.kernel.debugger;singleton:=true
Bundle-Version: 0.24.6.qualifier
Bundle-Version: 0.24.7.qualifier
Bundle-Vendor: Erlide project
Require-Bundle: org.erlide.core,
org.erlide.kernel.common
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Kernel Erlang functionality
Bundle-SymbolicName: org.erlide.kernel.ide;singleton:=true
Bundle-Version: 0.26.9.qualifier
Bundle-Version: 0.26.10.qualifier
Bundle-Vendor: Erlide project
Require-Bundle: org.erlide.core,
org.erlide.kernel.common
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: erlide Model_api
Bundle-SymbolicName: org.erlide.model.api;singleton:=true
Bundle-Version: 0.24.11.qualifier
Bundle-Version: 0.24.12.qualifier
Bundle-Vendor: erlide.org
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Export-Package: org.erlide.engine,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: erlide model Tests Fragment
Bundle-SymbolicName: org.erlide.model.tests;singleton:=true
Bundle-Version: 0.24.10.qualifier
Bundle-Version: 0.24.11.qualifier
Bundle-Vendor: erlide.org
Fragment-Host: org.erlide.model
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: erlide model
Bundle-SymbolicName: org.erlide.model;singleton:=true
Bundle-Version: 0.24.12.qualifier
Bundle-Version: 0.24.13.qualifier
Bundle-Vendor: erlide.org project
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.7.0",
org.eclipse.core.resources;bundle-version="3.7.0",
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Erlang backend support (no eclipse dependencies)
Bundle-SymbolicName: org.erlide.runtime;singleton:=true
Bundle-Version: 0.24.11.qualifier
Bundle-Version: 0.24.12.qualifier
Bundle-Vendor: erlide.org
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: org.erlide.libs,
@@ -2,7 +2,7 @@
<feature
id="org.erlide.sdk"
label="Erlang SDK"
version="0.29.11.qualifier"
version="0.29.12.qualifier"
provider-name="erlide.org"
license-feature="org.erlide.licenses"
license-feature-version="1.0.0.qualifier">
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Test frameworks support plug-in
Bundle-SymbolicName: org.erlide.test_support;singleton:=true
Bundle-Version: 0.24.10.qualifier
Bundle-Version: 0.24.11.qualifier
Bundle-Activator: org.erlide.test_support.Activator
Bundle-Vendor: erlide.org
Require-Bundle: org.eclipse.ui,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Testing Support Libraries
Bundle-SymbolicName: org.erlide.testing.libs;singleton:=true
Bundle-Version: 1.1.7
Bundle-Version: 1.1.8
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Bundle-ClassPath: commons-collections-3.2.1.jar,
commons-lang-2.5.jar,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Erlang tracing for Erlide (java classes)
Bundle-SymbolicName: org.erlide.tracing.core;singleton:=true
Bundle-Version: 0.2.34.qualifier
Bundle-Version: 0.2.35.qualifier
Bundle-Activator: org.erlide.tracing.core.Activator
Require-Bundle: org.erlide.tracing.erlang;bundle-version="0.2.0",
org.erlide.tracing.ttbe;bundle-version="0.1.0",
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Erlang tracing for Erlide (Erlang helper modules)
Bundle-SymbolicName: org.erlide.tracing.erlang;singleton:=true
Bundle-Version: 0.2.14.qualifier
Bundle-Version: 0.2.15.qualifier
Bundle-Vendor: Erlang Solutions
Require-Bundle: org.erlide.core;bundle-version="0.8.4",
org.erlide.tracing.ttbe;bundle-version="0.1.0"
@@ -2,6 +2,6 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Erlang tracing for Erlide (trace tool builder modules)
Bundle-SymbolicName: org.erlide.tracing.ttbe;singleton:=true
Bundle-Version: 0.1.12.qualifier
Bundle-Version: 0.1.13.qualifier
Bundle-Vendor: Erlang Solutions
Require-Bundle: org.erlide.core;bundle-version="0.9.5"
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Tests
Bundle-SymbolicName: org.erlide.ui.tests;singleton:=true
Bundle-Version: 0.24.13.qualifier
Bundle-Version: 0.24.14.qualifier
Bundle-Vendor: Erilde.org project
Fragment-Host: org.erlide.ui
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.erlide.ui; singleton:=true
Bundle-Version: 0.24.15.qualifier
Bundle-Version: 0.24.16.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.erlide.ui.internal.ErlideUIPlugin
Bundle-Vendor: %providerName
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Common code, dependent on Eclipse
Bundle-SymbolicName: org.erlide.util;singleton:=true
Bundle-Version: 0.24.12.qualifier
Bundle-Version: 0.24.13.qualifier
Bundle-Vendor: erlide.org
Require-Bundle: org.eclipse.core.runtime,
org.erlide.libs;bundle-version="1.12.0",
View
@@ -2,7 +2,7 @@
<feature
id="org.erlide"
label="Erlang language tools IDE"
version="0.29.11.qualifier"
version="0.29.12.qualifier"
provider-name="%vendorName"
plugin="org.erlide.branding"
image="erlang-64.gif"

0 comments on commit e287c7f

Please sign in to comment.