Permalink
Browse files

prepared v0.13.0

  • Loading branch information...
vladdu committed May 17, 2011
1 parent 78d4440 commit fbb3152e748d644005bffa6d8208cc88a3390a45
View
11 CHANGES
@@ -1,3 +1,14 @@
+List of user visible changes between 0.12.0 and 0.13.0 (20110517)
+
+* There are again some large refactorings of the API code, and we're not yet close to something stable.
+
+943bb65 http://www.assembla.com/spaces/erlide/tickets/838-dialyzer---implement-plt-copy-feature
+fe3244b 814-npe-in--open-module--dialog
+98c50be 722-completion--nothing-is-shown-for-modules-using-export_all
+82d6b8c 752-test_support--improve-results-view-ui
+5f46626 750-test_support--links-to-source-from-results-view
+49397b8 549-open-module-dialog---too-slow The reading of resource attributes slowed down the searching a lot... removed
+
List of user visible changes between 0.11.1 and 0.12.0 (20110503)
2510907 826-launch---quick-launch-does-not-work-on-windows-some-times
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: erlide core Tests Fragment
Bundle-SymbolicName: org.erlide.core.tests;singleton:=true
-Bundle-Version: 0.11.2.qualifier
+Bundle-Version: 0.11.3.qualifier
Bundle-Vendor: erlide.org
Fragment-Host: org.erlide.core;bundle-version="0.6.0"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.erlide.core; singleton:=true
-Bundle-Version: 0.12.0.qualifier
+Bundle-Version: 0.13.0.qualifier
Bundle-Activator: org.erlide.core.ErlangPlugin
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Cover Interfaces
Bundle-SymbolicName: org.erlide.cover.api;singleton:=true
-Bundle-Version: 0.2.1
+Bundle-Version: 0.2.2
Bundle-Activator: org.erlide.cover.api.Activator
Require-Bundle: org.eclipse.core.runtime,
org.erlide.core;bundle-version="0.11.0",
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Cover suport for ErlIde (Core plugin)
Bundle-SymbolicName: org.erlide.cover.core;singleton:=true
-Bundle-Version: 0.2.1.qualifier
+Bundle-Version: 0.2.2.qualifier
Bundle-Activator: org.erlide.cover.core.Activator
Bundle-Vendor: Erlang Solutions
Require-Bundle: org.eclipse.core.runtime,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Cover plugin UI
Bundle-SymbolicName: org.erlide.cover.ui;singleton:=true
-Bundle-Version: 0.2.1.qualifier
+Bundle-Version: 0.2.2.qualifier
Bundle-Activator: org.erlide.cover.ui.Activator
Bundle-Vendor: Erlang Solutions
Require-Bundle: org.eclipse.ui,
@@ -2,7 +2,7 @@
<feature
id="org.erlide.headless"
label="Erlide core (headless)"
- version="0.12.0.qualifier"
+ version="0.13.0.qualifier"
provider-name="erlide.org"
plugin="org.erlide.core">
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: erlide Jinterface Tests Fragment
Bundle-SymbolicName: org.erlide.jinterface.tests;singleton:=true
-Bundle-Version: 0.11.1.qualifier
+Bundle-Version: 0.11.2.qualifier
Bundle-Vendor: erlide.org
Fragment-Host: org.erlide.jinterface;bundle-version="0.6.0"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.erlide.jinterface; singleton:=true
-Bundle-Version: 0.11.2.qualifier
+Bundle-Version: 0.11.3.qualifier
Bundle-ClassPath: .
Bundle-Vendor: %providerName
Bundle-Localization: plugin
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Kernel Erlang functionality
Bundle-SymbolicName: org.erlide.kernel.ide;singleton:=true
-Bundle-Version: 0.11.2.qualifier
+Bundle-Version: 0.11.3.qualifier
Bundle-Vendor: Erlide project
Require-Bundle: org.erlide.core,
org.erlide.kernel.common
@@ -2,7 +2,7 @@
<feature
id="org.erlide.sdk"
label="erlide SDK"
- version="0.12.0.qualifier"
+ version="0.13.0.qualifier"
provider-name="erlide.org">
<description>
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Test frameworks support plug-in
Bundle-SymbolicName: org.erlide.test_support;singleton:=true
-Bundle-Version: 0.11.2.qualifier
+Bundle-Version: 0.11.3.qualifier
Bundle-Activator: org.erlide.test_support.Activator
Bundle-Vendor: erlide.org
Require-Bundle: org.eclipse.ui,
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Erlang tracing for Erlide (java classes)
Bundle-SymbolicName: org.erlide.tracing.core;singleton:=true
-Bundle-Version: 0.2.9.qualifier
+Bundle-Version: 0.2.10.qualifier
Bundle-Activator: org.erlide.tracing.core.Activator
Require-Bundle: org.erlide.tracing.erlang;bundle-version="0.2.0",
org.erlide.tracing.ttbe;bundle-version="0.1.0",
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Erlang tracing for Erlide (Erlang helper modules)
Bundle-SymbolicName: org.erlide.tracing.erlang;singleton:=true
-Bundle-Version: 0.2.5.qualifier
+Bundle-Version: 0.2.6.qualifier
Bundle-Vendor: Erlang Solutions
Require-Bundle: org.erlide.core;bundle-version="0.8.4",
org.erlide.tracing.ttbe;bundle-version="0.1.0"
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Tests
Bundle-SymbolicName: org.erlide.ui.tests;singleton:=true
-Bundle-Version: 0.11.2.qualifier
+Bundle-Version: 0.11.3.qualifier
Bundle-Vendor: Erilde.org project
Fragment-Host: org.erlide.ui
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.erlide.ui; singleton:=true
-Bundle-Version: 0.11.2.qualifier
+Bundle-Version: 0.11.3.qualifier
Bundle-ClassPath: .
Bundle-Activator: org.erlide.ui.ErlideUIPlugin
Bundle-Vendor: %providerName
@@ -2,6 +2,6 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Wrangler Core Plugin
Bundle-SymbolicName: org.erlide.wrangler.core;singleton:=true
-Bundle-Version: 0.9.5.qualifier
+Bundle-Version: 0.9.6.qualifier
Bundle-Vendor: UKC
Require-Bundle: org.erlide.core
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Duplicated code detection fragment
Bundle-SymbolicName: org.erlide.wrangler.refactoring.duplicatedcode;singleton:=true
-Bundle-Version: 0.9.5.qualifier
+Bundle-Version: 0.9.6.qualifier
Bundle-Vendor: UKC
Fragment-Host: org.erlide.wrangler.refactoring;bundle-version="0.9"
Bundle-RequiredExecutionEnvironment: J2SE-1.5
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Wrangler Refactor plug-in
Bundle-SymbolicName: org.erlide.wrangler.refactoring;singleton:=true
-Bundle-Version: 0.10.9.qualifier
+Bundle-Version: 0.10.10.qualifier
Bundle-ClassPath: wrangler.jar
Bundle-Activator: org.erlide.wrangler.refactoring.Activator
Require-Bundle: org.eclipse.core.runtime;bundle-version="3.3.0",
View
@@ -2,7 +2,7 @@
<feature
id="org.erlide"
label="Erlang IDE"
- version="0.12.0.qualifier"
+ version="0.13.0.qualifier"
provider-name="erlide.org"
image="erlang120.gif">
<install-handler/>
@@ -2,7 +2,7 @@ Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: Bterl
Bundle-SymbolicName: shade.bterl;singleton:=true
-Bundle-Version: 0.11.2.qualifier
+Bundle-Version: 0.11.3.qualifier
Bundle-Activator: org.erlide.shade.bterl.Activator
Bundle-Vendor: erlide.org
Require-Bundle: org.eclipse.ui,

0 comments on commit fbb3152

Please sign in to comment.