Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #3 from fbricon/jbosstools

Fix compatibility with EAP ER6 maven repo + Prevent Eclipse JS validator from crashing
  • Loading branch information...
commit 9d19704be91349d41eed5d520c1bd215fe044456 2 parents 93a0a02 + a6e7e3d
@jfuerth jfuerth authored
View
3  .gitignore
@@ -2,5 +2,6 @@
.idea
.classpath
.project
-.settings
+.settings/*
+!.settings/.jsdtscope
*/target/
View
6 kitchensink-quickstart/src/main/resources/META-INF/maven/archetype-metadata.xml
@@ -55,5 +55,11 @@
<include>README.md</include>
</includes>
</fileSet>
+ <fileSet encoding="UTF-8">
+ <directory>.settings/</directory>
+ <includes>
+ <include>**/.jsdtscope</include>
+ </includes>
+ </fileSet>
</fileSets>
</archetype-descriptor>
View
11 kitchensink-quickstart/src/main/resources/archetype-resources/.gitignore
@@ -0,0 +1,11 @@
+*~
+.classpath
+.project
+target
+.settings/*
+!.settings/.jsdtscope
+.DS_Store
+.faces-config.xml.jsfdia
+MANIFEST.MF
+.idea
+*.iml
View
12 kitchensink-quickstart/src/main/resources/archetype-resources/.settings/.jsdtscope
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<classpath>
+ <classpathentry excluding="KitchenSink/" kind="src" path="src/main/webapp"/>
+ <classpathentry kind="con" path="org.eclipse.wst.jsdt.launching.JRE_CONTAINER"/>
+ <classpathentry kind="con" path="org.eclipse.wst.jsdt.launching.WebProject">
+ <attributes>
+ <attribute name="hide" value="true"/>
+ </attributes>
+ </classpathentry>
+ <classpathentry kind="con" path="org.eclipse.wst.jsdt.launching.baseBrowserLibrary"/>
+ <classpathentry kind="output" path=""/>
+</classpath>
View
12 kitchensink-quickstart/src/main/resources/archetype-resources/pom.xml
@@ -22,22 +22,22 @@
BOM -->
#if ($enterprise == "true" || $enterprise == "y" || $enterprise == "yes" )
<!-- Certified version of the JBoss EAP components we want to use -->
- <version.org.jboss.spec.jboss.javaee6>3.0.0.Beta1-redhat-1</version.org.jboss.spec.jboss.javaee6>
+ <version.org.jboss.spec.jboss.javaee6>3.0.0.Final-redhat-1</version.org.jboss.spec.jboss.javaee6>
<!-- Alternatively, comment out the above line, and un-comment the line
- below to use version 2.0.0.Final which is based on community built dependencies.
+ below to use version 3.0.0.Final which is based on community built dependencies.
You can actually use this stack with any version of JBoss AS that implements
the Java EE 6 web profile -->
- <!-- <version.org.jboss.spec.jboss.javaee6>2.0.0.Final</version.org.jboss.spec.jboss.javaee6> -->
+ <!-- <version.org.jboss.spec.jboss.javaee6>3.0.0.Final</version.org.jboss.spec.jboss.javaee6> -->
<version.org.jboss.errai>${errai.target.version}</version.org.jboss.errai>
<version.com.google.gwt>2.4.0</version.com.google.gwt>
<version.org.codehaus.mojo.gwt.maven.plugin>\${version.com.google.gwt}</version.org.codehaus.mojo.gwt.maven.plugin>
#else
- <version.org.jboss.spec.jboss.javaee6>2.0.0.Final</version.org.jboss.spec.jboss.javaee6>
+ <version.org.jboss.spec.jboss.javaee6>3.0.0.Final</version.org.jboss.spec.jboss.javaee6>
<!-- Alternatively, comment out the above line, and un-comment the line
- below to use version 3.0.0.Beta1-redhat-1 which is a release certified to
+ below to use version 3.0.0.Final-redhat-1 which is a release certified to
work with JBoss EAP 6. It requires you have access to the JBoss EAP 6 maven
repository. -->
- <!-- <version.org.jboss.spec.jboss.javaee6>3.0.0.Beta1-redhat-1</version.org.jboss.spec.jboss.javaee6> -->
+ <!-- <version.org.jboss.spec.jboss.javaee6>3.0.0.Final-redhat-1</version.org.jboss.spec.jboss.javaee6> -->
<version.org.jboss.errai>${errai.target.version}</version.org.jboss.errai>
<version.com.google.gwt>2.4.0</version.com.google.gwt>
<version.org.codehaus.mojo.gwt.maven.plugin>\${version.com.google.gwt}</version.org.codehaus.mojo.gwt.maven.plugin>

0 comments on commit 9d19704

Please sign in to comment.
Something went wrong with that request. Please try again.