Skip to content
Permalink
Browse files
Chore: Test on Node.js 15 (#13844)
Running `npm install` in the repository with Node.js 15 currently
requires the `--legacy-peer-deps` requirement because npm is resolving
`eslint-plugin-eslint-plugin`'s `eslint` peer dependency version as
`undefined`. We can figure out later if that's an issue on our end or
npm's, but in the meantime this will let us run CI on Node.js 15. I'm
hoping this is a temporary situation so didn't update the contributing
documentation to mention the flag.
  • Loading branch information
btmills committed Nov 18, 2020
1 parent 37a06d6 commit 038dc73c99ae68eae2035ef303f3a947053c8f05
Showing with 5 additions and 1 deletion.
  1. +5 −1 .github/workflows/ci.yml
@@ -26,7 +26,7 @@ jobs:
strategy:
matrix:
os: [ubuntu-latest]
node: [14.x, 13.x, 12.x, 10.x, "10.12.0"]
node: [15.x, 14.x, 13.x, 12.x, 10.x, "10.12.0"]
include:
- os: windows-latest
node: "12.x"
@@ -40,6 +40,10 @@ jobs:
node-version: ${{ matrix.node }}
- name: Install Packages
run: npm install
if: ${{ !startswith(matrix.node, '15') }}
- name: Install Packages
run: npm install --legacy-peer-deps
if: ${{ startswith(matrix.node, '15') }}
- name: Test
run: node Makefile mocha
- name: Fuzz Test

0 comments on commit 038dc73

Please sign in to comment.