Skip to content
Permalink
Browse files
Upgrade: eslint-plugin-eslint-plugin to v4 (#15169)
Some rules have been added to the `recommended` config so we no longer have to manually enable them.

https://github.com/not-an-aardvark/eslint-plugin-eslint-plugin/releases/tag/v4.0.0
  • Loading branch information
bmish committed Oct 19, 2021
1 parent 35f3254 commit 249a04070f88d2c895af3b78d60d2eff2730730e
Showing with 1 addition and 8 deletions.
  1. +0 −7 .eslintrc.js
  2. +1 −1 package.json
@@ -64,18 +64,12 @@ module.exports = {
}
},
rules: {
"eslint-plugin/consistent-output": "error",
"eslint-plugin/no-deprecated-context-methods": "error",
"eslint-plugin/no-only-tests": "error",
"eslint-plugin/prefer-message-ids": "error",
"eslint-plugin/prefer-output-null": "error",
"eslint-plugin/prefer-placeholders": "error",
"eslint-plugin/prefer-replace-text": "error",
"eslint-plugin/report-message-format": ["error", "[^a-z].*\\.$"],
"eslint-plugin/require-meta-docs-description": "error",
"eslint-plugin/require-meta-has-suggestions": "error",
"eslint-plugin/require-meta-schema": "error",
"eslint-plugin/require-meta-type": "error",
"eslint-plugin/test-case-property-ordering": "error",
"eslint-plugin/test-case-shorthand-strings": "error",
"internal-rules/multiline-comment-style": "error"
@@ -85,7 +79,6 @@ module.exports = {
files: ["lib/rules/*", "tools/internal-rules/*"],
excludedFiles: ["index.js"],
rules: {
"eslint-plugin/prefer-object-rule": "error",
"internal-rules/no-invalid-meta": "error"
}
},
@@ -99,7 +99,7 @@
"eslint": "file:.",
"eslint-config-eslint": "file:packages/eslint-config-eslint",
"eslint-plugin-eslint-comments": "^3.2.0",
"eslint-plugin-eslint-plugin": "^3.5.3",
"eslint-plugin-eslint-plugin": "^4.0.1",
"eslint-plugin-internal-rules": "file:tools/internal-rules",
"eslint-plugin-jsdoc": "^36.0.6",
"eslint-plugin-node": "^11.1.0",

0 comments on commit 249a040

Please sign in to comment.