Skip to content
Permalink
Browse files
Breaking: drop node v10/v13/v15 (fixes #14023) (#14592)
* Breaking: drop node v10/v13 (fixes #14023)

* Update .github/workflows/ci.yml

Co-authored-by: Brandon Mills <btmills@users.noreply.github.com>

* Update relative-module-resolver.js

* Update package.json

Co-authored-by: Michaël De Boey <info@michaeldeboey.be>

* Update ci.yml

* Update README.md

* Update getting-started.md

* chore: fs-teardown ^0.1.3

Co-authored-by: Brandon Mills <btmills@users.noreply.github.com>
Co-authored-by: Michaël De Boey <info@michaeldeboey.be>
  • Loading branch information
3 people committed Aug 5, 2021
1 parent b8b2d55 commit f3cb3208c8952a6218d54658cfda85942b9fda42
Show file tree
Hide file tree
Showing 5 changed files with 6 additions and 13 deletions.
@@ -26,7 +26,7 @@ jobs:
strategy:
matrix:
os: [ubuntu-latest]
node: [16.x, 15.x, 14.x, 13.x, 12.x, 10.x, "10.12.0"]
node: [16.x, 14.x, 12.x, "12.22.0"]
include:
- os: windows-latest
node: "12.x"
@@ -43,7 +43,7 @@ ESLint is a tool for identifying and reporting on patterns found in ECMAScript/J

## <a name="installation-and-usage"></a>Installation and Usage

Prerequisites: [Node.js](https://nodejs.org/) (`^10.12.0`, or `>=12.0.0`) built with SSL support. (If you are using an official Node.js distribution, SSL is always built in.)
Prerequisites: [Node.js](https://nodejs.org/) (`^12.22.0`, `^14.17.0`, or `>=16.0.0`) built with SSL support. (If you are using an official Node.js distribution, SSL is always built in.)

You can install ESLint using npm:

@@ -8,7 +8,7 @@ ESLint is a tool for identifying and reporting on patterns found in ECMAScript/J

## Installation and Usage

Prerequisites: [Node.js](https://nodejs.org/en/) (`^10.12.0`, or `>=12.0.0`) built with SSL support. (If you are using an official Node.js distribution, SSL is always built in.)
Prerequisites: [Node.js](https://nodejs.org/en/) (`^12.22.0`, `^14.17.0`, or `>=16.0.0`) built with SSL support. (If you are using an official Node.js distribution, SSL is always built in.)

You can install ESLint using npm or yarn:

@@ -17,14 +17,7 @@

"use strict";

const Module = require("module");

/*
* `Module.createRequire` is added in v12.2.0. It supports URL as well.
* We only support the case where the argument is a filepath, not a URL.
*/
// eslint-disable-next-line node/no-unsupported-features/node-builtins, node/no-deprecated-api
const createRequire = Module.createRequire || Module.createRequireFromPath;
const { createRequire } = require("module");

module.exports = {

@@ -103,7 +103,7 @@
"eslint-release": "^2.0.0",
"eslump": "^3.0.0",
"esprima": "^4.0.1",
"fs-teardown": "0.1.1",
"fs-teardown": "^0.1.3",
"glob": "^7.1.6",
"jsdoc": "^3.5.5",
"karma": "^6.1.1",
@@ -141,6 +141,6 @@
],
"license": "MIT",
"engines": {
"node": "^10.12.0 || >=12.0.0"
"node": "^12.22.0 || ^14.17.0 || >=16.0.0"
}
}

0 comments on commit f3cb320

Please sign in to comment.