Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade lodash to version 4.17.13 or later. #11992

Closed
toptalo opened this issue Jul 15, 2019 · 4 comments

Comments

@toptalo
Copy link

commented Jul 15, 2019

CVE-2019-10744 More information
high severity
Vulnerable versions: < 4.17.13
Patched version: 4.17.13
Affected versions of lodash are vulnerable to Prototype Pollution.
The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.

@toptalo

This comment has been minimized.

Copy link
Author

commented Jul 16, 2019

❤️

@mcandre

This comment has been minimized.

Copy link

commented Jul 18, 2019

ETA for a fresh NPM eslint release version, in order to publish this patch for regular users?

@platinumazure

This comment has been minimized.

Copy link
Member

commented Jul 18, 2019

@mcandre We usually release every 2 weeks on Friday or Saturday, with our next release being this week. You can look at issues with the "release" label to follow the next release in general (or see #11955 for this week's release specifically).

@Lonniebiz

This comment has been minimized.

Copy link

commented Jul 29, 2019

Thanks for fixing this! I no longer see these warnings in 6.1.0:

Lodash

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.