Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Chore: Upgrade eslint-plugin-jsdoc to v25 and remove --legacy-peer-deps #14244

Merged
merged 6 commits into from Mar 25, 2021

Conversation

@btmills
Copy link
Member

@btmills btmills commented Mar 23, 2021

Prerequisites checklist

What is the purpose of this pull request? (put an "X" next to an item)

[ ] Documentation update
[ ] Bug fix (template)
[ ] New rule (template)
[ ] Changes an existing rule (template)
[ ] Add autofixing to a rule
[ ] Add a CLI option
[ ] Add something to the core
[x] Other, please explain: Since #13844 added Node 15 and with it npm v7 to the build matrix, we've had to use --legacy-peer-deps when running npm install with npm v7. This upgrades the last incompatible dependency so we can just npm install in any supported Node/npm version.

What changes did you make? (Give an overview)

  • Chore: Upgrade eslint-plugin-jsdoc to v25

    This is a Chore instead of an Upgrade because it's in devDependencies. v25 is the first release of eslint-plugin-jsdoc to bump the eslint peer dependency to allow eslint@7. Once it's upgraded, we won't have to use --legacy-peer-deps to install dependencies with npm v7. The newer version was unsatisfied with the cliOptions param to translateOptions typed as just Object, so I turned our Optionator config into a JSDoc typedef.

  • Chore: npm v7 no longer needs --legacy-peer-deps (refs #13844)

    eslint-plugin-jsdoc was the last upgrade needed to be compatible with the new peer dependency resolution in npm v7.

Is there anything you'd like reviewers to focus on?

Thanks to npm/cli#2896 (comment) for deciphering the error log and pointing out where the incompatibility was.

btmills added 2 commits Mar 23, 2021
This is a Chore instead of an Upgrade because it's in `devDependencies`.
v25 is the first release of `eslint-plugin-jsdoc` to bump the `eslint`
peer dependency to allow `eslint@7`. Once it's upgraded, we won't have
to use `--legacy-peer-deps` to install dependencies with npm v7. The
newer version was unsatisfied with the `cliOptions` param to
`translateOptions` typed as just `Object`, so I turned our Optionator
config into a JSDoc typedef.
`eslint-plugin-jsdoc` was the last upgrade needed to be compatible with
the new peer dependency resolution in npm v7.
Copy link
Member

@aladdin-add aladdin-add left a comment

LGTM! 💯

Loading

nzakas
nzakas approved these changes Mar 24, 2021
lib/options.js Outdated Show resolved Hide resolved
Loading
lib/options.js Outdated Show resolved Hide resolved
Loading
lib/options.js Outdated Show resolved Hide resolved
Loading
lib/options.js Outdated Show resolved Hide resolved
Loading
lib/options.js Show resolved Hide resolved
Loading
btmills and others added 3 commits Mar 24, 2021
Co-authored-by: Milos Djermanovic <milos.djermanovic@gmail.com>
Co-authored-by: Milos Djermanovic <milos.djermanovic@gmail.com>
lib/options.js Outdated Show resolved Hide resolved
Loading
Co-authored-by: Milos Djermanovic <milos.djermanovic@gmail.com>
@btmills btmills requested a review from mdjermanovic Mar 25, 2021
Copy link
Member

@mdjermanovic mdjermanovic left a comment

LGTM, thanks!

Loading

@mdjermanovic mdjermanovic merged commit 49d1697 into master Mar 25, 2021
13 checks passed
Loading
@mdjermanovic mdjermanovic deleted the no-more-legacy-peer-deps branch Mar 25, 2021
@eslint-github-bot eslint-github-bot bot locked and limited conversation to collaborators Sep 22, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants