Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bangle.js broken notifications #2207

Closed
johan-m-o opened this issue May 27, 2022 · 4 comments
Closed

Bangle.js broken notifications #2207

johan-m-o opened this issue May 27, 2022 · 4 comments

Comments

@johan-m-o
Copy link

johan-m-o commented May 27, 2022

I updated my Bangle.js 2 to 2v13.123, from 2v13.97 (I think it was). After that I can no longer receive any kind of notification from Gadgetbridge, reverting the firmware (to 2v13 stable, since I didn't have access to anything else) makes notifications work again.

The Gadgetbridge Debug app does receive all the relevant information from GB, but for some reason it's not received by Android Integration.

I have no idea what commit caused this, but just wanted to give a heads-up...

@myxor
Copy link
Contributor

myxor commented Jun 1, 2022

I can confirm this.

See also: http://forum.espruino.com/conversations/376541/

@gfwilliams
Copy link
Member

gfwilliams commented Jun 6, 2022

This works for me - judging by that thread, this only applies if you have also installed the weather app? Or maybe also some other app that does similar things with GB. Can you confirm if you've got something else installed?

I'm really struggling to reproduce this with a cut down example though. For instance:

function GB() {
  print("A");
}

Modules.addCached("lib", function() {
  const _GB = global.GB;
  global.GB = (event) => {
    print("B");
    if (_GB) setTimeout(_GB, 0, event);
  };
});


require("lib");

GB();

works fine. Anyone able to provide me with a bit of code that actually reproduces this, so I can actually figure out what's going wrong?

@myxor
Copy link
Contributor

myxor commented Jun 6, 2022

Can confirm that i have installed the weather app.

@johan-m-o
Copy link
Author

johan-m-o commented Jun 6, 2022

I do have the weather app, but simply uninstalling that is not enough to get notifications working on my setup. Some other app I have installed must be interfering in the same way. But, as described in the thread it's pretty easy to reproduce.

nstalling default apps together with Android integration and Messages on the current bleeding edge (2v13.136 tested) has working notifications. But, as soon as the Weather app is installed notifications stop working (and start working again as soon as it's uninstalled).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

3 participants