Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

err="waiting for transactions" #15646

Closed
sevenMonkey opened this issue Dec 11, 2017 · 4 comments

Comments

Projects
None yet
4 participants
@sevenMonkey
Copy link

commented Dec 11, 2017

System information

Geth version: 1.7.3-stable
OS & Version: OSX
Commit hash :

Expected behaviour

Occurs this error when I startup the geth client, I can't search the question in google

geth --datadir "~/Library/Ethereum/ethdev" --dev

WARN [12-11|11:31:52] Block sealing failed err="waiting for transactions"

Actual behaviour

geth --datadir "~/Library/Ethereum/ethdev" --dev

WARN [12-11|11:31:52] Block sealing failed err="waiting for transactions"

Steps to reproduce the behaviour

Backtrace

[backtrace]
@karalabe

This comment has been minimized.

Copy link
Member

commented Dec 14, 2017

In dev mode, the node only mines if there are transactions. Make a transaction and the node will mine it.

@karalabe karalabe closed this Dec 14, 2017

@drozdziak1

This comment has been minimized.

Copy link

commented Aug 11, 2018

I know this is pretty old, but what can I do if I'd like to locally test code which relies on confirmations?

@karalabe

This comment has been minimized.

Copy link
Member

commented Aug 14, 2018

You can force dev mode to seal blocks periodically instead of waiting for transactions via --dev.period=3 (for a 3 second period). You lose instant transactions though. Would that be enough?

@MicahZoltu

This comment has been minimized.

Copy link
Contributor

commented Jan 11, 2019

@karalabe Is it possible to get the instant-block functionality via genesis.json instead of --dev? I have a genesis.json that is setup a certain way for our project, but I am using clique which appears to have a minimum of 1 second blocks. If I try to use --dev geth complains because the rest of my settings are not compatible with that mode.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.