Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Accounts are not showing in Mist0.8.5 #1308

Open
prashantprabhakar opened this issue Oct 17, 2016 · 9 comments

Comments

Projects
None yet
7 participants
@prashantprabhakar
Copy link

commented Oct 17, 2016

System information

Version: `0.8.5`
OS & Version: linux
Node type: `geth(default)`

Accounts are not showing up in Mist 0.8.5.But I can see my accounts in keystore folder of .ethereum directory. I even added a new account to Mist, but that too did't show up but one more file was added in keystore representing newly created account.
Even on checking developer's tool of Mist, I can see all my accounts when I enter web3.eth.accounts.
So why accounts are not showing up in wallet?
no accounts

@luclu

This comment has been minimized.

Copy link
Member

commented Oct 17, 2016

@prashantprabhakar could you please try to:

  1. restart the wallet
  2. add another account, click it and go back to the wallet screen
@prashantprabhakar

This comment has been minimized.

Copy link
Author

commented Oct 17, 2016

Yes, I have already done both the steps. Whenever I create a new account, a new file is added in keystore. But nothing appears on Mist screen. I can see a generating wallet popup box after entering my password, and then nothing..A fresh wallet screen is in from of me without any accounts.

@optymusGrime

This comment has been minimized.

Copy link

commented Oct 17, 2016

I'm experiencing the same problem also followed steps outlined by @luclu. can verify the issue.

Windows x64 build (running on win 10)

@hiddentao

This comment has been minimized.

Copy link
Contributor

commented Oct 17, 2016

Could you please open the Javascript Console of Mist and paste here what you see.

@prashantprabhakar

This comment has been minimized.

Copy link
Author

commented Oct 17, 2016

Console ouptut for v0.8.5:

Failed to load resource: net::ERR_FILE_NOT_FOUND file:///home/gemini/Ethereum/EthereumWallet0.8.5/Users/ich/github/mist/dist…/wallet/packages/ethereum_dapp-styles/fonts/SourceSansPro-ExtraLightIt.otf Failed to load resource: net::ERR_FILE_NOT_FOUND

Failed to load resource: net::ERR_FILE_NOT_FOUND file:///sockjs/info?cb=nvxj0vet33 Failed to load resource: net::ERR_FILE_NOT_FOUND

Node started syncing, stopping app operation @ file:///home/gemini/Ethereum/EthereumWallet0.8.5/Users/ich/github/mist/dist….asar/interface/wallet/f6e44fd3a6364a5106154cdf3516a4cbc1c24963.js:368:378

I updated my wallet to v 0.8.6. Still facing same issue.

@hiddentao

This comment has been minimized.

Copy link
Contributor

commented Oct 17, 2016

Hmm, not a lot of info to go on there. I’ll have to do some testing locally.

-- 
Ramesh Nair

Director
HiddenTao Ltd (UK company no. 6807289)

http://hiddentao.com
https://github.com/hiddentao
https://www.linkedin.com/in/hiddentao

On 17 October 2016 at 13:49:40, prashantprabhakar (notifications@github.com) wrote:

Console ouptut:

Failed to load resource: net::ERR_FILE_NOT_FOUND file:///home/gemini/Ethereum/EthereumWallet0.8.5/Users/ich/github/mist/dist…/wallet/packages/ethereum_dapp-styles/fonts/SourceSansPro-ExtraLightIt.otf Failed to load resource: net::ERR_FILE_NOT_FOUND

Failed to load resource: net::ERR_FILE_NOT_FOUND file:///sockjs/info?cb=nvxj0vet33 Failed to load resource: net::ERR_FILE_NOT_FOUND

Node started syncing, stopping app operation @ file:///home/gemini/Ethereum/EthereumWallet0.8.5/Users/ich/github/mist/dist….asar/interface/wallet/f6e44fd3a6364a5106154cdf3516a4cbc1c24963.js:368:378


You are receiving this because you commented.
Reply to this email directly, view it on GitHub, or mute the thread.

@ddsjangster

This comment has been minimized.

Copy link

commented Oct 17, 2016

I am experiencing the same issue with Ethereum Wallet v.0.8.6 as prasantprabhakar. i.e. Wallet is syncing, but the balance in my accounts shows 0 despite UTC files being in the correct keystore folder. What happened and how to fix it so I can see my correct ETH balance?

@jones-in-the-fast-lane

This comment has been minimized.

Copy link

commented Oct 18, 2016

This also happens to me (since 0.8.4) and again in 0.8.6. Wallet file is in correct folder.

Win 7 64bit

@prashantprabhakar

This comment has been minimized.

Copy link
Author

commented Oct 20, 2016

@hiddentao I am also facing same issues with latest Ethereum Wallet 0.8.6. I think the issue lies in that Wallet cann't read files from keystore properly. Because after I removed everything and started downloading blockchain again, I created some accounts but none of them appeared on my wallet screen. but after restarting Mist, all are visible. Again I deleted 3 accounts out of 7 from keystore, but still Mist is showing all 7 accounts, If I check from geth I can see 4 accounts. SO geth and keystore are in agreement but Ethereum-Wallet isn't.

@luclu luclu added the Type: Bug label Oct 21, 2016

@luclu luclu added this to the 0.8.7 milestone Oct 21, 2016

@evertonfraga evertonfraga modified the milestones: 0.8.7, 0.8.8 Oct 26, 2016

@evertonfraga evertonfraga modified the milestones: 0.8.8, 0.9 Dec 16, 2016

@mist-bot mist-bot bot added the Status: Triage label Jan 27, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.