fix and update package.json/npm-shrinkwrap.json #1194

Merged
merged 1 commit into from Sep 27, 2016

Projects

None yet

2 participants

@luclu
Member
luclu commented Sep 24, 2016 edited

fixes #1188, #1208

npm dependency graph was broken, test this via:

  1. uninstall every falsy globally installed module
  2. rm -r node_modules
  3. try to npm install

This PR will:

  1. add unmet deps (tslint@3.15.1, typescript@1.7.3) (npm install --save )
  2. update and cleanup npm-shrinkwrap.json via npm install; npm prune; npm shrinkwrap
    • changes:
      • update version string to 0.8.3
      • add both modules (1.) to package.json
      • updates shrinkwrap's dependency graph
        • removes electron-builder as it is only a development package (--save-dev)

Tested on:

  • mac: mac, linux, win builds
  • linux: linux build
@luclu luclu added the please review label Sep 24, 2016
@evertonfraga
Member

It worked properly

@evertonfraga evertonfraga merged commit c0d8c75 into ethereum:develop Sep 27, 2016

1 check failed

continuous-integration/travis-ci/pr The Travis CI build failed
Details
@luclu luclu deleted the luclu:update-npm-shrinkwrap branch Oct 8, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment