New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't install web3 with yarn #1070

Closed
jonbesga opened this Issue Sep 22, 2017 · 20 comments

Comments

Projects
None yet
@jonbesga

jonbesga commented Sep 22, 2017

Hi, I'm having some problems installing web3 with Yarn

I'm using Yarn 1.0.2 and Node 8.5.0

╰─○ yarn add web3                                                                                                                                 
yarn add v1.0.2                                                                                                                                   
[1/4] Resolving packages...                                                                                                                       
Couldn't find any versions for "web3-net" that matches "^1.1.0"          
? Please choose a version of "web3-net" from this list: (Use arrow keys) 
❯ 1.0.0-beta.21                     
  1.0.0-beta.20                     
  1.0.0-beta.19                     
  1.0.0-beta.18                     
  1.0.0-beta.17                     
  1.0.0-beta.16                     
  1.0.0-beta.15                     
  1.0.0-beta.14                     
  1.0.0-beta.13                     
  1.0.0-beta.12                     
  1.0.0-beta.11                     
  1.0.0-beta.10                     
  1.0.0-beta.9                      
  1.0.0-beta.8                      
Couldn't find any versions for "web3-utils" that matches "^1.1.0"        
? Please choose a version of "web3-utils" from this list: (Use arrow keys) 
❯ 1.0.0-beta.21                     
  1.0.0-beta.20                     
  1.0.0-beta.19                     
  1.0.0-beta.17                     
  1.0.0-beta.16                     
  1.0.0-beta.15                     
  1.0.0-beta.14                     
  1.0.0-beta.13                     
  1.0.0-beta.12                     
  1.0.0-beta.11                     
  1.0.0-beta.10                     
  1.0.0-beta.9                      
  1.0.0-beta.8                      
warning minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
error Couldn't find package "web3-core-promiEvent" on the "npm" registry.
info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.
Error: Couldn't find package "web3-requestManager" on the "npm" registry.
    at /usr/lib/node_modules/yarn/lib/cli.js:48173:15
    at Generator.next (<anonymous>)
    at step (/usr/lib/node_modules/yarn/lib/cli.js:92:30)
    at /usr/lib/node_modules/yarn/lib/cli.js:103:13
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)
@perissology

This comment has been minimized.

Show comment
Hide comment
@perissology

perissology Sep 23, 2017

related to #994

This is due to a bug in yarn where it resolves the lerna-tmp tag and not the latest. yarnpkg/yarn#4208

perissology commented Sep 23, 2017

related to #994

This is due to a bug in yarn where it resolves the lerna-tmp tag and not the latest. yarnpkg/yarn#4208

@frozeman

This comment has been minimized.

Show comment
Hide comment
@frozeman

frozeman Sep 25, 2017

Member

I can't find any lerna-tmp in the 1.0 branch of the repo.

Member

frozeman commented Sep 25, 2017

I can't find any lerna-tmp in the 1.0 branch of the repo.

@perissology

This comment has been minimized.

Show comment
Hide comment
@perissology

perissology Sep 25, 2017

@frozeman

run npm info web3-core and it is listed

  'dist-tags': { 'lerna-temp': '1.1.0', latest: '1.0.0-beta.21' },

perissology commented Sep 25, 2017

@frozeman

run npm info web3-core and it is listed

  'dist-tags': { 'lerna-temp': '1.1.0', latest: '1.0.0-beta.21' },
@OR13

This comment has been minimized.

Show comment
Hide comment
@OR13

OR13 Sep 30, 2017

yarn add web3@beta let me pick. note sure if this is wise to do.

OR13 commented Sep 30, 2017

yarn add web3@beta let me pick. note sure if this is wise to do.

@frozeman

This comment has been minimized.

Show comment
Hide comment
@frozeman

frozeman Oct 20, 2017

Member

I removed the distilled tag. This was added by a person who accidentally released web3-core under his name, before i ever published it. I had to contact quite a few people to get this repo under my control :P back then. I now removed the tag, please let me know if it solves your issues.

Member

frozeman commented Oct 20, 2017

I removed the distilled tag. This was added by a person who accidentally released web3-core under his name, before i ever published it. I had to contact quite a few people to get this repo under my control :P back then. I now removed the tag, please let me know if it solves your issues.

@frozeman frozeman closed this Oct 20, 2017

@remiroyc

This comment has been minimized.

Show comment
Hide comment
@remiroyc

remiroyc Oct 20, 2017

Same issue here

remiroyc commented Oct 20, 2017

Same issue here

@boorac

This comment has been minimized.

Show comment
Hide comment
@boorac

boorac Oct 22, 2017

Same here

boorac commented Oct 22, 2017

Same here

@fernandoBRS

This comment has been minimized.

Show comment
Hide comment
@fernandoBRS

fernandoBRS Oct 22, 2017

Same issue here too.

fernandoBRS commented Oct 22, 2017

Same issue here too.

@feleio

This comment has been minimized.

Show comment
Hide comment
@feleio

feleio Oct 22, 2017

Same issue here

feleio commented Oct 22, 2017

Same issue here

@Zolmeister

This comment has been minimized.

Show comment
Hide comment
@Zolmeister

Zolmeister Oct 23, 2017

workaround... yarn add web3@^0.19.0

Zolmeister commented Oct 23, 2017

workaround... yarn add web3@^0.19.0

@MrHash

This comment has been minimized.

Show comment
Hide comment
@MrHash

MrHash Oct 24, 2017

same prob

MrHash commented Oct 24, 2017

same prob

@spherefoundry

This comment has been minimized.

Show comment
Hide comment
@spherefoundry

spherefoundry Oct 25, 2017

@frozeman Still not working with yarn.

Couldn't find any versions for "web3-utils" that matches "^1.1.0"

I tried the previous versions and 1.0.0-beta.20 is the last that works.

spherefoundry commented Oct 25, 2017

@frozeman Still not working with yarn.

Couldn't find any versions for "web3-utils" that matches "^1.1.0"

I tried the previous versions and 1.0.0-beta.20 is the last that works.

@dacarley

This comment has been minimized.

Show comment
Hide comment
@dacarley

dacarley Oct 25, 2017

dacarley commented Oct 25, 2017

@Moejoe90

This comment has been minimized.

Show comment
Hide comment
@Moejoe90

Moejoe90 Nov 27, 2017

Same issue here with web3-utils

Moejoe90 commented Nov 27, 2017

Same issue here with web3-utils

@dacarley

This comment has been minimized.

Show comment
Hide comment
@dacarley

dacarley Nov 27, 2017

What error are you seeing exactly?

Here's what I currently get:

Node 4.8.4, Yarn 1.32

yarn add web3-utils

[1/4] 🔍  Resolving packages...
[2/4] 🚚  Fetching packages...
error ethjs-unit@0.1.6: The engine "node" is incompatible with this module. Expected version ">=6.5.0".
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.

Node 6.11.5, Yarn 1.32

yarn add web3-utils

yarn add v1.3.2
[1/4] 🔍  Resolving packages...
[2/4] 🚚  Fetching packages...
[3/4] 🔗  Linking dependencies...
[4/4] 📃  Building fresh packages...
success Saved 1 new dependency.
└─ web3-utils@1.0.0-beta.26
✨  Done in 4.12s.

dacarley commented Nov 27, 2017

What error are you seeing exactly?

Here's what I currently get:

Node 4.8.4, Yarn 1.32

yarn add web3-utils

[1/4] 🔍  Resolving packages...
[2/4] 🚚  Fetching packages...
error ethjs-unit@0.1.6: The engine "node" is incompatible with this module. Expected version ">=6.5.0".
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.

Node 6.11.5, Yarn 1.32

yarn add web3-utils

yarn add v1.3.2
[1/4] 🔍  Resolving packages...
[2/4] 🚚  Fetching packages...
[3/4] 🔗  Linking dependencies...
[4/4] 📃  Building fresh packages...
success Saved 1 new dependency.
└─ web3-utils@1.0.0-beta.26
✨  Done in 4.12s.
@kriffo

This comment has been minimized.

Show comment
Hide comment
@kriffo

kriffo Jan 21, 2018

Samesies

kriffo commented Jan 21, 2018

Samesies

@jonbesga

This comment has been minimized.

Show comment
Hide comment
@jonbesga

jonbesga Jan 26, 2018

It's not happening anymore. Using Yarn 1.3.2 and Node 9.4.0

jonbesga commented Jan 26, 2018

It's not happening anymore. Using Yarn 1.3.2 and Node 9.4.0

@lukasink

This comment has been minimized.

Show comment
Hide comment
@lukasink

lukasink Mar 1, 2018

Was having issues previously on yarn version 1.2.1 and node v9.6.1. Upgraded yarn to 1.5.1 and was able to get web3 installed without issue. Just adding another confirmation that the issue appears solved with latest versions

lukasink commented Mar 1, 2018

Was having issues previously on yarn version 1.2.1 and node v9.6.1. Upgraded yarn to 1.5.1 and was able to get web3 installed without issue. Just adding another confirmation that the issue appears solved with latest versions

@manfye

This comment has been minimized.

Show comment
Hide comment
@manfye

manfye Mar 12, 2018

still the same problem

manfye commented Mar 12, 2018

still the same problem

@MarekJavurek

This comment has been minimized.

Show comment
Hide comment
@MarekJavurek

MarekJavurek Jun 8, 2018

@frozeman can you please provide some help?

MarekJavurek commented Jun 8, 2018

@frozeman can you please provide some help?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment