Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Corrupted cross-built pom for classcycle #56

Closed
djspiewak opened this Issue Feb 8, 2012 · 2 comments

Comments

Projects
None yet
2 participants
[info] Resolving org.specs2#classycle_2.9.1;1.4 ...
[error]     public: bad module name found in http://repo1.maven.org/maven2/org/specs2/classycle_2.9.1/1.4/classycle_2.9.1-1.4.pom: expected='classycle_2.9.1 found='classycle'
[error]     Scala-Tools Maven2 Repository: bad module name found in http://scala-tools.org/repo-releases/org/specs2/classycle_2.9.1/1.4/classycle_2.9.1-1.4.pom: expected='classycle_2.9.1 found='classycle'
[warn]  ::::::::::::::::::::::::::::::::::::::::::::::
[warn]  ::          UNRESOLVED DEPENDENCIES         ::
[warn]  ::::::::::::::::::::::::::::::::::::::::::::::
[warn]  :: org.specs2#classycle_2.9.1;1.4: several problems occurred while resolving dependency: org.specs2#classycle_2.9.1;1.4 {optional=[default(compile)]}:
[warn]  java.text.ParseException: inconsistent module descriptor file found in 'http://repo1.maven.org/maven2/org/specs2/classycle_2.9.1/1.4/classycle_2.9.1-1.4.pom': bad module name: expected='classycle_2.9.1' found='classycle'; 
[warn]  java.text.ParseException: inconsistent module descriptor file found in 'http://scala-tools.org/repo-releases/org/specs2/classycle_2.9.1/1.4/classycle_2.9.1-1.4.pom': bad module name: expected='classycle_2.9.1' found='classycle'; 
[warn]  ::::::::::::::::::::::::::::::::::::::::::::::
[error] {file:/Users/daniel/Development/Scala/specs2/}default-99774c/*:update: sbt.ResolveException: unresolved dependency: org.specs2#classycle_2.9.1;1.4: several problems occurred while resolving dependency: org.specs2#classycle_2.9.1;1.4 {optional=[default(compile)]}:
[error]     java.text.ParseException: inconsistent module descriptor file found in 'http://repo1.maven.org/maven2/org/specs2/classycle_2.9.1/1.4/classycle_2.9.1-1.4.pom': bad module name: expected='classycle_2.9.1' found='classycle'; 
[error]     java.text.ParseException: inconsistent module descriptor file found in 'http://scala-tools.org/repo-releases/org/specs2/classycle_2.9.1/1.4/classycle_2.9.1-1.4.pom': bad module name: expected='classycle_2.9.1' found='classycle'; 
[error] Total time: 3 s, completed Feb 8, 2012 10:22:31 AM

At this time, I'm unable to build specs2 locally.

Owner

etorreborre commented Feb 8, 2012

Sorry about that Daniel. I just created a branch with no classycle dependency which you can build from: https://github.com/etorreborre/specs2/tree/1.8-no-classycle.

Then I'll fix up this mess this week-end (my first problem was that no one ever deployed the classycle jar to any repository).

@etorreborre etorreborre closed this Feb 8, 2012

Awesome; thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment