0.93 Ubuntu Offline Bundle Fail #270

Open
rapodaca opened this Issue Mar 16, 2015 · 5 comments

Projects

None yet

3 participants

@rapodaca

Tried running Install_DoubleClick_RunInTerminal.sh on a clean install of Ubuntu 12.04.5. Got this output:

$ ./Install_DoubleClick_RunInTerminal.sh
[sudo] password for rich:
Selecting previously unselected package armory.
(Reading database ... 144392 files and directories currently installed.)
Unpacking armory (from armory_0.93_ubuntu-64bit.deb) ...
Selecting previously unselected package dpkg-sig.
Unpacking dpkg-sig (from dpkg-sig_0.13.1_all.deb) ...
Selecting previously unselected package libqt4-designer.
Unpacking libqt4-designer (from libqt4-designer_4.8.1-0ubuntu4.8_amd64.deb) ...
Selecting previously unselected package libqt4-help.
Unpacking libqt4-help (from libqt4-help_4.8.1-0ubuntu4.8_amd64.deb) ...
Selecting previously unselected package libqt4-scripttools.
Unpacking libqt4-scripttools (from libqt4-scripttools_4.8.1-0ubuntu4.8_amd64.deb) ...
Selecting previously unselected package libqt4-test.
Unpacking libqt4-test (from libqt4-test_4.8.1-0ubuntu4.8_amd64.deb) ...
Selecting previously unselected package libqtassistantclient4.
Unpacking libqtassistantclient4 (from libqtassistantclient4_4.6.3-3ubuntu2_amd64.deb) ...
Selecting previously unselected package libqtwebkit4.
Unpacking libqtwebkit4 (from libqtwebkit4_2.2.1-1ubuntu4_amd64.deb) ...
Selecting previously unselected package python-psutil.
Unpacking python-psutil (from python-psutil_0.4.1-1ubuntu1_amd64.deb) ...
Selecting previously unselected package python-pyasn1.
Unpacking python-pyasn1 (from python-pyasn1_0.0.11a-1ubuntu1_all.deb) ...
Selecting previously unselected package python-qt4.
Unpacking python-qt4 (from python-qt4_4.9.1-2ubuntu1_amd64.deb) ...
Selecting previously unselected package python-sip.
Unpacking python-sip (from python-sip_4.13.2-1_amd64.deb) ...
Selecting previously unselected package python-twisted.
Unpacking python-twisted (from python-twisted_11.1.0-1ubuntu2_all.deb) ...
Selecting previously unselected package python-twisted-conch.
Unpacking python-twisted-conch (from python-twisted-conch_11.1.0-1_all.deb) ...
Selecting previously unselected package python-twisted-lore.
Unpacking python-twisted-lore (from python-twisted-lore_11.1.0-1_all.deb) ...
Selecting previously unselected package python-twisted-mail.
Unpacking python-twisted-mail (from python-twisted-mail_11.1.0-1_all.deb) ...
Selecting previously unselected package python-twisted-news.
Unpacking python-twisted-news (from python-twisted-news_11.1.0-1_all.deb) ...
Selecting previously unselected package python-twisted-runner.
Unpacking python-twisted-runner (from python-twisted-runner_11.1.0-1_amd64.deb) ...
Selecting previously unselected package python-twisted-words.
Unpacking python-twisted-words (from python-twisted-words_11.1.0-1_all.deb) ...
dpkg: dependency problems prevent configuration of armory:
armory depends on libstdc++6 (>= 4.7); however:
Version of libstdc++6 on system is 4.6.3-1ubuntu5.
dpkg: error processing armory (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dpkg-sig:
dpkg-sig depends on libconfig-file-perl; however:
Package libconfig-file-perl is not installed.
dpkg: error processing dpkg-sig (--install):
dependency problems - leaving unconfigured
Setting up libqt4-designer (4:4.8.1-0ubuntu4.8) ...
Setting up libqt4-help (4:4.8.1-0ubuntu4.8) ...
Setting up libqt4-scripttools (4:4.8.1-0ubuntu4.8) ...
Setting up libqt4-test (4:4.8.1-0ubuntu4.8) ...
Setting up libqtassistantclient4 (4.6.3-3ubuntu2) ...
Setting up libqtwebkit4 (2.2.1-1ubuntu4) ...
Setting up python-psutil (0.4.1-1ubuntu1) ...
Setting up python-pyasn1 (0.0.11a-1ubuntu1) ...
Setting up python-sip (4.13.2-1) ...
Setting up python-twisted-lore (11.1.0-1) ...
Setting up python-twisted-mail (11.1.0-1) ...
Setting up python-twisted-news (11.1.0-1) ...
Setting up python-twisted-runner (11.1.0-1) ...
Setting up python-twisted-words (11.1.0-1) ...
Setting up python-qt4 (4.9.1-2ubuntu1) ...
Processing triggers for doc-base ...
Processing 29 changed doc-base files, 2 added doc-base files...
Setting up python-twisted-conch (1:11.1.0-1) ...
Processing triggers for python-twisted-core ...
Processing triggers for man-db ...
Setting up python-twisted (11.1.0-1ubuntu2) ...
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
armory
dpkg-sig

I expected to be able to run this script and then start using Armory.

Which minor dot release of Ubuntu 12.04 (12.04.1, 12.04.2 ... 12.04.5) was the Offline Bundle tested with?

@josephbisch

These lines detail what is wrong with installing Armory itself:

dpkg: dependency problems prevent configuration of armory:
armory depends on libstdc++6 (>= 4.7); however:
Version of libstdc++6 on system is 4.6.3-1ubuntu5.

It appears that a dependency on libstdc++6 of at least version 4.7 was introduced (accidentally?) in the latest version of Armory. The latest version of libstdc++6 that any Ubuntu 12.04 install can have is 4.6.3.

It might be a good idea to try contacting Armory through their official support channel. I don't think they check these issues often.

You might also want to let them know about the following issue:

dpkg: dependency problems prevent configuration of dpkg-sig:
dpkg-sig depends on libconfig-file-perl; however:
Package libconfig-file-perl is not installed.

It looks like they have to add libconfig-file-perl and its dependencies to the offline bundle, so that dpkg-sig can be installed.

@droark
Collaborator
droark commented Mar 16, 2015

Hello. Sorry about the goof. We're working on a permanent solution for this issue. In the meantime, the following workaround works for me and should work for others too.

Go to http://askubuntu.com/questions/113291/how-do-i-install-gcc-4-7/315220#315220 and follow the directions there. This should be enough to get you going. If not, let us know what issues you're still seeing.

Thanks.

@rapodaca

@droark Thanks for the information. Three questions about the workaround:

  1. Does this require a network connection? That's a non-starter for an offline computer.
  2. There was also a problem with libconfig-file-perl not being present in the Offline Bundle. How should I address that?
  3. Which minor revision of Ubuntu 12.04 would be the best to try? I've seen reports that this can be significant. For example:

https://bitcointalk.org/index.php?topic=519117.0

@droark
Collaborator
droark commented Mar 17, 2015

Hello.

1)It should be possible to download a package on a networked computer, place it on an SD card (or whatever) and move it over to the offline machine. http://stackoverflow.com/questions/4419268/how-do-i-download-a-package-from-apt-get-without-installing-it has one example, with the caveat that I haven't tried this myself.

2)Same deal. FWIW, I didn't have to deal with this on 12.04.5.

3)I used 12.04.5 when I was troubleshooting this a few days ago.

@rapodaca

Thanks for the info. I've put together a summary of my solution here:

http://bitzuma.com/posts/offline-installation-of-armory-on-tails-and-ubuntu-linux/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment