Permalink
Browse files

fix ant version check in configure; drop old MySQL DBs during upgrade

  • Loading branch information...
1 parent 522081e commit 143e126af854ef990756d0b267b8b0070f4b7c30 Andy Grimm committed Jun 28, 2011
Showing with 4 additions and 4 deletions.
  1. +2 −2 configure
  2. +2 −2 configure.ac
View
@@ -4851,8 +4851,8 @@ if test ! -e $JAVA_HOME/include/jni.h ; then
as_fn_error $? "Cannot find jni.h in $JAVA_HOME: do you have a JDK installed?" "$LINENO" 5
fi
-ant_version=`$ANT -version 2>&1 | grep "Ant version" | \
- sed -e 's/.*Ant version \([0-9.]*\).*/\1/'`
+ant_version=`$ANT -version 2>&1 | grep "Ant.* version" | \
+ sed -e 's/.*Ant.* version \([0-9.]*\).*/\1/'`
goodversion=`expr $ant_version ">=" $ant_min_version`
if test $goodversion -eq 0; then
as_fn_error $? "Eucalyptus needs at least ANT version $ant_min_version" "$LINENO" 5
View
@@ -191,8 +191,8 @@ if test ! -e $JAVA_HOME/include/jni.h ; then
AC_MSG_ERROR([Cannot find jni.h in $JAVA_HOME: do you have a JDK installed?])
fi
-ant_version=`$ANT -version 2>&1 | grep "Ant version" | \
- sed -e 's/.*Ant version \([[0-9.]]*\).*/\1/'`
+ant_version=`$ANT -version 2>&1 | grep "Ant.* version" | \
+ sed -e 's/.*Ant.* version \([[0-9.]]*\).*/\1/'`
goodversion=`expr $ant_version ">=" $ant_min_version`
if test $goodversion -eq 0; then
AC_MSG_ERROR([Eucalyptus needs at least ANT version $ant_min_version])

0 comments on commit 143e126

Please sign in to comment.