New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Youtube Videos not showing up #5

Open
saifulmuhajir opened this Issue Mar 17, 2018 · 5 comments

Comments

Projects
None yet
5 participants
@saifulmuhajir
Copy link

saifulmuhajir commented Mar 17, 2018

Using singleViewStyle = "casper" causing Youtube videos not showing up on single post view. On the other hand, putting "caspertwo" showing Youtube videos just fine.

@shah

This comment has been minimized.

Copy link

shah commented May 20, 2018

I've got the same issue @eueung -- any idea how we can fix this issue? Thanks!

@rguske

This comment has been minimized.

Copy link

rguske commented Jul 25, 2018

@eueung I´d appreciate if you could share any thoughts. I´m facing the same issue. Thanks a lot.

@softinio

This comment has been minimized.

Copy link

softinio commented Jul 30, 2018

I am having this issue too. As a workaround I have created my own shortcode for youtube in the meanwhile in case anyone wants to use:

I created this layout/shortcodes/yt.html:

  <iframe src="https://www.youtube.com/embed/{{ index .Params 0 }}?start={{ index .Params 1 }}"
  style="position: absolute; top: 0; left: 0; width: 560; height: 315;" allowfullscreen frameborder="0" title="YouTube Video"></iframe>

Which creates a new shortcode called yt so I use it like this:

{{< yt adfadadaa >}}
@rguske

This comment has been minimized.

Copy link

rguske commented Jul 30, 2018

Awesome @softinio! I immediately tried it out and it works smoothly! Thanks a lot for this!
FYI @eueung @shah @saifulmuhajir

@timhere

This comment has been minimized.

Copy link

timhere commented Oct 10, 2018

I'm also having this issue. I've looked in devtools and the shortcode is working as the iframe is present in the markup.

I assume this is a styling issue.

jcfischer added a commit to jcfischer/hugo-chaschper that referenced this issue Dec 31, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment