New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tomcat 8.0.28 failed to start after adding um-webapp #73

Closed
manojsharma20 opened this Issue Dec 23, 2016 · 12 comments

Comments

Projects
None yet
2 participants
@manojsharma20

manojsharma20 commented Dec 23, 2016

Tomcat 8.0.28 failed to start after adding um-webapp in lession 4 of module 1 in tomcat8. I have followed your all step mention until you try to run the program.

I have did not make any changes, i have just added the webapp module into apache tomcat 8 which was newly created by me.

Error Stack

INFO: Starting Servlet Engine: Apache Tomcat/8.0.28
Dec 23, 2016 1:13:35 PM org.apache.catalina.util.SessionIdGeneratorBase createSecureRandom
INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [108] milliseconds.
Dec 23, 2016 1:13:35 PM org.apache.catalina.core.ContainerBase startInternal
SEVERE: A child container failed during start
java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/um-webapp]]
at java.util.concurrent.FutureTask.report(FutureTask.java:122)
at java.util.concurrent.FutureTask.get(FutureTask.java:192)
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:916)
at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:871)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1408)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1398)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/um-webapp]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
... 6 more
Caused by: org.apache.catalina.LifecycleException: Failed to start component [org.apache.catalina.webresources.StandardRoot@142f9f8a]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:4854)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:4984)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 6 more
Caused by: org.apache.catalina.LifecycleException: Failed to initialize component [org.apache.catalina.webresources.JarResourceSet@22651f32]
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
at org.apache.catalina.webresources.StandardRoot.startInternal(StandardRoot.java:699)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 9 more
Caused by: java.lang.IllegalArgumentException: java.util.zip.ZipException: invalid LOC header (bad signature)
at org.apache.catalina.webresources.JarResourceSet.initInternal(JarResourceSet.java:96)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
... 12 more
Caused by: java.util.zip.ZipException: invalid LOC header (bad signature)
at java.util.zip.ZipFile.read(Native Method)
at java.util.zip.ZipFile.access$1400(ZipFile.java:61)
at java.util.zip.ZipFile$ZipFileInputStream.read(ZipFile.java:717)
at java.util.zip.ZipFile$ZipFileInflaterInputStream.fill(ZipFile.java:420)
at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:158)
at sun.misc.IOUtils.readFully(IOUtils.java:65)
at java.util.jar.JarFile.getBytes(JarFile.java:425)
at java.util.jar.JarFile.getManifestFromReference(JarFile.java:193)
at java.util.jar.JarFile.getManifest(JarFile.java:180)
at org.apache.catalina.webresources.JarResourceSet.initInternal(JarResourceSet.java:94)
... 13 more

Dec 23, 2016 1:13:35 PM org.apache.catalina.core.ContainerBase startInternal
SEVERE: A child container failed during start
java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost]]
at java.util.concurrent.FutureTask.report(FutureTask.java:122)
at java.util.concurrent.FutureTask.get(FutureTask.java:192)
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:916)
at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:262)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.StandardService.startInternal(StandardService.java:439)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:769)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.startup.Catalina.start(Catalina.java:625)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:351)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:485)
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1408)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1398)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.catalina.LifecycleException: A child container failed during start
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:924)
at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:871)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 6 more

Dec 23, 2016 1:13:35 PM org.apache.catalina.startup.Catalina start
SEVERE: The required Server component failed to start so Tomcat is unable to start.
org.apache.catalina.LifecycleException: Failed to start component [StandardServer[8005]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.startup.Catalina.start(Catalina.java:625)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:351)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:485)
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardService[Catalina]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:769)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 7 more
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.core.StandardService.startInternal(StandardService.java:439)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 9 more
Caused by: org.apache.catalina.LifecycleException: A child container failed during start
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:924)
at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:262)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 11 more

Dec 23, 2016 1:13:35 PM org.apache.coyote.AbstractProtocol pause
INFO: Pausing ProtocolHandler ["http-nio-8080"]
Dec 23, 2016 1:13:35 PM org.apache.coyote.AbstractProtocol pause
INFO: Pausing ProtocolHandler ["ajp-nio-8009"]
Dec 23, 2016 1:13:35 PM org.apache.catalina.core.StandardService stopInternal
INFO: Stopping service Catalina
Dec 23, 2016 1:13:35 PM org.apache.coyote.AbstractProtocol destroy
INFO: Destroying ProtocolHandler ["http-nio-8080"]
Dec 23, 2016 1:13:35 PM org.apache.coyote.AbstractProtocol destroy
SEVERE: Failed to destroy end point associated with ProtocolHandler ["http-nio-8080"]
java.lang.NullPointerException
at org.apache.tomcat.util.net.NioEndpoint.releaseCaches(NioEndpoint.java:305)
at org.apache.tomcat.util.net.NioEndpoint.unbind(NioEndpoint.java:481)
at org.apache.tomcat.util.net.AbstractEndpoint.destroy(AbstractEndpoint.java:823)
at org.apache.coyote.AbstractProtocol.destroy(AbstractProtocol.java:532)
at org.apache.catalina.connector.Connector.destroyInternal(Connector.java:1023)
at org.apache.catalina.util.LifecycleBase.destroy(LifecycleBase.java:305)
at org.apache.catalina.core.StandardService.destroyInternal(StandardService.java:588)
at org.apache.catalina.util.LifecycleBase.destroy(LifecycleBase.java:305)
at org.apache.catalina.core.StandardServer.destroyInternal(StandardServer.java:859)
at org.apache.catalina.util.LifecycleBase.destroy(LifecycleBase.java:305)
at org.apache.catalina.startup.Catalina.start(Catalina.java:629)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:351)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:485)

Dec 23, 2016 1:13:35 PM org.apache.coyote.AbstractProtocol destroy
INFO: Destroying ProtocolHandler ["ajp-nio-8009"]
Dec 23, 2016 1:13:35 PM org.apache.coyote.AbstractProtocol destroy
SEVERE: Failed to destroy end point associated with ProtocolHandler ["ajp-nio-8009"]
java.lang.NullPointerException
at org.apache.tomcat.util.net.NioEndpoint.releaseCaches(NioEndpoint.java:305)
at org.apache.tomcat.util.net.NioEndpoint.unbind(NioEndpoint.java:481)
at org.apache.tomcat.util.net.AbstractEndpoint.destroy(AbstractEndpoint.java:823)
at org.apache.coyote.AbstractProtocol.destroy(AbstractProtocol.java:532)
at org.apache.catalina.connector.Connector.destroyInternal(Connector.java:1023)
at org.apache.catalina.util.LifecycleBase.destroy(LifecycleBase.java:305)
at org.apache.catalina.core.StandardService.destroyInternal(StandardService.java:588)
at org.apache.catalina.util.LifecycleBase.destroy(LifecycleBase.java:305)
at org.apache.catalina.core.StandardServer.destroyInternal(StandardServer.java:859)
at org.apache.catalina.util.LifecycleBase.destroy(LifecycleBase.java:305)
at org.apache.catalina.startup.Catalina.start(Catalina.java:629)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:351)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:485)

@eugenp

This comment has been minimized.

Show comment
Hide comment
@eugenp

eugenp Dec 23, 2016

Owner

Hmm - it looks like you have some corrupted library locally. It happens quite rarely, but it does happen.
Try to clear your local maven repo and build again.
I just tried to run the project on Tomcat 8.0.39 and it works fine.

Hope that helps.
Cheers,
Eugen.

Owner

eugenp commented Dec 23, 2016

Hmm - it looks like you have some corrupted library locally. It happens quite rarely, but it does happen.
Try to clear your local maven repo and build again.
I just tried to run the project on Tomcat 8.0.39 and it works fine.

Hope that helps.
Cheers,
Eugen.

@manojsharma20

This comment has been minimized.

Show comment
Hide comment
@manojsharma20

manojsharma20 Dec 23, 2016

I have download the fresh module 1 from https://github.com/eugenp/REST-With-Spring/tree/module1 and extracted into my drive. Then i have import existing maven project and select lesson 4 of module 4 and just run the um-webapp on project.

Still i am getting same issue. Cloud you please send me you project file.

manojsharma20 commented Dec 23, 2016

I have download the fresh module 1 from https://github.com/eugenp/REST-With-Spring/tree/module1 and extracted into my drive. Then i have import existing maven project and select lesson 4 of module 4 and just run the um-webapp on project.

Still i am getting same issue. Cloud you please send me you project file.

@manojsharma20

This comment has been minimized.

Show comment
Hide comment
@manojsharma20

manojsharma20 Dec 23, 2016

I have also done maven install and now i am getting this error message.

Publishing failed with multiple errors Resource is out of sync with the file system: '/um-webapp-m1-l4-start/target/classes/logback.xml'. Resource is out of sync with the file system: '/um-webapp-m1-l4-start/target/classes/persistence-cargo.properties'. Resource is out of sync with the file system: '/um-webapp-m1-l4-start/target/classes/persistence-h2.properties'.

manojsharma20 commented Dec 23, 2016

I have also done maven install and now i am getting this error message.

Publishing failed with multiple errors Resource is out of sync with the file system: '/um-webapp-m1-l4-start/target/classes/logback.xml'. Resource is out of sync with the file system: '/um-webapp-m1-l4-start/target/classes/persistence-cargo.properties'. Resource is out of sync with the file system: '/um-webapp-m1-l4-start/target/classes/persistence-h2.properties'.

@eugenp

This comment has been minimized.

Show comment
Hide comment
@eugenp

eugenp Dec 23, 2016

Owner

Well - if you're controlling the server from Eclipse, you'll need to do a full clean on the server, and then a publish.
You can also deploy with Boot - and not have to worry about all of that.

Cheers,
Eugen.

Owner

eugenp commented Dec 23, 2016

Well - if you're controlling the server from Eclipse, you'll need to do a full clean on the server, and then a publish.
You can also deploy with Boot - and not have to worry about all of that.

Cheers,
Eugen.

@manojsharma20

This comment has been minimized.

Show comment
Hide comment
@manojsharma20

manojsharma20 Dec 23, 2016

Well, i have done maven clean common, um-webapp, and uner-management and then maven install in STS then i am again getting

[INFO] Scanning for projects... [INFO] [INFO] ------------------------------------------------------------------------ [INFO] Building um-webapp 0.1.0-SNAPSHOT [INFO] ------------------------------------------------------------------------ [INFO] [INFO] --- maven-resources-plugin:3.0.1:resources (default-resources) @ um-webapp-m1-l4-start --- [INFO] Using 'UTF-8' encoding to copy filtered resources. [INFO] Copying 3 resources [INFO] [INFO] --- maven-compiler-plugin:3.5.1:compile (default-compile) @ um-webapp-m1-l4-start --- [INFO] Changes detected - recompiling the module! [INFO] Compiling 25 source files to D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\classes [ERROR] error reading C:\Users\dell1\.m2\repository\org\javassist\javassist\3.20.0-GA\javassist-3.20.0-GA.jar; invalid LOC header (bad signature) [INFO] [INFO] --- maven-resources-plugin:3.0.1:testResources (default-testResources) @ um-webapp-m1-l4-start --- [INFO] Using 'UTF-8' encoding to copy filtered resources. [INFO] Copying 1 resource [INFO] [INFO] --- maven-compiler-plugin:3.5.1:testCompile (default-testCompile) @ um-webapp-m1-l4-start --- [INFO] Changes detected - recompiling the module! [INFO] Compiling 4 source files to D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\test-classes [ERROR] error reading C:\Users\dell1\.m2\repository\org\javassist\javassist\3.20.0-GA\javassist-3.20.0-GA.jar; invalid LOC header (bad signature) [INFO] [INFO] --- maven-surefire-plugin:2.19.1:test (default-test) @ um-webapp-m1-l4-start --- [INFO] [INFO] --- maven-war-plugin:2.6:war (default-war) @ um-webapp-m1-l4-start --- [INFO] Packaging webapp [INFO] Assembling webapp [um-webapp-m1-l4-start] in [D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\um-webapp] [INFO] Processing war project [INFO] Copying webapp resources [D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\src\main\webapp] [INFO] Webapp assembled in [453 msecs] [INFO] Building war: D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\um-webapp.war [INFO] [INFO] --- maven-install-plugin:2.5.2:install (default-install) @ um-webapp-m1-l4-start --- [INFO] Installing D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\um-webapp.war to C:\Users\dell1\.m2\repository\com\baeldung\um-webapp-m1-l4-start\0.1.0-SNAPSHOT\um-webapp-m1-l4-start-0.1.0-SNAPSHOT.war [INFO] Installing D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\pom.xml to C:\Users\dell1\.m2\repository\com\baeldung\um-webapp-m1-l4-start\0.1.0-SNAPSHOT\um-webapp-m1-l4-start-0.1.0-SNAPSHOT.pom [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESS [INFO] ------------------------------------------------------------------------ [INFO] Total time: 6.966 s [INFO] Finished at: 2016-12-23T15:17:50+05:30 [INFO] Final Memory: 31M/262M [INFO] ------------------------------------------------------------------------

I think problem is the javaassist, maven not able to install javaassist.

manojsharma20 commented Dec 23, 2016

Well, i have done maven clean common, um-webapp, and uner-management and then maven install in STS then i am again getting

[INFO] Scanning for projects... [INFO] [INFO] ------------------------------------------------------------------------ [INFO] Building um-webapp 0.1.0-SNAPSHOT [INFO] ------------------------------------------------------------------------ [INFO] [INFO] --- maven-resources-plugin:3.0.1:resources (default-resources) @ um-webapp-m1-l4-start --- [INFO] Using 'UTF-8' encoding to copy filtered resources. [INFO] Copying 3 resources [INFO] [INFO] --- maven-compiler-plugin:3.5.1:compile (default-compile) @ um-webapp-m1-l4-start --- [INFO] Changes detected - recompiling the module! [INFO] Compiling 25 source files to D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\classes [ERROR] error reading C:\Users\dell1\.m2\repository\org\javassist\javassist\3.20.0-GA\javassist-3.20.0-GA.jar; invalid LOC header (bad signature) [INFO] [INFO] --- maven-resources-plugin:3.0.1:testResources (default-testResources) @ um-webapp-m1-l4-start --- [INFO] Using 'UTF-8' encoding to copy filtered resources. [INFO] Copying 1 resource [INFO] [INFO] --- maven-compiler-plugin:3.5.1:testCompile (default-testCompile) @ um-webapp-m1-l4-start --- [INFO] Changes detected - recompiling the module! [INFO] Compiling 4 source files to D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\test-classes [ERROR] error reading C:\Users\dell1\.m2\repository\org\javassist\javassist\3.20.0-GA\javassist-3.20.0-GA.jar; invalid LOC header (bad signature) [INFO] [INFO] --- maven-surefire-plugin:2.19.1:test (default-test) @ um-webapp-m1-l4-start --- [INFO] [INFO] --- maven-war-plugin:2.6:war (default-war) @ um-webapp-m1-l4-start --- [INFO] Packaging webapp [INFO] Assembling webapp [um-webapp-m1-l4-start] in [D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\um-webapp] [INFO] Processing war project [INFO] Copying webapp resources [D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\src\main\webapp] [INFO] Webapp assembled in [453 msecs] [INFO] Building war: D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\um-webapp.war [INFO] [INFO] --- maven-install-plugin:2.5.2:install (default-install) @ um-webapp-m1-l4-start --- [INFO] Installing D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\target\um-webapp.war to C:\Users\dell1\.m2\repository\com\baeldung\um-webapp-m1-l4-start\0.1.0-SNAPSHOT\um-webapp-m1-l4-start-0.1.0-SNAPSHOT.war [INFO] Installing D:\Spring-Tool-Suite\REST-With-Spring-module1\m1-lesson4-start\um-webapp\pom.xml to C:\Users\dell1\.m2\repository\com\baeldung\um-webapp-m1-l4-start\0.1.0-SNAPSHOT\um-webapp-m1-l4-start-0.1.0-SNAPSHOT.pom [INFO] ------------------------------------------------------------------------ [INFO] BUILD SUCCESS [INFO] ------------------------------------------------------------------------ [INFO] Total time: 6.966 s [INFO] Finished at: 2016-12-23T15:17:50+05:30 [INFO] Final Memory: 31M/262M [INFO] ------------------------------------------------------------------------

I think problem is the javaassist, maven not able to install javaassist.

@eugenp

This comment has been minimized.

Show comment
Hide comment
@eugenp

eugenp Dec 23, 2016

Owner

I don't see any issue there - I see you're getting BUILD-SUCCESS and no javaassist issues?
So, given that looks successful - are you now able to deploy?

Owner

eugenp commented Dec 23, 2016

I don't see any issue there - I see you're getting BUILD-SUCCESS and no javaassist issues?
So, given that looks successful - are you now able to deploy?

@manojsharma20

This comment has been minimized.

Show comment
Hide comment
@manojsharma20

manojsharma20 Dec 23, 2016

Kindly look on line number 5 or 6 there a line like below.

[ERROR] error reading C:\Users\dell1\.m2\repository\org\javassist\javassist\3.20.0-GA\javassist-3.20.0-GA.jar; invalid LOC header (bad signature) [INFO] [INFO] --- maven-resources-

I have tried after this and again i am getting first error as mentioned first time.

manojsharma20 commented Dec 23, 2016

Kindly look on line number 5 or 6 there a line like below.

[ERROR] error reading C:\Users\dell1\.m2\repository\org\javassist\javassist\3.20.0-GA\javassist-3.20.0-GA.jar; invalid LOC header (bad signature) [INFO] [INFO] --- maven-resources-

I have tried after this and again i am getting first error as mentioned first time.

@eugenp

This comment has been minimized.

Show comment
Hide comment
@eugenp

eugenp Dec 23, 2016

Owner

Yeah, I see it now.
Is that after you deleted your entire .m2 repo from disk and built again?

Owner

eugenp commented Dec 23, 2016

Yeah, I see it now.
Is that after you deleted your entire .m2 repo from disk and built again?

@manojsharma20

This comment has been minimized.

Show comment
Hide comment
@manojsharma20

manojsharma20 Dec 23, 2016

manojsharma20 commented Dec 23, 2016

@eugenp

This comment has been minimized.

Show comment
Hide comment
@eugenp

eugenp Dec 23, 2016

Owner

You have the path in the error message:
C:\Users\dell1.m2\repository
You'll need to go there and delete everything under the repository folder (or just delete that folder completely).
Then, build again.

Owner

eugenp commented Dec 23, 2016

You have the path in the error message:
C:\Users\dell1.m2\repository
You'll need to go there and delete everything under the repository folder (or just delete that folder completely).
Then, build again.

@manojsharma20

This comment has been minimized.

Show comment
Hide comment
@manojsharma20

manojsharma20 Dec 23, 2016

Yes, it does. I have remove everything inside .m2 and start again with fresh setup and that it. Everything working fine now. I am able to get roles.

Thanks.

manojsharma20 commented Dec 23, 2016

Yes, it does. I have remove everything inside .m2 and start again with fresh setup and that it. Everything working fine now. I am able to get roles.

Thanks.

@eugenp

This comment has been minimized.

Show comment
Hide comment
@eugenp

eugenp Dec 23, 2016

Owner

Sounds good.

Owner

eugenp commented Dec 23, 2016

Sounds good.

@eugenp eugenp closed this Dec 23, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment