perl5i won't install on ActivePerl due to true.pm not being able to compile #183

Open
wchristian opened this Issue Feb 24, 2011 · 8 comments

3 participants

@schwern

sigh true.pm was so much simpler when it wasn't a huge wad of XS code.

@wchristian

In the hope of helping things along, i did some digging and added more details to the bug report. It looks like it's mostly a question of EUMM being configured right in the Makefile.PL.

@chocolateboy

sigh: any chance this could be fixed in EUMM, where it belongs?

@wchristian

I can and will fix it the code, since i have permission and ability to change it. However i am not allowed (and probably also not able) to make a full release of EUMM.

So i think the question is more accurately:

Would a fix of this be enough of a reason to trigger a full release of EUMM to CPAN?

(I've actually been wondering for a while what the conditions for new EUMM releases are.)

@chocolateboy

I can and will fix it the code, since i have permission and ability to change it.

Great. Thanks.

Would a fix of this be enough of a reason to
trigger a full release of EUMM to CPAN?

I'm happy to apply the fix to true.pm in the interim. I just want to avoid maintaining a workaround I haven't used, tested or understood.

@wchristian

You have all my sympathies and support there. :)

I'm just acting in a way that will get this problem resolved as fast as possible while producing good knock-on effects by trying to poke schwern here.

@schwern

Any motion on this?

@wchristian

Yes, sorry, i'd actually managed to forget why i fixed Liblist for Windows. Said fix is now in fact merged into master over there, so as soon as a new release of EUMM is cut, and true.pm updated to require that new version, things will be fixed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment