Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 46 lines (41 sloc) 2.508 kb
dad4170 @ELLIOTTCABLE * Added support for `rakefile_name`, so you can have a semantically-n…
ELLIOTTCABLE authored
1 # -*- encoding: utf-8 -*-
aada446 @evan Gemspec
authored
2 # stub: echoe 4.6.6 ruby lib
dad4170 @ELLIOTTCABLE * Added support for `rakefile_name`, so you can have a semantically-n…
ELLIOTTCABLE authored
3
e3e5f81 @technicalpickles Added a .gemspec so github can generate a gem for me.
technicalpickles authored
4 Gem::Specification.new do |s|
acfa8d5 @evan Rdoc README extension to please Github
authored
5 s.name = "echoe"
aada446 @evan Gemspec
authored
6 s.version = "4.6.6"
e3e5f81 @technicalpickles Added a .gemspec so github can generate a gem for me.
technicalpickles authored
7
4304065 Compatibility with RubyGems 1.8.4 and Rake 0.9.0. Uncertain behavior …
Evan Weaver authored
8 s.required_rubygems_version = Gem::Requirement.new(">= 1.8.4") if s.respond_to? :required_rubygems_version=
acfa8d5 @evan Rdoc README extension to please Github
authored
9 s.authors = ["Evan Weaver"]
3a5f05f @evan Gem public cert
authored
10 s.cert_chain = ["/Users/eweaver/cloudburst/github/echoe/echoe.pem"]
a675632 @evan Fix bug with unclosed manifest file.
authored
11 s.date = "2014-05-15"
acfa8d5 @evan Rdoc README extension to please Github
authored
12 s.description = "A Rubygems packaging tool that provides Rake tasks for documentation, extension compiling, testing, and deployment."
13 s.email = ""
14 s.extra_rdoc_files = ["CHANGELOG", "LICENSE", "README.rdoc", "lib/echoe.rb", "lib/echoe/extensions.rb", "lib/echoe/platform.rb", "lib/echoe/rubygems.rb"]
3a5f05f @evan Gem public cert
authored
15 s.files = ["CHANGELOG", "LICENSE", "MIT-LICENSE", "Manifest", "README.rdoc", "Rakefile", "echoe.gemspec", "echoe.pem", "lib/echoe.rb", "lib/echoe/extensions.rb", "lib/echoe/platform.rb", "lib/echoe/rubygems.rb", "vendor/rake/MIT-LICENSE", "vendor/rake/lib/rake/contrib/compositepublisher.rb", "vendor/rake/lib/rake/contrib/ftptools.rb", "vendor/rake/lib/rake/contrib/publisher.rb", "vendor/rake/lib/rake/contrib/rubyforgepublisher.rb", "vendor/rake/lib/rake/contrib/sshpublisher.rb", "vendor/rake/lib/rake/contrib/sys.rb"]
aada446 @evan Gemspec
authored
16 s.homepage = "http://fauna.github.com/fauna/echoe/"
3a5f05f @evan Gem public cert
authored
17 s.licenses = ["Academic Free License (AFL) v. 3.0"]
782a7e3 @evan Remove gemcutter
authored
18 s.rdoc_options = ["--line-numbers", "--title", "Echoe", "--main", "README.rdoc"]
acfa8d5 @evan Rdoc README extension to please Github
authored
19 s.require_paths = ["lib"]
20 s.rubyforge_project = "fauna"
3a5f05f @evan Gem public cert
authored
21 s.rubygems_version = "2.1.10"
782a7e3 @evan Remove gemcutter
authored
22 s.signing_key = "/Users/eweaver/cloudburst/configuration/gem_certificates/gem-private_key.pem"
acfa8d5 @evan Rdoc README extension to please Github
authored
23 s.summary = "A Rubygems packaging tool that provides Rake tasks for documentation, extension compiling, testing, and deployment."
e3e5f81 @technicalpickles Added a .gemspec so github can generate a gem for me.
technicalpickles authored
24
25 if s.respond_to? :specification_version then
782a7e3 @evan Remove gemcutter
authored
26 s.specification_version = 4
e3e5f81 @technicalpickles Added a .gemspec so github can generate a gem for me.
technicalpickles authored
27
8201343 Use GitHub for default url and documentation hosting.
Evan Weaver authored
28 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
4304065 Compatibility with RubyGems 1.8.4 and Rake 0.9.0. Uncertain behavior …
Evan Weaver authored
29 s.add_runtime_dependency(%q<rubyforge>, [">= 2.0.4"])
30 s.add_runtime_dependency(%q<allison>, [">= 2.0.3"])
acfa8d5 @evan Rdoc README extension to please Github
authored
31 s.add_runtime_dependency(%q<rdoc>, [">= 2.5.11"])
0baa3ba Version.
Evan Weaver authored
32 s.add_runtime_dependency(%q<rake>, [">= 0.9.2"])
e3e5f81 @technicalpickles Added a .gemspec so github can generate a gem for me.
technicalpickles authored
33 else
4304065 Compatibility with RubyGems 1.8.4 and Rake 0.9.0. Uncertain behavior …
Evan Weaver authored
34 s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
35 s.add_dependency(%q<allison>, [">= 2.0.3"])
acfa8d5 @evan Rdoc README extension to please Github
authored
36 s.add_dependency(%q<rdoc>, [">= 2.5.11"])
0baa3ba Version.
Evan Weaver authored
37 s.add_dependency(%q<rake>, [">= 0.9.2"])
e3e5f81 @technicalpickles Added a .gemspec so github can generate a gem for me.
technicalpickles authored
38 end
39 else
4304065 Compatibility with RubyGems 1.8.4 and Rake 0.9.0. Uncertain behavior …
Evan Weaver authored
40 s.add_dependency(%q<rubyforge>, [">= 2.0.4"])
41 s.add_dependency(%q<allison>, [">= 2.0.3"])
acfa8d5 @evan Rdoc README extension to please Github
authored
42 s.add_dependency(%q<rdoc>, [">= 2.5.11"])
0baa3ba Version.
Evan Weaver authored
43 s.add_dependency(%q<rake>, [">= 0.9.2"])
e3e5f81 @technicalpickles Added a .gemspec so github can generate a gem for me.
technicalpickles authored
44 end
45 end
Something went wrong with that request. Please try again.