Find file History
Fetching latest commit…
Cannot retrieve the latest commit at this time.

README.md

eslint-config-eventbrite-react

version downloads Maintenance Status

PRs Welcome license

Eventbrite's ESLint config that lints React & JSX, adhering to the Eventbrite JavaScript Coding Style Guide.

Usage

This ESLint configuration requires eslint, babel-eslint, eslint-plugin-babel, eslint-plugin-import, eslint-plugin-react, eslint-plugin-jsx-a11y and eslint-plugin-jest.

Install using npm:

npm install --save-dev eslint@^4.19.1 babel-eslint@^8.2.3 eslint-plugin-babel@^5.1.0 eslint-plugin-import@^2.11.0 eslint-plugin-react@^7.7.0 eslint-plugin-jsx-a11y@^6.0.3 eslint-plugin-jest@^21.15.1 eslint-config-eventbrite-react

...or using yarn:

yarn add --dev eslint@^4.19.1 babel-eslint@^8.2.3 eslint-plugin-babel@^5.1.0 eslint-plugin-import@^2.11.0 eslint-plugin-react@^7.7.0 eslint-plugin-jsx-a11y@^6.0.3 eslint-plugin-jest@^21.15.1 eslint-config-eventbrite-react

Extend eslint-config-eventbrite-react in your .eslintrc.json:

{
    "extends": "eventbrite-react"
}

NOTE: This configuration extends eslint-config-eventbrite and plugin:react/recommended'.

Contributing

Thank you for your willingness to contribute! 😀

Although eslint-config-eventbrite-react is a public package, its primary purpose is for linting Eventbrite's React JavaScript code. Therefore, it is unlikely that we'll accept changes to rules as they may adversely affect the linting of our own code. However, we do welcome fixes for errors or additions for omissions.

If you are uncertain as to whether your suggestion qualifies, go ahead and submit a Pull Request and we'll let you know. Thanks again!

License

The library is available as open source under the terms of the MIT License.

Thanks

Many thanks to Airbnb and their example eslint-config-airbnb.