Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump @wordpress/eslint-plugin from 1.0.1 to 2.1.0 #1125

Merged
merged 4 commits into from Apr 23, 2019

Conversation

Projects
None yet
3 participants
@dependabot-preview
Copy link
Contributor

commented Apr 23, 2019

Bumps @wordpress/eslint-plugin from 1.0.1 to 2.1.0.

Changelog

Sourced from @wordpress/eslint-plugin's changelog.

2.1.0 (2019-03-20)

New Features

  • The bundled eslint-plugin-jsx-a11y dependency has been updated from requiring ^6.0.2 to requiring ^6.2.1 (see new features added in 6.2.0 and 6.1.0).
  • The bundled eslint-plugin-react dependency has been updated from requiring 7.7.0 to requiring ^7.12.4 (see new features added in 7.12.0, 7.11.0, 7.10.0, 7.9.0 and 7.8.0).

2.0.0 (2019-03-06)

Breaking Changes

New Features

1.0.0 (2018-12-12)

New Features

  • Initial release.
Commits
Maintainer changes

This version was pushed to npm by jorgefilipecosta, a new releaser for @wordpress/eslint-plugin since your current version.


Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Note: This repo was added to Dependabot recently, so you'll receive a maximum of 5 PRs for your first few update runs. Once an update run creates fewer than 5 PRs we'll remove that limit.

You can always request more updates by clicking Bump now in your Dependabot dashboard.

Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot ignore this [patch|minor|major] version will close this PR and stop Dependabot creating any more for this minor/major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Pull request limits (per update run and/or open at any time)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

Finally, you can contact us by mentioning @dependabot.

@dependabot-preview dependabot-preview bot requested a review from nerrad Apr 23, 2019

@dependabot-preview dependabot-preview bot force-pushed the dependabot/npm_and_yarn/@wordpress/eslint-plugin-2.1.0 branch 5 times, most recently from 9b84789 to 10d82d7 Apr 23, 2019

@nerrad

This comment has been minimized.

Copy link
Member

commented Apr 23, 2019

@dependabot-bot rebase

@dependabot-preview dependabot-preview bot force-pushed the dependabot/npm_and_yarn/@wordpress/eslint-plugin-2.1.0 branch from 10d82d7 to e7e840b Apr 23, 2019

nerrad added some commits Apr 23, 2019

@nerrad

nerrad approved these changes Apr 23, 2019

Copy link
Member

left a comment

This package introduces updated eslint rulesets which introduced some eslinting failures. In this pull:

  • I've disabled the @wordpress/dependency-group eslint rule because it doesn't apply to our project.
  • I fixed any remaining linting issues in our existing codebase due to the new rules.
  • I rebuilt the build files (dev).

Because of the changes in code (which is very minimal) I also:

  • verified that plugins exit modal works as expected.
  • verified EventAttendees block works as expected.

Once javascript tests pass this can be merged.

@nerrad nerrad merged commit 5f77595 into master Apr 23, 2019

1 of 2 checks passed

Travis CI - Pull Request Build Canceled
Details
codecov/project 91.74% remains the same compared to b1b8060
Details

@nerrad nerrad deleted the dependabot/npm_and_yarn/@wordpress/eslint-plugin-2.1.0 branch Apr 23, 2019

eeteamcodebase pushed a commit that referenced this pull request Apr 23, 2019

EE DevBox Server
Bumping version to 4.9.80.rc.094. Previous Commit message: "Bump @wor…
…dpress/eslint-plugin from 1.0.1 to 2.1.0 (#1125)

* Bump @wordpress/eslint-plugin from 1.0.1 to 2.1.0

Bumps [@wordpress/eslint-plugin](https://github.com/WordPress/gutenberg/tree/HEAD/packages/eslint-plugin) from 1.0.1 to 2.1.0.
- [Release notes](https://github.com/WordPress/gutenberg/releases)
- [Changelog](https://github.com/WordPress/gutenberg/blob/master/packages/eslint-plugin/CHANGELOG.md)
- [Commits](https://github.com/WordPress/gutenberg/commits/@wordpress/eslint-plugin@2.1.0/packages/eslint-plugin)

Signed-off-by: dependabot[bot] <support@dependabot.com>

* disable @wordpress/dependency-group rule

* fix linting issues introduced by eslint package update

* update build files (dev)
"

@nerrad nerrad added this to the 4.9.80.p milestone Apr 24, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.