Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Noticing that EM is failing on current trunk of ruby 2.0 (missing rb_enable_interrupt) #389

Closed
SamSaffron opened this Issue · 3 comments

5 participants

@SamSaffron

/home/sam/.rvm/gems/ruby-head/bin/thin: symbol lookup error: /home/sam/.rvm/gems/ruby-head/gems/eventmachine-1.0.0/lib/rubyeventmachine.so: undefined symbol: rb_enable_interrupt

@ttilley

My fork passes the test suite on 2.0.0dev, but it isn't exactly work performed with the goal of clean upstream integration. My goal was to work on splitting it into merge-friendly pieces after I got everything working in rbx, then kinda wandered off after a shiny object or something.

Test results:
https://travis-ci.org/ttilley/eventmachine/jobs/3383828/#L8

Version of patchset tracking upstream:
https://github.com/ttilley/eventmachine/tree/as

Version of patchset tracking EventMachine-LiveEdition:
https://github.com/ttilley/eventmachine/tree/emle-as

@ibc

Hi @ttilley, I've open an issue in EventMachine-LE for considering your commits:

ibc#14

Could we please talk there about the implications of your changes? Thanks a lot.

@joallard

See issue #248

@tmm1 tmm1 closed this
@alzeih alzeih referenced this issue in readium/readium-js-viewer
Closed

Update Gemfile for a later version of eventmachine #1

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.