Skip to content
Permalink
Browse files

chore: enable TS watch, updates lock files

  • Loading branch information...
evereq committed Apr 23, 2019
1 parent 67b06e5 commit 6ae4e550e29a31e75b2f72bf92e0cb61c80eaf73
@@ -363,18 +363,6 @@
"@babel/types" "^7.2.2"
lodash "^4.17.11"

"@babel/helper-module-transforms@^7.4.3":
version "7.4.3"
resolved "https://registry.yarnpkg.com/@babel/helper-module-transforms/-/helper-module-transforms-7.4.3.tgz#b1e357a1c49e58a47211a6853abb8e2aaefeb064"
integrity sha512-H88T9IySZW25anu5uqyaC1DaQre7ofM+joZtAaO2F8NBdFfupH0SZ4gKjgSFVcvtx/aAirqA9L9Clio2heYbZA==
dependencies:
"@babel/helper-module-imports" "^7.0.0"
"@babel/helper-simple-access" "^7.1.0"
"@babel/helper-split-export-declaration" "^7.0.0"
"@babel/template" "^7.2.2"
"@babel/types" "^7.2.2"
lodash "^4.17.11"

"@babel/helper-optimise-call-expression@^7.0.0":
version "7.0.0"
resolved "https://registry.yarnpkg.com/@babel/helper-optimise-call-expression/-/helper-optimise-call-expression-7.0.0.tgz#a2920c5702b073c15de51106200aa8cad20497d5"
@@ -394,13 +382,6 @@
dependencies:
lodash "^4.17.11"

"@babel/helper-regex@^7.4.3":
version "7.4.3"
resolved "https://registry.yarnpkg.com/@babel/helper-regex/-/helper-regex-7.4.3.tgz#9d6e5428bfd638ab53b37ae4ec8caf0477495147"
integrity sha512-hnoq5u96pLCfgjXuj8ZLX3QQ+6nAulS+zSgi6HulUwFbEruRAKwbGLU5OvXkE14L8XW6XsQEKsIDfgthKLRAyA==
dependencies:
lodash "^4.17.11"

"@babel/helper-remap-async-to-generator@^7.1.0":
version "7.1.0"
resolved "https://registry.yarnpkg.com/@babel/helper-remap-async-to-generator/-/helper-remap-async-to-generator-7.1.0.tgz#361d80821b6f38da75bd3f0785ece20a88c5fe7f"
@@ -422,16 +403,6 @@
"@babel/traverse" "^7.4.0"
"@babel/types" "^7.4.0"

"@babel/helper-replace-supers@^7.4.0":
version "7.4.0"
resolved "https://registry.yarnpkg.com/@babel/helper-replace-supers/-/helper-replace-supers-7.4.0.tgz#4f56adb6aedcd449d2da9399c2dcf0545463b64c"
integrity sha512-PVwCVnWWAgnal+kJ+ZSAphzyl58XrFeSKSAJRiqg5QToTsjL+Xu1f9+RJ+d+Q0aPhPfBGaYfkox66k86thxNSg==
dependencies:
"@babel/helper-member-expression-to-functions" "^7.0.0"
"@babel/helper-optimise-call-expression" "^7.0.0"
"@babel/traverse" "^7.4.0"
"@babel/types" "^7.4.0"

"@babel/helper-simple-access@^7.1.0":
version "7.1.0"
resolved "https://registry.yarnpkg.com/@babel/helper-simple-access/-/helper-simple-access-7.1.0.tgz#65eeb954c8c245beaa4e859da6188f39d71e585c"
@@ -2653,18 +2624,6 @@ autoprefixer@^9.0.0, autoprefixer@^9.4.7:
postcss "^7.0.14"
postcss-value-parser "^3.3.1"

autoprefixer@^9.4.7:
version "9.5.1"
resolved "https://registry.yarnpkg.com/autoprefixer/-/autoprefixer-9.5.1.tgz#243b1267b67e7e947f28919d786b50d3bb0fb357"
integrity sha512-KJSzkStUl3wP0D5sdMlP82Q52JLy5+atf2MHAre48+ckWkXgixmfHyWmA77wFDy6jTHU6mIgXv6hAQ2mf1PjJQ==
dependencies:
browserslist "^4.5.4"
caniuse-lite "^1.0.30000957"
normalize-range "^0.1.2"
num2fraction "^1.2.2"
postcss "^7.0.14"
postcss-value-parser "^3.3.1"

aws-sign2@~0.7.0:
version "0.7.0"
resolved "https://registry.yarnpkg.com/aws-sign2/-/aws-sign2-0.7.0.tgz#b46e890934a9591f2d2f6f86d7e6a9f1b3fe76a8"
@@ -3542,11 +3501,6 @@ camelcase@^5.0.0, camelcase@^5.2.0:
resolved "https://registry.yarnpkg.com/camelcase/-/camelcase-5.3.1.tgz#e3c9b31569e106811df242f715725a1f4c494320"
integrity sha512-L28STB170nwWS63UjtlEOE3dldQApaJXZkOI1uMFfzf3rRuPegHaHesyee+YxQ+W6SvRDQV6UrdOdRiR153wJg==

camelcase@^5.2.0:
version "5.3.1"
resolved "https://registry.yarnpkg.com/camelcase/-/camelcase-5.3.1.tgz#e3c9b31569e106811df242f715725a1f4c494320"
integrity sha512-L28STB170nwWS63UjtlEOE3dldQApaJXZkOI1uMFfzf3rRuPegHaHesyee+YxQ+W6SvRDQV6UrdOdRiR153wJg==

can-promise@0.0.1:
version "0.0.1"
resolved "https://registry.yarnpkg.com/can-promise/-/can-promise-0.0.1.tgz#7a7597ad801fb14c8b22341dfec314b6bd6ad8d3"
@@ -3559,11 +3513,6 @@ caniuse-lite@^1.0.30000929, caniuse-lite@^1.0.30000955, caniuse-lite@^1.0.300009
resolved "https://registry.yarnpkg.com/caniuse-lite/-/caniuse-lite-1.0.30000957.tgz#fb1026bf184d7d62c685205358c3b24b9e29f7b3"
integrity sha512-8wxNrjAzyiHcLXN/iunskqQnJquQQ6VX8JHfW5kLgAPRSiSuKZiNfmIkP5j7jgyXqAQBSoXyJxfnbCFS0ThSiQ==

caniuse-lite@^1.0.30000955, caniuse-lite@^1.0.30000957:
version "1.0.30000957"
resolved "https://registry.yarnpkg.com/caniuse-lite/-/caniuse-lite-1.0.30000957.tgz#fb1026bf184d7d62c685205358c3b24b9e29f7b3"
integrity sha512-8wxNrjAzyiHcLXN/iunskqQnJquQQ6VX8JHfW5kLgAPRSiSuKZiNfmIkP5j7jgyXqAQBSoXyJxfnbCFS0ThSiQ==

canonical-path@1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/canonical-path/-/canonical-path-1.0.0.tgz#fcb470c23958def85081856be7a86e904f180d1d"
@@ -4110,7 +4059,7 @@ conventional-changelog-atom@^2.0.1:
dependencies:
q "^1.5.1"

conventional-changelog-cli@^2.0.11:
conventional-changelog-cli@^2.0.12:
version "2.0.12"
resolved "https://registry.yarnpkg.com/conventional-changelog-cli/-/conventional-changelog-cli-2.0.12.tgz#ffe04f5430fbc339dc7fa28634c2e0de5dd76e2e"
integrity sha512-6wh9W5Gpr9DM40E8cFi0qa6JotVm4Jq+suksuqgKnm544H8ZXsRhgGNXShDASOteY9brv9fX8/+fE/QL1wHqbA==
@@ -5424,16 +5373,6 @@ editorconfig@^0.15.2:
semver "^5.6.0"
sigmund "^1.0.1"

editorconfig@^0.15.2:
version "0.15.3"
resolved "https://registry.yarnpkg.com/editorconfig/-/editorconfig-0.15.3.tgz#bef84c4e75fb8dcb0ce5cee8efd51c15999befc5"
integrity sha512-M9wIMFx96vq0R4F+gRpY3o2exzb8hEj/n9S8unZtHSvYjibBp/iMufSzvmOcV/laG0ZtuTVGtiJggPOSW2r93g==
dependencies:
commander "^2.19.0"
lru-cache "^4.1.5"
semver "^5.6.0"
sigmund "^1.0.1"

ee-first@1.1.1:
version "1.1.1"
resolved "https://registry.yarnpkg.com/ee-first/-/ee-first-1.1.1.tgz#590c61156b0ae2f4f0255732a158b266bc56b21d"
@@ -5449,11 +5388,6 @@ electron-to-chromium@^1.3.103, electron-to-chromium@^1.3.122:
resolved "https://registry.yarnpkg.com/electron-to-chromium/-/electron-to-chromium-1.3.124.tgz#861fc0148748a11b3e5ccebdf8b795ff513fa11f"
integrity sha512-glecGr/kFdfeXUHOHAWvGcXrxNU+1wSO/t5B23tT1dtlvYB26GY8aHzZSWD7HqhqC800Lr+w/hQul6C5AF542w==

electron-to-chromium@^1.3.122:
version "1.3.124"
resolved "https://registry.yarnpkg.com/electron-to-chromium/-/electron-to-chromium-1.3.124.tgz#861fc0148748a11b3e5ccebdf8b795ff513fa11f"
integrity sha512-glecGr/kFdfeXUHOHAWvGcXrxNU+1wSO/t5B23tT1dtlvYB26GY8aHzZSWD7HqhqC800Lr+w/hQul6C5AF542w==

elliptic@^6.0.0:
version "6.4.1"
resolved "https://registry.yarnpkg.com/elliptic/-/elliptic-6.4.1.tgz#c2d0b7776911b86722c632c3c06c60f2f819939a"
@@ -6915,23 +6849,6 @@ history@^4.7.2:
tiny-warning "^1.0.0"
value-equal "^0.4.0"

highlight.js@~9.12.0:
version "9.12.0"
resolved "https://registry.yarnpkg.com/highlight.js/-/highlight.js-9.12.0.tgz#e6d9dbe57cbefe60751f02af336195870c90c01e"
integrity sha1-5tnb5Xy+/mB1HwKvM2GVhwyQwB4=

history@^4.7.2:
version "4.9.0"
resolved "https://registry.yarnpkg.com/history/-/history-4.9.0.tgz#84587c2068039ead8af769e9d6a6860a14fa1bca"
integrity sha512-H2DkjCjXf0Op9OAr6nJ56fcRkTSNrUiv41vNJ6IswJjif6wlpZK0BTfFbi7qK9dXLSYZxkq5lBsj3vUjlYBYZA==
dependencies:
"@babel/runtime" "^7.1.2"
loose-envify "^1.2.0"
resolve-pathname "^2.2.0"
tiny-invariant "^1.0.2"
tiny-warning "^1.0.0"
value-equal "^0.4.0"

hmac-drbg@^1.0.0:
version "1.0.1"
resolved "https://registry.yarnpkg.com/hmac-drbg/-/hmac-drbg-1.0.1.tgz#d2745701025a6c775a6c545793ed502fc0c649a1"
@@ -8494,6 +8411,11 @@ lodash.isequal@^4.5.0:
resolved "https://registry.yarnpkg.com/lodash.isequal/-/lodash.isequal-4.5.0.tgz#415c4478f2bcc30120c22ce10ed3226f7d3e18e0"
integrity sha1-QVxEePK8wwEgwizhDtMib30+GOA=

lodash.ismatch@^4.4.0:
version "4.4.0"
resolved "https://registry.yarnpkg.com/lodash.ismatch/-/lodash.ismatch-4.4.0.tgz#756cb5150ca3ba6f11085a78849645f188f85f37"
integrity sha1-dWy1FQyjum8RCFp4hJZF8Yj4Xzc=

lodash.isplainobject@^4.0.6:
version "4.0.6"
resolved "https://registry.yarnpkg.com/lodash.isplainobject/-/lodash.isplainobject-4.0.6.tgz#7c526a52d89b45c45cc690b88163be0497f550cb"
@@ -9987,18 +9909,6 @@ parse-entities@^1.0.2, parse-entities@^1.1.0, parse-entities@^1.1.2:
is-decimal "^1.0.0"
is-hexadecimal "^1.0.0"

parse-entities@^1.1.2:
version "1.2.1"
resolved "https://registry.yarnpkg.com/parse-entities/-/parse-entities-1.2.1.tgz#2c761ced065ba7dc68148580b5a225e4918cdd69"
integrity sha512-NBWYLQm1KSoDKk7GAHyioLTvCZ5QjdH/ASBBQTD3iLiAWJXS5bg1jEWI8nIJ+vgVvsceBVBcDGRWSo0KVQBvvg==
dependencies:
character-entities "^1.0.0"
character-entities-legacy "^1.0.0"
character-reference-invalid "^1.0.0"
is-alphanumerical "^1.0.0"
is-decimal "^1.0.0"
is-hexadecimal "^1.0.0"

parse-github-repo-url@^1.3.0:
version "1.4.1"
resolved "https://registry.yarnpkg.com/parse-github-repo-url/-/parse-github-repo-url-1.4.1.tgz#9e7d8bb252a6cb6ba42595060b7bf6df3dbc1f50"
@@ -0,0 +1,6 @@
{
"watch": ["src"],
"ext": "ts",
"ignore": ["src/**/*.spec.ts"],
"exec": "node --inspect-brk -r tsconfig-paths/register -r ts-node/register src/main.ts"
}
@@ -0,0 +1,5 @@
{
"watch": ["build"],
"ext": "js",
"exec": "node build/main"
}
@@ -33,6 +33,7 @@
"coverage": "cross-env NODE_ENV=development NODE_OPTIONS=--max_old_space_size=4096 nyc report --reporter=text-lcov | coveralls",
"precommit": "cross-env NODE_ENV=development NODE_OPTIONS=--max_old_space_size=4096 lint-staged",
"start": "cross-env NODE_ENV=development NODE_OPTIONS=--max_old_space_size=4096 yarn tsc && node build/main.js",
"start:dev": "cross-env NODE_ENV=development NODE_OPTIONS=--max_old_space_size=4096 concurrently \"wait-on build/main.js && nodemon\" \"tsc -w -p tsconfig.build.json\" ",
"start:prod": "cross-env NODE_ENV=production NODE_OPTIONS=--max_old_space_size=4096 yarn tsc && node ./build/pm2bootstrap.js",
"build": "cross-env NODE_ENV=development NODE_OPTIONS=--max_old_space_size=4096 yarn tsc && yarn webpack",
"dev": "cross-env NODE_ENV=development NODE_OPTIONS=--max_old_space_size=4096 yarn tsc && node ./build/main.js",
@@ -46,18 +47,17 @@
},
"dependencies": {
"@captemulation/get-parameter-names": "^1.2.0",
"@nestjs/common": "^6.0.2",
"@nestjs/core": "^6.0.2",
"@nestjs/common": "^6.0.4",
"@nestjs/core": "^6.0.4",
"@nestjs/cqrs": "^6.0.0",
"@nestjs/graphql": "^6.0.2",
"@nestjs/microservices": "^6.0.2",
"@nestjs/graphql": "^6.0.4",
"@nestjs/microservices": "^6.0.4",
"@nestjs/passport": "^6.0.0",
"@nestjs/platform-express": "^6.0.2",
"@nestjs/platform-socket.io": "^6.0.2",
"@nestjs/platform-express": "^6.0.4",
"@nestjs/platform-socket.io": "^6.0.4",
"@nestjs/swagger": "^3.0.2",
"@nestjs/testing": "^6.0.2",
"@nestjs/typeorm": "^6.0.0",
"@nestjs/websockets": "^6.0.2",
"@nestjs/websockets": "^6.0.4",
"apollo-server-express": "^2.4.8",
"axios": "^0.18.0",
"bcrypt": "^3.0.4",
@@ -139,6 +139,7 @@
"ws": "^6.2.0"
},
"devDependencies": {
"@nestjs/testing": "^6.0.4",
"@commitlint/cli": "^7.5.2",
"@commitlint/config-conventional": "^7.5.0",
"@commitlint/config-lerna-scopes": "^7.5.1",
@@ -187,7 +188,7 @@
"cz-conventional-changelog": "^2.1.0",
"husky": "^1.3.1",
"jest": "^24.5.0",
"nodemon": "^1.18.10",
"nodemon": "^1.18.11",
"nyc": "^13.3.0",
"prettier": "^1.16.4",
"prettier-tslint": "^0.4.2",
@@ -197,11 +198,12 @@
"supertest": "^4.0.2",
"ts-jest": "^24.0.0",
"ts-loader": "^5.3.3",
"ts-node": "^8.0.3",
"tslint": "^5.14.0",
"ts-node": "^8.1.0",
"tslint": "^5.16.0",
"typedoc": "^0.14.2",
"typemoq": "^2.1.0",
"typescript": "~3.1.6",
"typescript": "~3.4.3",
"wait-on": "^3.2.0",
"webpack": "^4.29.6",
"webpack-cli": "^3.3.0",
"webpack-command": "^0.4.2",
@@ -0,0 +1,4 @@
{
"extends": "./tsconfig.json",
"exclude": ["node_modules", "build", "test", "**/*spec.ts"]
}
@@ -3,7 +3,9 @@
"module": "commonjs",
"lib": ["dom", "esnext", "es2017.object"],
"baseUrl": "./src",
"outDir": "build",
"incremental": true,
"removeComments": true,
"outDir": "./build",
"target": "es6",
"moduleResolution": "node",
"preserveConstEnums": true,
@@ -21,5 +23,5 @@
}
},
"include": ["src/**/*.ts", "./*.ts"],
"exclude": ["backup", "backup/TrackingService", "node_modules"]
"exclude": ["backup", "build", "backup/TrackingService", "node_modules"]
}
Oops, something went wrong.

0 comments on commit 6ae4e55

Please sign in to comment.
You can’t perform that action at this time.