Skip to content

Legacy Swift versions

Evgenii Neumerzhitckii edited this page Apr 20, 2019 · 14 revisions

Use the following setup instructions for the previous versions of the library if you use an older version of Swift.

Swift 4.2 Xcode 10

Library version / git tag: 12.0.0

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 12.0
  • CocoaPods: pod 'Dodo', '~> 12.0'

Swift 4.0 Xcode 9.1

Library version / git tag: 11.0.2

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 11.0
  • CocoaPods: pod 'Dodo', '~> 11.0'

Swift 4.0 Xcode 9.0

Library version / git tag: 9.0.1

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 9.0
  • CocoaPods: pod 'Dodo', '~> 9.0'

Swift 3.1 Xcode 8.3

Library version / git tag: 8.0.0

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 8.0
  • CocoaPods: pod 'Dodo', '~> 8.0'

Swift 3.0

Library version / git tag: 7.0.0

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 7.0
  • CocoaPods: pod 'Dodo', '~> 7.0'

Swift 3.0 Xcode 8 beta

Xcode 8 beta 6

Library version / git tag: 6.0.0

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 6.0
  • CocoaPods: pod 'Dodo', git: 'https://github.com/marketplacer/Dodo.git', tag: '6.0.0'

Xcode 8 beta 5/6

Library version / git tag: 5.0.0

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 5.0
  • CocoaPods: pod 'Dodo', git: 'https://github.com/marketplacer/Dodo.git', tag: '5.0.0'

Xcode 8 beta 2

Library version / git tag: 4.0.0

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 4.0
  • CocoaPods: pod 'Dodo', '~> 4.0'

Xcode 8 beta 1

Library version / git tag: 3.0.0

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 3.0
  • CocoaPods: pod 'Dodo', '~> 3.0'

Swift 2.3

Library version / git tag: 2.2.1

github "marketplacer/Dodo" ~> 2.2

and run carthage like carthage update Dodo --no-use-binaries --platform iOS --toolchain com.apple.dt.toolchain.Swift_2_3

  • CocoaPods:
swift_version = '2.3'
pod 'Dodo', '~> 2.2'

Swift 2.2

Library version / git tag: 2.2.1

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 2.2
  • CocoaPods: pod 'Dodo', '~> 2.2'

Swift 2.0

Library version / git tag: 2.0.13

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 2.0.0
  • CocoaPods: pod 'Dodo', '~> 2.0.0'

Swift 1.2

Library version / git tag: 1.0.17

  • File: DodoDistrib.swift
  • Carthage: github "marketplacer/Dodo" ~> 1.0
  • CocoaPods: pod 'Dodo', '~> 1.0'
You can’t perform that action at this time.