Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Some displays do not display the memtemp data in the correct place [BUG] #532

Closed
ian-rubenstein-mpf opened this issue Nov 5, 2019 · 6 comments
Labels
bug

Comments

@ian-rubenstein-mpf
Copy link

@ian-rubenstein-mpf ian-rubenstein-mpf commented Nov 5, 2019

Describe the bug
The memtemp data is running over the edge of the screen

To Reproduce
Steps to reproduce the behavior:

  1. load v1.2.1
  2. enable memtemp (vertical or horizontal)
  3. load UI

Expected behavior
Should be in the same location on screen as prior to update

Screenshots
image (2)

Environment (please complete the following information):

  • Pwnagotchi version 1.2.1
  • OS version osx, n/a
  • Type of hardware rpi0w, waveshare_213d
  • Any additional hardware used

Additional context
Add any other context about the problem here.

@Arttumiro

This comment has been minimized.

Copy link
Contributor

@Arttumiro Arttumiro commented Nov 5, 2019

According to RustyPaper on slack same happens with Inky too, once switched to waveshare_2 everything looks perfect

@srcr

This comment has been minimized.

Copy link

@srcr srcr commented Nov 8, 2019

ui

Environment
Pwnagotchi version 1.2.1
Type of hardware rpi0w, inkyphat

note
Just my 2 cents just upgraded to 1.2.1, and found the issue as described.

@charlesrocket

This comment has been minimized.

Copy link
Contributor

@charlesrocket charlesrocket commented Nov 8, 2019

Same on 1.2.1 with inkyphat-red (rpi0w), hori/vert

@charlesrocket

This comment has been minimized.

Copy link
Contributor

@charlesrocket charlesrocket commented Nov 9, 2019

@ian-rubenstein-mpf could you drop 213d from the title since its not just for waveshare case?

@ian-rubenstein-mpf ian-rubenstein-mpf changed the title The 213d does not display the memtemp data in the correct place [BUG] Some displays do not display the memtemp data in the correct place [BUG] Nov 9, 2019
@b33rANDfr13s

This comment has been minimized.

Copy link

@b33rANDfr13s b33rANDfr13s commented Nov 10, 2019

memtemp was configured on my first 60+ hours or runtime in the last week.

Also running any inky pHAT from Pimironi

I just configured auto-update today and updated to pwnagotchi v1.2.1

After updating, both horizontal and vertical memtemp displays are partially off-screen.

memtemp issue

@charlesrocket

This comment has been minimized.

Copy link
Contributor

@charlesrocket charlesrocket commented Nov 10, 2019

@b33rANDfr13s btw this might be an offtop but i think you should also blank your device names?) https://github.com/evilsocket/pwnagotchi/blob/master/pwnagotchi/plugins/default/grid.py#L12-L41 in case your device found some internet over somewhere and you forgot to turn off grid

@budd3993 budd3993 mentioned this issue Nov 10, 2019
5 of 9 tasks complete
@evilsocket evilsocket closed this Nov 15, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.