Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

[maven-release-plugin] prepare release androidannotations-2.1

  • Loading branch information...
commit 2941d8e590cf9adb90ad313010812920ea34b92e 1 parent 1a6bd4d
@pyricau pyricau authored
View
5 AndroidAnnotations/androidannotations/pom.xml
@@ -1,12 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>com.googlecode.androidannotations</groupId>
<artifactId>androidannotations-parent</artifactId>
- <version>2.1-SNAPSHOT</version>
+ <version>2.1</version>
</parent>
<groupId>com.googlecode.androidannotations</groupId>
View
167 AndroidAnnotations/functional-test-1-5/pom.xml
@@ -1,84 +1,83 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
- <modelVersion>4.0.0</modelVersion>
-
- <parent>
- <artifactId>androidannotations-parent</artifactId>
- <groupId>com.googlecode.androidannotations</groupId>
- <version>2.1-SNAPSHOT</version>
- </parent>
-
- <groupId>com.googlecode.androidannotations</groupId>
- <artifactId>functional-test-1-5</artifactId>
- <packaging>apk</packaging>
- <name>functional-test-1-5</name>
-
- <dependencies>
- <dependency>
- <groupId>com.googlecode.androidannotations</groupId>
- <artifactId>androidannotations</artifactId>
- </dependency>
- <dependency>
- <groupId>com.googlecode.androidannotations</groupId>
- <artifactId>androidannotations</artifactId>
- <classifier>api</classifier>
- </dependency>
- <dependency>
- <groupId>com.google.android</groupId>
- <artifactId>android</artifactId>
- <version>1.5_r4</version>
- <scope>provided</scope>
- </dependency>
- <dependency>
- <groupId>com.google.android</groupId>
- <artifactId>android-test</artifactId>
- <version>1.5_r4</version>
- <scope>provided</scope>
- </dependency>
- <dependency>
- <groupId>com.pivotallabs</groupId>
- <artifactId>robolectric</artifactId>
- <version>1.0-RC1</version>
- <scope>test</scope>
- </dependency>
- <dependency>
- <groupId>org.easytesting</groupId>
- <artifactId>fest-assert</artifactId>
- <version>1.4</version>
- <scope>test</scope>
- </dependency>
-
- </dependencies>
-
- <build>
- <plugins>
- <!-- TODO remove conf if default is OK -->
- <plugin>
- <groupId>com.jayway.maven.plugins.android.generation2</groupId>
- <artifactId>maven-android-plugin</artifactId>
- <version>2.8.3</version>
- <configuration>
- <androidManifestFile>${project.basedir}/AndroidManifest.xml</androidManifestFile>
- <assetsDirectory>${project.basedir}/assets</assetsDirectory>
- <resourceDirectory>${project.basedir}/res</resourceDirectory>
- <nativeLibrariesDirectory>${project.basedir}/src/main/native</nativeLibrariesDirectory>
- <sdk>
- <platform>3</platform>
- </sdk>
- <deleteConflictingFiles>true</deleteConflictingFiles>
- <undeployBeforeDeploy>true</undeployBeforeDeploy>
- </configuration>
- <extensions>true</extensions>
- </plugin>
-
- <plugin>
- <artifactId>maven-compiler-plugin</artifactId>
- <configuration>
- <source>1.6</source>
- <target>1.6</target>
- </configuration>
- </plugin>
- </plugins>
- </build>
-</project>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+
+ <parent>
+ <artifactId>androidannotations-parent</artifactId>
+ <groupId>com.googlecode.androidannotations</groupId>
+ <version>2.1</version>
+ </parent>
+
+ <groupId>com.googlecode.androidannotations</groupId>
+ <artifactId>functional-test-1-5</artifactId>
+ <packaging>apk</packaging>
+ <name>functional-test-1-5</name>
+
+ <dependencies>
+ <dependency>
+ <groupId>com.googlecode.androidannotations</groupId>
+ <artifactId>androidannotations</artifactId>
+ </dependency>
+ <dependency>
+ <groupId>com.googlecode.androidannotations</groupId>
+ <artifactId>androidannotations</artifactId>
+ <classifier>api</classifier>
+ </dependency>
+ <dependency>
+ <groupId>com.google.android</groupId>
+ <artifactId>android</artifactId>
+ <version>1.5_r4</version>
+ <scope>provided</scope>
+ </dependency>
+ <dependency>
+ <groupId>com.google.android</groupId>
+ <artifactId>android-test</artifactId>
+ <version>1.5_r4</version>
+ <scope>provided</scope>
+ </dependency>
+ <dependency>
+ <groupId>com.pivotallabs</groupId>
+ <artifactId>robolectric</artifactId>
+ <version>1.0-RC1</version>
+ <scope>test</scope>
+ </dependency>
+ <dependency>
+ <groupId>org.easytesting</groupId>
+ <artifactId>fest-assert</artifactId>
+ <version>1.4</version>
+ <scope>test</scope>
+ </dependency>
+
+ </dependencies>
+
+ <build>
+ <plugins>
+ <!-- TODO remove conf if default is OK -->
+ <plugin>
+ <groupId>com.jayway.maven.plugins.android.generation2</groupId>
+ <artifactId>maven-android-plugin</artifactId>
+ <version>2.8.3</version>
+ <configuration>
+ <androidManifestFile>${project.basedir}/AndroidManifest.xml</androidManifestFile>
+ <assetsDirectory>${project.basedir}/assets</assetsDirectory>
+ <resourceDirectory>${project.basedir}/res</resourceDirectory>
+ <nativeLibrariesDirectory>${project.basedir}/src/main/native</nativeLibrariesDirectory>
+ <sdk>
+ <platform>3</platform>
+ </sdk>
+ <deleteConflictingFiles>true</deleteConflictingFiles>
+ <undeployBeforeDeploy>true</undeployBeforeDeploy>
+ </configuration>
+ <extensions>true</extensions>
+ </plugin>
+
+ <plugin>
+ <artifactId>maven-compiler-plugin</artifactId>
+ <configuration>
+ <source>1.6</source>
+ <target>1.6</target>
+ </configuration>
+ </plugin>
+ </plugins>
+ </build>
+</project>
View
7 AndroidAnnotations/pom.xml
@@ -1,13 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
-<project
- xmlns="http://maven.apache.org/POM/4.0.0"
- xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>com.googlecode.androidannotations</groupId>
<artifactId>androidannotations-parent</artifactId>
- <version>2.1-SNAPSHOT</version>
+ <version>2.1</version>
<packaging>pom</packaging>
<name>Android Annotations Parent</name>
View
311 AndroidAnnotations/rest-api-test-1-5/pom.xml
@@ -1,156 +1,155 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
- xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
- <modelVersion>4.0.0</modelVersion>
-
- <parent>
- <artifactId>androidannotations-parent</artifactId>
- <groupId>com.googlecode.androidannotations</groupId>
- <version>2.1-SNAPSHOT</version>
- </parent>
-
- <groupId>com.googlecode.androidannotations</groupId>
- <artifactId>rest-api-test-1-5</artifactId>
- <packaging>apk</packaging>
- <name>rest-api-test-1-5</name>
-
- <properties>
- <spring-android-version>1.0.0.M2</spring-android-version>
- <jackson-version>1.7.2</jackson-version>
- <simple-version>2.4.1</simple-version>
- <android-rome-version>1.0.0-r2</android-rome-version>
- </properties>
-
- <dependencies>
- <dependency>
- <groupId>com.googlecode.androidannotations</groupId>
- <artifactId>androidannotations</artifactId>
- </dependency>
- <dependency>
- <groupId>com.googlecode.androidannotations</groupId>
- <artifactId>androidannotations</artifactId>
- <classifier>api</classifier>
- </dependency>
- <dependency>
- <groupId>com.google.android</groupId>
- <artifactId>android</artifactId>
- <version>1.5_r4</version>
- <scope>provided</scope>
- </dependency>
- <dependency>
- <groupId>com.google.android</groupId>
- <artifactId>android-test</artifactId>
- <version>1.5_r4</version>
- <scope>provided</scope>
- </dependency>
- <dependency>
- <groupId>com.pivotallabs</groupId>
- <artifactId>robolectric</artifactId>
- <version>1.0-RC1</version>
- <scope>test</scope>
- </dependency>
- <dependency>
- <groupId>org.easytesting</groupId>
- <artifactId>fest-assert</artifactId>
- <version>1.4</version>
- <scope>test</scope>
- </dependency>
- <dependency>
- <!-- spring-android-rest-template is required to use the Rest API -->
- <groupId>org.springframework.android</groupId>
- <artifactId>spring-android-rest-template</artifactId>
- <version>${spring-android-version}</version>
- </dependency>
- <dependency>
- <!-- Using Jackson for JSON marshaling -->
- <groupId>org.codehaus.jackson</groupId>
- <artifactId>jackson-mapper-asl</artifactId>
- <version>${jackson-version}</version>
- </dependency>
- <dependency>
- <!-- Using Simple for XML marshaling -->
- <groupId>org.simpleframework</groupId>
- <artifactId>simple-xml</artifactId>
- <version>${simple-version}</version>
- <exclusions>
- <exclusion>
- <artifactId>stax</artifactId>
- <groupId>stax</groupId>
- </exclusion>
- <exclusion>
- <artifactId>stax-api</artifactId>
- <groupId>stax</groupId>
- </exclusion>
- </exclusions>
- </dependency>
- <dependency>
- <!-- Using ROME for RSS and ATOM feeds -->
- <groupId>com.google.code.android-rome-feed-reader</groupId>
- <artifactId>android-rome-feed-reader</artifactId>
- <version>${android-rome-version}</version>
- </dependency>
- </dependencies>
-
- <build>
- <plugins>
- <!-- TODO remove conf if default is OK -->
- <plugin>
- <groupId>com.jayway.maven.plugins.android.generation2</groupId>
- <artifactId>maven-android-plugin</artifactId>
- <version>2.8.3</version>
- <configuration>
- <androidManifestFile>${project.basedir}/AndroidManifest.xml</androidManifestFile>
- <assetsDirectory>${project.basedir}/assets</assetsDirectory>
- <resourceDirectory>${project.basedir}/res</resourceDirectory>
- <nativeLibrariesDirectory>${project.basedir}/src/main/native</nativeLibrariesDirectory>
- <sdk>
- <platform>3</platform>
- </sdk>
- <deleteConflictingFiles>true</deleteConflictingFiles>
- <undeployBeforeDeploy>true</undeployBeforeDeploy>
- </configuration>
- <extensions>true</extensions>
- </plugin>
-
- <plugin>
- <artifactId>maven-compiler-plugin</artifactId>
- <configuration>
- <source>1.6</source>
- <target>1.6</target>
- </configuration>
- </plugin>
- </plugins>
- </build>
-
-
- <repositories>
- <!-- For developing with Android ROME Feed Reader -->
- <repository>
- <id>android-rome-feed-reader-repository</id>
- <name>Android ROME Feed Reader Repository</name>
- <url>https://android-rome-feed-reader.googlecode.com/svn/maven2/releases</url>
- </repository>
- <!-- For testing against latest Spring snapshots -->
- <repository>
- <id>org.springframework.maven.snapshot</id>
- <name>Spring Maven Snapshot Repository</name>
- <url>http://maven.springframework.org/snapshot</url>
- <releases>
- <enabled>false</enabled>
- </releases>
- <snapshots>
- <enabled>true</enabled>
- </snapshots>
- </repository>
- <!-- For developing against latest Spring milestones -->
- <repository>
- <id>org.springframework.maven.milestone</id>
- <name>Spring Maven Milestone Repository</name>
- <url>http://maven.springframework.org/milestone</url>
- <snapshots>
- <enabled>false</enabled>
- </snapshots>
- </repository>
- </repositories>
-
-</project>
+<?xml version="1.0" encoding="UTF-8"?>
+<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
+ <modelVersion>4.0.0</modelVersion>
+
+ <parent>
+ <artifactId>androidannotations-parent</artifactId>
+ <groupId>com.googlecode.androidannotations</groupId>
+ <version>2.1</version>
+ </parent>
+
+ <groupId>com.googlecode.androidannotations</groupId>
+ <artifactId>rest-api-test-1-5</artifactId>
+ <packaging>apk</packaging>
+ <name>rest-api-test-1-5</name>
+
+ <properties>
+ <spring-android-version>1.0.0.M2</spring-android-version>
+ <jackson-version>1.7.2</jackson-version>
+ <simple-version>2.4.1</simple-version>
+ <android-rome-version>1.0.0-r2</android-rome-version>
+ </properties>
+
+ <dependencies>
+ <dependency>
+ <groupId>com.googlecode.androidannotations</groupId>
+ <artifactId>androidannotations</artifactId>
+ </dependency>
+ <dependency>
+ <groupId>com.googlecode.androidannotations</groupId>
+ <artifactId>androidannotations</artifactId>
+ <classifier>api</classifier>
+ </dependency>
+ <dependency>
+ <groupId>com.google.android</groupId>
+ <artifactId>android</artifactId>
+ <version>1.5_r4</version>
+ <scope>provided</scope>
+ </dependency>
+ <dependency>
+ <groupId>com.google.android</groupId>
+ <artifactId>android-test</artifactId>
+ <version>1.5_r4</version>
+ <scope>provided</scope>
+ </dependency>
+ <dependency>
+ <groupId>com.pivotallabs</groupId>
+ <artifactId>robolectric</artifactId>
+ <version>1.0-RC1</version>
+ <scope>test</scope>
+ </dependency>
+ <dependency>
+ <groupId>org.easytesting</groupId>
+ <artifactId>fest-assert</artifactId>
+ <version>1.4</version>
+ <scope>test</scope>
+ </dependency>
+ <dependency>
+ <!-- spring-android-rest-template is required to use the Rest API -->
+ <groupId>org.springframework.android</groupId>
+ <artifactId>spring-android-rest-template</artifactId>
+ <version>${spring-android-version}</version>
+ </dependency>
+ <dependency>
+ <!-- Using Jackson for JSON marshaling -->
+ <groupId>org.codehaus.jackson</groupId>
+ <artifactId>jackson-mapper-asl</artifactId>
+ <version>${jackson-version}</version>
+ </dependency>
+ <dependency>
+ <!-- Using Simple for XML marshaling -->
+ <groupId>org.simpleframework</groupId>
+ <artifactId>simple-xml</artifactId>
+ <version>${simple-version}</version>
+ <exclusions>
+ <exclusion>
+ <artifactId>stax</artifactId>
+ <groupId>stax</groupId>
+ </exclusion>
+ <exclusion>
+ <artifactId>stax-api</artifactId>
+ <groupId>stax</groupId>
+ </exclusion>
+ </exclusions>
+ </dependency>
+ <dependency>
+ <!-- Using ROME for RSS and ATOM feeds -->
+ <groupId>com.google.code.android-rome-feed-reader</groupId>
+ <artifactId>android-rome-feed-reader</artifactId>
+ <version>${android-rome-version}</version>
+ </dependency>
+ </dependencies>
+
+ <build>
+ <plugins>
+ <!-- TODO remove conf if default is OK -->
+ <plugin>
+ <groupId>com.jayway.maven.plugins.android.generation2</groupId>
+ <artifactId>maven-android-plugin</artifactId>
+ <version>2.8.3</version>
+ <configuration>
+ <androidManifestFile>${project.basedir}/AndroidManifest.xml</androidManifestFile>
+ <assetsDirectory>${project.basedir}/assets</assetsDirectory>
+ <resourceDirectory>${project.basedir}/res</resourceDirectory>
+ <nativeLibrariesDirectory>${project.basedir}/src/main/native</nativeLibrariesDirectory>
+ <sdk>
+ <platform>3</platform>
+ </sdk>
+ <deleteConflictingFiles>true</deleteConflictingFiles>
+ <undeployBeforeDeploy>true</undeployBeforeDeploy>
+ </configuration>
+ <extensions>true</extensions>
+ </plugin>
+
+ <plugin>
+ <artifactId>maven-compiler-plugin</artifactId>
+ <configuration>
+ <source>1.6</source>
+ <target>1.6</target>
+ </configuration>
+ </plugin>
+ </plugins>
+ </build>
+
+
+ <repositories>
+ <!-- For developing with Android ROME Feed Reader -->
+ <repository>
+ <id>android-rome-feed-reader-repository</id>
+ <name>Android ROME Feed Reader Repository</name>
+ <url>https://android-rome-feed-reader.googlecode.com/svn/maven2/releases</url>
+ </repository>
+ <!-- For testing against latest Spring snapshots -->
+ <repository>
+ <id>org.springframework.maven.snapshot</id>
+ <name>Spring Maven Snapshot Repository</name>
+ <url>http://maven.springframework.org/snapshot</url>
+ <releases>
+ <enabled>false</enabled>
+ </releases>
+ <snapshots>
+ <enabled>true</enabled>
+ </snapshots>
+ </repository>
+ <!-- For developing against latest Spring milestones -->
+ <repository>
+ <id>org.springframework.maven.milestone</id>
+ <name>Spring Maven Milestone Repository</name>
+ <url>http://maven.springframework.org/milestone</url>
+ <snapshots>
+ <enabled>false</enabled>
+ </snapshots>
+ </repository>
+ </repositories>
+
+</project>
Please sign in to comment.
Something went wrong with that request. Please try again.