Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support ActiveSupport v7 #771

Merged
merged 1 commit into from Jan 11, 2022
Merged

Support ActiveSupport v7 #771

merged 1 commit into from Jan 11, 2022

Conversation

stanhu
Copy link
Contributor

@stanhu stanhu commented Jan 11, 2022

https://github.com/excon/excon/runs/4781841441 was failing:

 Excon instrumentation
    basic notification - returns ["excon.request", "excon.response"]
    uninitialized constant ActiveSupport::IsolatedExecutionState (NameError)
      /home/runner/work/excon/excon/vendor/bundle/ruby/3.0.0/gems/activesupport-7.0.1/lib/active_support/notifications.rb:268:in `registry'
      /home/runner/work/excon/excon/vendor/bundle/ruby/3.0.0/gems/activesupport-7.0.1/lib/active_support/notifications.rb:263:in `instrumenter'
      /home/runner/work/excon/excon/vendor/bundle/ruby/3.0.0/gems/activesupport-7.0.1/lib/active_support/notifications.rb:206:in `instrument'

As rails/rails#43852 explains, we can just
require active_support and this will auto-load the correct constants.

https://github.com/excon/excon/runs/4781841441 was failing:

```
 Excon instrumentation
    basic notification - returns ["excon.request", "excon.response"]
    uninitialized constant ActiveSupport::IsolatedExecutionState (NameError)
      /home/runner/work/excon/excon/vendor/bundle/ruby/3.0.0/gems/activesupport-7.0.1/lib/active_support/notifications.rb:268:in `registry'
      /home/runner/work/excon/excon/vendor/bundle/ruby/3.0.0/gems/activesupport-7.0.1/lib/active_support/notifications.rb:263:in `instrumenter'
      /home/runner/work/excon/excon/vendor/bundle/ruby/3.0.0/gems/activesupport-7.0.1/lib/active_support/notifications.rb:206:in `instrument'
```

As rails/rails#43852 explains, we can just
`require active_support` and this will auto-load the correct constants.
geemus
geemus approved these changes Jan 11, 2022
Copy link
Contributor

@geemus geemus left a comment

Looks good, thanks for tracking that down and helping us with a fix!

@geemus geemus merged commit 44cf104 into excon:master Jan 11, 2022
6 checks passed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants