Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot get GCM token for device #2073

Open
KthProg opened this issue Aug 4, 2018 · 8 comments

Comments

Projects
None yet
7 participants
@KthProg
Copy link

commented Aug 4, 2018

Environment

ExpoKit, running on Android, LG Stylo 3+

Steps to Reproduce

  1. Call await Notifications.getExpoPushTokenAsync();
  2. Receive error

Expected Behavior

  1. Call Notifications.getExpoPushTokenAsync();
  2. Receive token

Actual Behavior

I get this error.
screenshot_2018-08-04-16-56-33

Reproducible Demo

I can't reproduce this issue in a demo. This happens every single time in my app, however. The first few calls to get the token seemed to work fine. Is this maybe some issue when you have already requested the Expo push token for that device?

@KthProg

This comment has been minimized.

@KthProg

This comment has been minimized.

Copy link
Author

commented Aug 4, 2018

Adding FCM details and using exp start appears to have fixed the issue.

@picklechips

This comment has been minimized.

Copy link

commented Aug 6, 2018

I started getting this error within the last couple of days, running with exp start instead of npm start fixed the problem 😄

@LouisJS

This comment has been minimized.

Copy link

commented Sep 3, 2018

Using exp start instead of npm start also did the trick for me. But why is that ?
Will there be any impact on my final build ?

@salihkiraz

This comment has been minimized.

Copy link
Contributor

commented Nov 13, 2018

Make sure you're logged Expo. I improved when I logged in again.

exp login

@fadilnatakusumah

This comment has been minimized.

Copy link

commented Feb 8, 2019

same with @salihkiraz login fix the issue

@VM8198

This comment has been minimized.

Copy link

commented Mar 5, 2019

run expo login
login with your credentials and it will work fine...

@Raj1998

This comment has been minimized.

Copy link

commented Apr 19, 2019

Make sure you're logged Expo. I improved when I logged in again.

exp login

thanks a lot... !!!!!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.