Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error: AnimatedRegion could not obtain AnimatedWithChildren base class #4601

Closed
drfenixion opened this issue Jun 13, 2019 · 4 comments
Closed

Error: AnimatedRegion could not obtain AnimatedWithChildren base class #4601

drfenixion opened this issue Jun 13, 2019 · 4 comments
Labels

Comments

@drfenixion
Copy link

@drfenixion drfenixion commented Jun 13, 2019

馃悰 Bug Report

When app starts get the error - "AnimatedRegion could not obtain AnimatedWithChildren base class

  • node_modules/expo/build/logs/LogSerialization.js:148:4 in w
  • node_modules/expo/build/logs/LogSerialization.js:41:24 in
  • node_modules/regenerator-runtime/runtime.js:45:44 in p
  • node_modules/regenerator-runtime/runtime.js:271:30 in
  • node_modules/regenerator-runtime/runtime.js:45:44 in p
  • node_modules/regenerator-runtime/runtime.js:135:28 in n
  • node_modules/regenerator-runtime/runtime.js:170:17 in
  • node_modules/promise/setimmediate/core.js:45:7 in c
    "

Environment

Expo CLI 2.19.5 environment info:
System:
OS: Linux 4.15 Ubuntu 16.04.5 LTS (Xenial Xerus)
Shell: 4.3.48 - /bin/bash
Binaries:
Node: 11.6.0 - ~/.nvm/versions/node/v11.6.0/bin/node
Yarn: 1.16.0 - /usr/bin/yarn
npm: 6.9.0 - ~/.nvm/versions/node/v11.6.0/bin/npm
npmPackages:
expo: ^32.0.0 => 32.0.6
react: 16.5.0 => 16.5.0
react-native: https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz => 0.57.1
react-navigation: ^3.0.9 => 3.11.0
npmGlobalPackages:
expo-cli: 2.19.5

Android

Steps to Reproduce

Update to Expo 2.11.2 from the previous version and started getting this error.

Actual Behavior

The app works as previously but getting the error. The app works fine if skip error.

I did

remove node_modules
remove package-lock.json
npm install
yarn install (just trying another dependency system, without profit)

Other info

Here I see same issue react-native-community/react-native-maps#1303
And answer with likes:

got the same problem only when i enable "JS minify" in "dev settings" when i shake the smartphone.
un check it solve the error showing

How can I do it with Expo?

@drfenixion drfenixion added the bug label Jun 13, 2019
@cruzach

This comment has been minimized.

Copy link
Contributor

@cruzach cruzach commented Jun 14, 2019

You can turn the minify flag on/off by passing either the --minify or --no-minify flags to expo start, respectively. (source)

Let me know if that ends up working!

@drfenixion

This comment has been minimized.

Copy link
Author

@drfenixion drfenixion commented Jun 14, 2019

Yes, it works. If expo start --no-minify app works without error. With --minify get the error.

@cruzach

This comment has been minimized.

Copy link
Contributor

@cruzach cruzach commented Jun 18, 2019

Since it seems like this is an issue (only with minified code) that is due to the react-native-maps library, I'm going to close here.

(Seems like using yarn instead of npm fixes it though)

@cruzach cruzach closed this Jun 18, 2019
@drfenixion

This comment has been minimized.

Copy link
Author

@drfenixion drfenixion commented Jun 19, 2019

Yarn not fix it for me

@lock lock bot added the outdated label Dec 16, 2019
@lock lock bot locked and limited conversation to collaborators Dec 16, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
2 participants
You can鈥檛 perform that action at this time.