Skip to content
Branch: master
Find file History
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
..
Failed to load latest commit information.
android
build
ios
src
.eslintrc.js
.npmignore
README.md
babel.config.js
package.json
tsconfig.json
unimodule.json

README.md

expo-gl

Provides GLView that acts as OpenGL ES render target and gives GL context object implementing WebGL 2.0 specification.

API documentation

Installation in managed Expo projects

For managed managed Expo projects, please follow the installation instructions in the API documentation for the latest stable release. If you follow the link and there is no documentation available then this library is not yet usable within managed projects — it is likely to be included in an upcoming Expo SDK release.

Installation in bare React Native projects

For bare React Native projects, you must ensure that you have installed and configured the react-native-unimodules package before continuing.

Install expo-gl-cpp

expo-gl requires that you also install and configure expo-gl-cpp.

Add the package to your npm dependencies

expo install expo-gl

Compatibility

To use expo-gl with React Native 0.58.0 or newer you will need to use 5.x.x version of expo-gl and at least 0.4.0 of react-native-unimodules. Here is the table showing compatibility between these three packages:

expo-gl react-native-unimodules react-native
<=4.x.x 0.3.x <=0.57.x
>=5.0.0 >=0.4.0 *

Configure for iOS

Run pod install in the ios directory after installing the npm package.

Configure for Android

No additional set up necessary.

Contributing

Contributions are very welcome! Please refer to guidelines described in the contributing guide.

You can’t perform that action at this time.