Require "zlib" but doesn't advertise dependency #1204

Closed
strk opened this Issue Jul 3, 2012 · 3 comments

Comments

Projects
None yet
2 participants
Contributor

strk commented Jul 3, 2012

I'm using express-2.4.3 from Windshaft using node-0.4.10 but a regression test in Windshaft fails with:

Error: Cannot find module 'zlib'
    at Function._resolveFilename (module.js:317:11)
    at Function._load (module.js:262:25)
    at require (module.js:346:19)
    at Object.<anonymous> (/usr/src/node/node_modules/Windshaft/node_modules/express/node_modules/connect/lib/middleware/compress.js:14:12)

connect is 1.9.1 -- maybe I should file this ticket in connect

Contributor

strk commented Jul 3, 2012

The "connect" dependency encoded in "express" is ">= 1.5.2 < 2.0.0",

Contributor

strk commented Jul 3, 2012

Sounds like senchalabs/connect#613 -- could the dependency made to include != 1.9.1 ?

Member

jonathanong commented Sep 7, 2013

this was added in node v0.8 (i think)

@jonathanong jonathanong closed this Sep 7, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment