Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

EZP-29938: PostgreSQL #553

Merged
merged 5 commits into from Mar 14, 2019

Conversation

4 participants
@DominikaK
Copy link
Contributor

commented Mar 13, 2019

Question Answer
JIRA Ticket https://jira.ez.no/browse/EZP-29938
Versions master (2.5)
Show resolved Hide resolved docs/cookbook/using_postgresql.md Outdated
Update docs/cookbook/using_postgresql.md
Co-Authored-By: DominikaK <dominika.kurek@ez.no>
@michalmilc90
Copy link
Contributor

left a comment

Well done! 😊

@alongosz
Copy link
Member

left a comment

Looks good.

Show resolved Hide resolved docs/cookbook/using_postgresql.md Outdated

To use PostgreSQL, you need to have the `php_pgsql` PHP extension installed.

If it is not enabled yet, enable `EzSystems\DoctrineSchemaBundle\DoctrineSchemaBundle()` in `AppKernel.php`.

This comment has been minimized.

Copy link
@alongosz

alongosz Mar 13, 2019

Member

If it's not enabled user/developer might also be missing ezsystems/doctrine-dbal-schema composer package, can be installed by composer require ezsystems/doctrine-dbal-schema. However if the bundle is enabled, package rather exists, so not sure how to word it ;)

If you use PostgreSQL, two parameters need to be set differently than when using MySQL:

- `env(DATABASE_DRIVER)` must be set to `pdo_pgsql` instead of the default `pdo_mysql`
- `env(DATABASE_CHARSET)` must be set to `utf8`, because PostgreSQL does not support the default value of `utf8mb4`.

This comment has been minimized.

Copy link
@alongosz

alongosz Mar 13, 2019

Member

I'd avoid here "does not support" as it might suggest that features delivered in MySQL utf8mb4 are not supported in PostgreSQL.
Let's rather say something like "because the default value of utf8mb4 is MySQL-specific". Or something like that ;)

Show resolved Hide resolved docs/releases/updating_ez_platform.md Outdated

alongosz and others added some commits Mar 14, 2019

Apply suggestions from code review
Co-Authored-By: DominikaK <dominika.kurek@ez.no>
Show resolved Hide resolved docs/cookbook/using_postgresql.md Outdated
Update docs/cookbook/using_postgresql.md
Co-Authored-By: DominikaK <dominika.kurek@ez.no>

@DominikaK DominikaK merged commit 77a0398 into master Mar 14, 2019

@DominikaK DominikaK deleted the postgres branch Mar 14, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.