Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update version of org.reflections:reflections #248

Merged

Conversation

@vbrandl
Copy link

commented Mar 13, 2019

reflections:0.9.10 depends on guava 18, which contains a denial of
service vulnerability:

reflections:0.9.11 depends on guava 20
(https://github.com/ronmamo/reflections/blob/master/pom.xml#L55) which
does not contain the mentioned vulnerability and is still Java 7
compatible (https://github.com/google/guava/wiki/Release21#java-8)

Valentin Brandl
`reflections:0.9.10` depends on guava 18, which contains a denial of
service vulnerability:

* http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-10237

`reflections:0.9.11 ` depends on guava 20
(https://github.com/ronmamo/reflections/blob/master/pom.xml#L55) which
does not contain the mentioned vulnerability and is still Java 7
compatible (https://github.com/google/guava/wiki/Release21#java-8)
@fabiomaffioletti fabiomaffioletti merged commit 098c764 into fabiomaffioletti:master Mar 20, 2019
1 check passed
1 check passed
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@fabiomaffioletti

This comment has been minimized.

Copy link
Owner

commented Mar 20, 2019

Merged and released. It'll be available on Maven central in the next hours. Thank you very much @vbrandl !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.