Permalink
Browse files

Make dev-Paramiko requirement for dev-Fab super explicit

  • Loading branch information...
1 parent f2db8fd commit 12b9fe769e11ff9f5a0d1f72ca6bda944ea932ee @bitprophet bitprophet committed Jan 3, 2013
Showing with 15 additions and 1 deletion.
  1. +6 −0 docs/index.rst
  2. +9 −1 docs/installation.rst
View
@@ -24,6 +24,12 @@ However, if you want to live on the edge, you can pull down the source code
from our Git repository, or fork us on Github. The :doc:`installation` page has
details for how to access the source code.
+.. warning::
+
+ If you install Fabric from Git, you will need to install its dependency
+ Paramiko from Git as well. See :doc:`the installation docs <installation>`
+ for details.
+
Development
===========
View
@@ -15,14 +15,22 @@ typically called ``fabric`` or ``python-fabric``. E.g.::
$ sudo apt-get install fabric
Advanced users wanting to install a development version may use ``pip`` to grab
-the latest master branch::
+the latest master branch (as well as the dev version of the Paramiko
+dependency)::
+ $ pip install paramiko==dev
$ pip install fabric==dev
Or, to install an editable version for debugging/hacking, execute ``pip install
-e .`` (or ``python setup.py install``) inside a :ref:`downloaded <downloads>`
or :ref:`cloned <source-code-checkouts>` copy of the source code.
+.. warning::
+
+ Any development installs of Fabric (whether via ``==dev`` or ``install
+ -e``) require the development version of Paramiko to be installed
+ beforehand, or Fabric's installation may fail.
+
Dependencies
============

0 comments on commit 12b9fe7

Please sign in to comment.